Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bedingtes Kopieren eines Zellbereichs
#1
Hallo zusammen,

Ich möchte ganz ohne Makros folgendes erreichen. Erst einmal nur innerhalb desselben Tabellenblatts:

Wenn in einer Zelle ein bestimmter Wert steht, sollen die Inhalte eines Zellbereichs von einer Stelle des Blatts in einen gleichgroßen Platz an anderer Stelle kopiert werden. Wirklich als 1:1 Kopie inkl. Formeln und bedingten Formatierungen, Farben, Rahmen etc. des Quellzellbereichs. Es geht um die Übertragung einer Formatvorlage aus mehren Zellen in einen bestimmten Zielbereich.

Ich habe versucht, Ziel- und Quellzellenbereich einen Namen zu geben:
Ziel ist C2:E4, Name: "ZZB"
Quelle ist G2:I4, Name: "QZB"
Die Bedingung soll in Zelle A1 erfüllt sein. Wenn der Wert dort = 1, dann soll eben wie beschrieben kopiert werden.

=WENN(A1="1";ZZB=QZB;"falsch")

Letzten Endes gibt es natürlich mehrere mögliche QZBs, die, je nachdem, was in A1 steht, in den ZZB kopiert werden sollen. Eben die Nutzung verschiedener Formate je nachdem, was in steht.

Die Formel oben geht nicht. Ich bekomme die Ausgabe #WERT!, wenn die Bedingung erfüllt ist. Wenn nicht, steht "falsch" drin.

Hat jemand eine Idee? Danke!
Antwortento top
#2
Hi,

warum erstellst du nicht eine richtige Vorlagendatei (.xltx)?
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallöchen,

also, eine Formel kopiert nicht irgendwo im Blatt Daten von einer Stelle zur andren und gleich gar keine Formeln, mal abgesehen von einfachen Konstrukten die man mit der Excel4Macro - Funktion AUSWERTEN berechnen könnte. Das würde man aber auch nicht in der gleichen Zelle tun, würde hier also auch nicht passen.

Um ohne Makros auszukommen müsstest Du für die beiden Fälle 1 oder <> 1 zwei unterschiedliche Vorlagen erstellen.

Alternativ kannst Du die Formel bzw. die Ergebnisse in Deine WENN einbauen, z.B. Übernahme der Werte aus C2 (erste Zelle von ZZB) in G2

=WENN(A1="1";index(ZZB;1;1);"falsch")
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste