Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bedingte Formatierung - Symbolsatz wird nur kurz angezeigt
#1
Lightbulb 
Hallo allerseits,

ich habe aktuell ein etwas komisches Problem.

Ich habe in AE2:AE9999 als mögliche Einträge entweder "Geschlossen" oder "Offen" stehen. Für diese beiden Einträge möchte ich nun in der zugehörigen Zelle AF2:AF9999 über Bedingte Formatierung einen Symbolsatz einfügen, der für "Geschlossen" eine grüne Ampel / einen grünen Haken anzeigt und für "Offen" entsprechend einen gelben haken oder eine gelbe Ampel. Zusätzlich soll in AF2:AF9999 gar nichts angezeigt werden, solange in AE2:AE9999 weder "Geschlossen" noch "Offen" steht. 

Men erster Versuch war, als Bedingung für den Symbolsatz Formeln zu verwenden. Also beispielsweise für grün =WENN (AE2="Geschlossen") und für gelb=WENN(AE2="Offen").
Das bringt zwar keine Fehlermeldung, aber leider auch keinen Symbolsatz. Es tut sich genau genommen gar nichts. 

Daraufhin habe ich in AF2:AF9999 folgende Formel eingesetzt: =WENN(AE2="Offen";"!";WENN(AE2="Geschlossen";"2";"")), um somit den Symbolsatz über das Auswahlkriterium "Zahl" anzusteuern. 

[img]
Dateiupload bitte im Forum! So geht es: Klick mich!
]

Ergebnis: Der Wille war ersichtlich, der Symbolsatz aber leider noch immer nicht. Wenn man in AE2:AE9999 eine entsprechende Eingabe macht, wird für einen kurzen Moment das zugehörige Symbol angezeigt. Aber es verschwindet dann sofort wieder. 

Kann mir bitte jemand sagen, wo hier der Fehler liegt ? Warum der Symbolsatz nicht korrekt angezeigt wird ? Vielleicht denke ich ja auch zu kompliziert und es gibt eine einfachere Lösung ? Ich bin auf jeden Fall dankbar für Tipps und Lösungen  Huh

Nachtrag: Das Bild sollte eigentlich einen Screenshot der gewählten Regeln für die Bedingte Formatierung darstellen. Ich hab jetzt gelernt, daß das hier nicht erwünscht ist. Aber ich krieg es auch nicht mehr heraus gelöscht im Beitrag. Also nicht ärgern bitte  Angel
Wer Schreibfehler findet, darf diese behalten.
Antworten Top
#2
Hi,

nimm doch einfach eine bed.Form mit Symbolsätzen statt einer Formel. Lass dir nur das Symbol anzeigen (entsprechenden Haken setzen). Jetzt schreibst du in die Zelle eine Formel wie =WENN(A1="Offen";1;Wenn(A1="Geschlossen";2;"")) auf diese Werte (1/2/"") reagierst du mit den entsprechenden Symbolen.
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top
#3
Hi,

Danke für Deine Antwort. Im Prinzip hatte  ich das als meinen zweiten Versuch gemacht....allerdings ohne Erfolg bzw. es wurde dann zwar das Ergebnis der Formel in der Zelle (1,2,"") angezeigt, aber die bedingte Formatierung hatte nicht gegriffen bzw. es kamen keine Symbole. Jetzt hab ich alles nochmals heraus gelöscht, wieder eingegeben...jetzt geht's ?‍♀️?‍♀️

Keine Ahnung wieso...aber Hauptsache, es geht jetzt.

Vielen Dank für Deine Unterstützung. ??
Wer Schreibfehler findet, darf diese behalten.
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste