Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auto ausfüllen
#1
Hallo allerseits,

ich bin neu hier und Excel Einsteiger...

Ich habe folgendes Problem:
wenn ich z.B. in Zelle A1 - 5 eintrage soll der Text aus Zelle B1 5 mal kopiert und in B2-B6 eingefügt werden.
Ändere ich den Wert in A1 z.B. auf 6 dann soll der Wert aus Zelle B1 6 mal kopiert und eingefügt werden...

Super wäre eine Lösung ohne VBA - ich bin ja Anfänger  Angel

Gruß

Anla
Antwortento top
#2
Hi Anla,


das in B2 einfügen und runterziehen:

=WENN(ZEILE()-2>=$A$1;"";$B$1)

LG
Alexandra
Antwortento top
#3
Hallo,

mal sehen, was unsere Formelmenschen darüber denken, aber ich fürchte

Zitat:Super wäre eine Lösung ohne VBA - ich bin ja Anfänger  [img]Dateiupload bitte im Forum - wie's geht: http://www.clever-excel-forum.de/thread-326.html .]

diesen Wunsch wirst Du begraben müssen.
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
Antwortento top
#4
Hallo, ich würde das sicher mit Power Query machen, weil es auch bestimmt nicht so einfach ist... Auch einfach so ohne Überschrift(en)... geht es aber mit Formelvorrat..:

Arbeitsblatt mit dem Namen 'Blatt2'
AB
15Müller
2Müller
3Müller
4Müller
5Müller
6

ZelleFormel
B2=WENN(ZEILE(A1)<A$1;B1;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Edith..: Zuschhhhhp.... (^_-)
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Smile 
Hallo Alexandra,

funktioniert grundsätzlich super...allerdings kommt der Text aus B1 noch dazu und so sind es 6 statt 5...???

Kann man doch bestimmt ändern oder  Huh
Antwortento top
#6
(03.04.2019, 18:59)anla schrieb: Hallo ,

funktioniert grundsätzlich super... allerdings ...

Hallo, wenn du die Idee dahinter verstehst, kannst du das selber ändern!?!?! 

Wenn in B2 =ZEILE()-2 steht; was kommt denn da raus..?

Oder meinen Vorschlag probieren...!?!?!
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Hi,

da Alexandra gerade offline ist, mal meine Antwort. Das war deine Vorgabe:


Zitat:wenn ich z.B. in Zelle A1 - 5 eintrage soll der Text aus Zelle B1 5 mal kopiert und in B2-B6 eingefügt werden.

Und genau das macht Alexandras Formel. Es wird unterhalb deines Originaltextes 5x die Kopie eingefügt. Wenn ich alle zusammenzähle, komme ich auf sechs.

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
15Text
2Text
3Text
4Text
5Text
6Text

ZelleFormel
B2=WENN(ZEILE()-2>=$A$1;"";$B$1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#8
... gelöscht
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#9
Hi Anla,

wie Günter schon geschrieben hat, gefordert hast du ja was anderes!Smile

Aber egal:

=WENN(ZEILE()-1>=$A$1;"";$B$1)

LG
Alexandra
Antwortento top
#10
Hi Alexandra,

sorry, da hatte ich mich falsch ausgedrückt...so ist´s gut aber ab 7 ist wieder "einer" zu viel... 17

Bin euch wirklich dankbar...Anfänger halt

Nette Grüße
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste