Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auswertung von Abverkaufslisten
#1
Hallo Ihr Lieben,
ich habe wieder eine neue Tabelle bei der monatlich die "extremsten" positiven Ausreißer bis dato per Hand abgeschrieben wurden.

Vielleicht geht das ja auch automatisch:

Vorgaben:
Wenn die Veränderung (Spalte D) über 5% plus oder minus ist und zusätzlich der Anteil (Spalte E) größer 2% ist, soll die entsprechende Zeile mit den Inhalten von Spalte A bis E (in diesem Beispiel ab Zeile 17) aufgelistet werden.

Das gleiche auch wenn die Veränderung (Spalte D) über 10% plus oder minus ist und zusätzlich der Anteil (Spalte E) kleiner 2% ist, soll die entsprechende Zeile mit den Inhalten von Spalte A bis E (in diesem Beispiel ab Zeile 17) aufgelistet werden.

Da es über 200 Warenbereiche in der originalen Tabelle sind. Und in manchen Monaten 10 und in manch anderen 50 "Extreme" aufgelistet werden müssen. Wäre es von Vorteil wenn Sie chronologisch aus der Haupttabelle untereinander auftauchen ohne viele Leerzeilen.

Freue mich auf eure Hilfe.
Vorab schon wieder vielen Dank

Gruß Max


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 10,94 KB / Downloads: 5)
Antwortento top
#2
Hallo Max,

hier eine mögliche Formel zur Ermittlung der gesuchten Zeilen:
Code:
=WENNFEHLER(AGGREGAT(15;6;ZEILE($A$5:$A$14)/((($D$5:$D$14*$D$5:$D$14>0,10001^2)*($E$5:$E$14<0,019999)+($D$5:$D$14*$D$5:$D$14>0,05001^2)*($E$5:$E$14>0,02001))>0);ZEILE(G1));"")


und in der Anlage die Beispieldatei.


Angehängte Dateien
.xlsx   test-19.xlsx (Größe: 12,07 KB / Downloads: 1)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste