Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auswertung mit Wert in 'rechter' Zelle
#1
Hallo an alle,

ich scheitere mal wieder an den einfachsten Aufgaben.
In meiner Datei will ich eine Auswertung in Spalte I haben, also die Differenz zur Vorgabe-Spalte D.
Es soll immer der Wert am weitesten rechts zur Auswertung genutzt werden.
Ich will das ganze aber nicht mit einer festen Zahl machen, da es wahrscheinlich passiert dass in der laufenden Prüfung noch mehr Spalten eingefügt werden.


.xlsx   Mappe1.xlsx (Größe: 12,89 KB / Downloads: 7)

Egal was ich jetzt probiert habe, hatte ich entweder eine Fehlermeldung oder es hat den Wert in Spalte H nicht anerkannt.
Könnt ihr mir bitte helfen?

Danke Smile
Antwortento top
#2
Hallo,

ich versehe wieder nicht richtig. Wozu brauchst Du den Verweis, wenn Du nur eine Summe errechnen möchtest?

Kons

ABCDEFGHI
4
5VORGABELAUFENDE PRÜFUNGDIFFERENZ
6KundeAuftragsnr.10.02.2020
7ABNN4949120 h187,0 h-67,0 h
8CDOO11590 h12,0 h11,0 h7,0 h5,0 h578,0 h
9EFPP250 h12,0 h238,0 h
10ABQQ400 h400,0 h
11CD171.200 h644,5 h555,5 h
12EF250 h250,0 h
13AB900 h900,0 h
14CD900 h
15EF1.200 h
16AB350 h
17
18
19
20
Formeln der Tabelle
ZelleFormel
E6=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!G9>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!G9;"")
F6=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!H9>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!H9;"")
G6=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!I9>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!I9;"")
H6=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!J9>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!J9;"")
F7=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!H13>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!H13;"")
G7=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!I13>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!I13;"")
H7=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!J13>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49047'!J13;"")
I7=WENNFEHLER(D7-(E7:H7);"")
I8=WENNFEHLER(D8-(E8:H8);"")
I9=WENNFEHLER(D9-(E9:H9);"")
I10=WENNFEHLER(D10-(E10:H10);"")
F11=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49048'!H13>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49048'!H13;"")
G11=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49048'!I13>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49048'!I13;"")
H11=WENN('X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49048'!J13>0;'X:\91_Arbeitsordner\Infor\Lenkungskreis\Nachkalkulation\[20200206_laufende Kalkulation_AH_Makro.xlsm]49048'!J13;"")
I11=WENNFEHLER(D11-(E11:H11);"")
I12=WENNFEHLER(D12-(E12:H12);"")
I13=WENNFEHLER(D13-(E13:H13);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#3
Hi AnnAnn,

verschiebe deine Differenzspalte neben die Spalte Vorgabe und nimm einfach die Summenformel
Code:
=D7-SUMME(F7:AA7)
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
In Zeile 8 habe ich die Werte aus Testzwecken eingetragen, aber leider falsch.
Ich ziehe die Werte aus einer anderen Tabelle und in dieser werden bereits die aktuellen Werte aufaddiert. Also kann ich wirklich nur den Wert ganz rechts nehmen, da sonst alles doppelt wäre.

Ich habe einige verschiedene Varianten in der Differenz Spalte probiert, aber hatte bei den leeren aktuellen Spalten immer eine Fehlermeldung.

Die Idee die Differenzspalte neben die Vorgabe zu machen finde ich gut, nur das mit der Summe würde leider nicht klappen.

Danke euch  22
Antwortento top
#5
Hallo,

ich verstehe dich wirklich nicht (die anderen aber scheinbar auch nicht) ... Wenn es nur um die Fehlermeldungen geht ...

Kons

ABCDEFGHI
5VORGABELAUFENDE PRÜFUNGDIFFERENZ
6KundeAuftragsnr.10.02.2020
7ABNN4949120 h187,0 h-67,0 h
8CDOO11590 h12,0 h11,0 h7,0 h5,0 h585,0 h
9EFPP250 h12,0 h238,0 h
10ABQQ400 h0,0 h
11CD171.200 h644,5 h555,5 h
12EF250 h0,0 h
13AB900 h0,0 h
14CD900 h
15EF1.200 h
16AB350 h
Formeln der Tabelle
ZelleFormel
I7=WENNFEHLER(D7-VERWEIS(2;1/(E7:H7<>"");E7:H7);0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#6
Ich kann es scheinbar wirklich überhaupt nicht erklären, das tut mir leid.

Aber mit kleinen Änderungen hat es jetzt glücklicherweise geklappt. Dankeschön!
Antwortento top
#7
Hallo AnnAnn,

da arbeiten wir einfach dran. Ich sage ja, vielleicht verstehe ich es auch nur nicht. Schön, dass du aber eine Lösung gefunden hast. Würde mich interessieren.

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#8
Ich habe mich dann für deine Formel 
=WENNFEHLER(D7-VERWEIS(2;1/(E7:H7<>"");E7:H7);0) 
entschieden. Nur mit dem kleinen Unterschied, dass ich die noch verfügbaren Stunden sehen wollte. (Also ...;D7)
Das hatte ich euch gegenüber bloß leider nicht deutlich gemacht.

Dank euch ist es jetzt wirklich schick Smile
[-] Folgende(r) 1 Benutzer sagt Danke an AnnAnn für diesen Beitrag:
  • marose67
Antwortento top
#9
Hallo AnnAnn,

Danke für die Info.

Weiterhin viel Spaß mit Excel.

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste