Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auswertung einer HighScore Liste
#1
Hallo Zusammen,

ich verzweifel an meiner Excel Tabelle und benötige dringend ein paar Tipps bzw. Hilfe.

Ich habe eine HighScore Liste welche nach an verschiedenen Tagen herangezogen wird. Diese sieht etwa wie folgt aus:

Code:
1. Tabelle Datum 01.01.2020                                          2. Tabelle Datum      15.01.2020

Rangnr      Name       Punkte                                         Rangnr.        Name             Punkte                            
1           AAA         250                                           1              AAB              370
2           AAB         210                                           2              AAD              365
3           AAC         200                                           3              AAA              250
4           AAD         180                                           4              AAC              230
                                                                      5              AAF              200
Die Rangordnung spielt dabei keine Rolle. Die Teilnehmer können vom 01.01 zum 15.01. entwender nur gleichbleibende Punkte erreicht haben oder mehr (daher gibt es entweder eine positive Veränderung der Punkte oder eine gleichbleibende Punktzahl). Desweiteren können zum 15.01. auch weitere Teilnehmer dazugekommen sein.

Diese beiden Tabellen sollen nun zum Tag (15.01) ausgewertet und bewertet werden.
Wie hoch sind die Differenz der einzelenen Spieler vom 01.01. zum 15.01. bzw "Keine Veränderung" ?

Ich habe es mit folgenden Funktionen versucht:
=WENN(ZÄHLENWENN(Spalte$Name;A$AA);WENN(370=250;"Keine Veränderung";370-250))
=WENN(VERGLEICH(A$AA;Spalte$Name);WENN(370=250;"Keine Veränderung";(370-250)))
=ZÄHLENWENN(Spalte$Name;A$AA)+WENN(370=250;"''Keine Veränderung";370-250)

Keiner diese Wege kommt zu der richtigen Lösung meines Problems. Die Berechnung der Differenz wird immer in der 1:1 Zeile durchgeführt (Bsp. 01.01. Nr. 2 AAB zu 15.01. Nr. 2 AAD) und nicht aufgrund des dazugehörigen Namens. Für mein Verständnis muss daher der Name verglichen werden, dann eine Veränderung der Punktzahl und die Ausgabe "Keine Veränderung" oder die tatsächliche Differenz der Punktzahl.

Ich hoffe ich konnte mein Problem hier verdeutlichen und freue mich über hilfreiche Tipps.

Vielen Dank im Voraus  17
Antwortento top
#2
Moin

Ohne Formeln. Als Pivot.
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGH
1DatumRangNamePunkteSumme von PunkteDatum
201.01.20201Peter250Name01.01.202015.01.2020
301.01.20202Max210Ernst200
401.01.20203Fritz200Fritz30
501.01.20204Hans100Hans265
615.01.20201Max370Max160
715.01.20202Hans365Peter0
815.01.20203Peter250
915.01.20204Fritz230
1015.01.20205Ernst200
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallo gstar,

du kannst die beiden Tabellen z.B. mit dem SVERWEIS abgleichen.
Bezogen auf deine Beispielwerte könnte das dann z.B. so aussehen:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGH
1Tabelle1 Datum 01.01.2020Tabelle2 Datum 15.01.2020
2RangNamePunkteRangNamePunkteVeränderung
31AAA2501AAB370160
42AAB2102AAD365185
53AAC2003AAA250keine Veräderung
64AAD1804AAC23030
75AAF200NEU

ZelleFormel
H3=WENNFEHLER(WENN(G3=SVERWEIS(F3;$B$3:$C$6;2;0);"keine Veräderung";G3-SVERWEIS(F3;$B$3:$C$6;2;0));"NEU")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß
Fred
Antwortento top
#4
Hey,
linke Pivot kumulierte Werte nach Datum
rechte Pivot absolute Zahlen.

Evtl hilft es Dir


Angehängte Dateien
.xlsx   Highscore.xlsx (Größe: 13,27 KB / Downloads: 2)
Antwortento top
#5
Ich glaube der Fragesteller ist auf Tauchstation.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#6
Guten Abend,

sorry für die späte Antwort ich war ein wenig beschäfigt die letzten Tage.
Vielen dank für die Tipps. Werde es mal probieren und mich dann die Tage zurückmelden ob es funktioniert hatte.
Antwortento top
#7
Guten abend,

ich habe es jetzt gelöst.
Mit:

=INDEX(Aktuell!$B$1:$E$500;VERGLEICH(A13;Aktuell!$B$1:$B$500;0);4)
=INDEX(AlteListe!$B$1:$E$500;VERGLEICH(A13;AlteListe!$B$1:$B$500;0);4)
und Als Ausgabe
=WENN(H13<0;"X";"X")

vielen dank euch für die Hilfe.
Antwortento top
#8
(14.06.2020, 22:08)gstar1404 schrieb: Guten abend,

ich habe es jetzt gelöst.
...
=WENN(H13<0;"X";"X")
...

Wow... Die Formel muss ich mir aber sowas von sichern. Wie kommt man auf sowas ..? holy shit...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#9
(15.06.2020, 01:10)Jockel schrieb: Wow... Die Formel muss ich mir aber sowas von sichern. Wie kommt man auf sowas ..? holy shit...

Guten Abend,

danke genau wegen Leuten wie Sie möchte man schon gar nicht solche Fragen stellen. 
unfassbar  Angry
Antwortento top
#10
Hola,

sorry, dann eine einfache Gegenfrage.
Wenn H13 < 0 ist soll X ausgegeben werden, ansonsten (also wenn H13 >=0 ist) auch X. 
Welche Logik steckt denn dahinter? Egal wie das Ergebnis ist, es kommt X heraus.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste