Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auswahl aus Dropdownlist nur einmal
#1
Hallo zusammen.
Ich versuche mich gerade für die Firma eine Einteilungstafel zu bauen. Dort sollen die Baustellen den Mitarbeitern zugeordnet werden.
Jetzt habe ich bereits Listen mit den Mitarbeitern erstellt. Auf einem anderen Tabellenblatt möchte ich dann den MA über eine Dropdownliste auswählen. Sobald dieser ausgewählt ist soll er aber nicht mehr in der Dropdownliste erscheinen um ihn nicht zwei mal auszuwählen.
Habe die test datei mal mit angehängt

vieleicht kann mir jemand helfen

Danke

Sven
.xls   Einteilung Lösung.xls (Größe: 43 KB / Downloads: 8)
Antwortento top
#2
Hi Sven,

so:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1MA-AuswahlMAListe DropDown
2ManfredFranzFranz
3PauliHerbertHerbert
4Manfred
5GerhardGerhard
6Pauli

ZelleFormel
D2=WENN(ZÄHLENWENN($A$2:$A$10;C2)=1;"";C2)

ZelleGültigkeitstypOperatorWert1Wert2
A2Liste=$D$2:$D$6
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Wieso speicherst du deine Datei als .xls, obwohl du das neueste Excel hast? So stehen dir nur 65Tsd Zeilen anstatt 1,4 Mio Zeilen zur Verfügung. Und auch die Spaltenanzahl ist auf 256 anstatt 16Tsd begrenzt.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Sven_EE
Antwortento top
#3
Danke für die schnelle Antwort,
das ist der grundsätzliche Gedanke den ich auch schon hatte, siehe Tabellenblatt Test im Anhang. Aber ich hätte gerne die Liste in einem anderen Tabellenblatt. Und da scheiterts bei mir.
Antwortento top
#4
Hin Sven,

übertrage meinen Vorschlag einfach auf dein anderes Tabellenblatt.

Liste auf zweitem Tabellenblatt:

Arbeitsblatt mit dem Namen 'Tabelle2'
AB
1MAListe DropDown
2Franz
3HerbertHerbert
4Manfred
5GerhardGerhard
6Pauli

ZelleFormel
B2=WENN(ZÄHLENWENN(Tabelle1!$A$2:$A$10;A2)=1;"";A2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

DropDown-Anwendung auf dem ersten:

   

Ausnahmsweise ein Bildchen, damit du siehst, dass auch in diesem Fall die bereits verwendeten Begriffe "aussortiert" wurden.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Herzlichen Dank
das hat mir enorm geholfen.
Antwortento top
#6
Hallo, ich finde Lücken in einer DropDownliste generell "unschön"...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Hi Jörg,

um dem unschönen Ästhetikgefühl abzuhelfen ( 05 ):

Arbeitsblatt mit dem Namen 'Tabelle3'
ABCDE
1MA-AuswahlMAListe DropDown
2ManfredFranzFranzFranz
3PauliHerbertHerbertHerbert
4ManfredGerhard
5GerhardGerhard
6Pauli

ZelleFormel
D2=WENN(ZÄHLENWENN($A$2:$A$10;C2)=1;"";C2)
E2=WENNFEHLER(INDEX(D:D;AGGREGAT(15;6;ZEILE($D$2:$D$6)/($D$2:$D$6<>"");ZEILE(A1)));"")

ZelleGültigkeitstypOperatorWert1Wert2
A2Liste=$E$2:$E$6
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

   
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Hallo Günter, mir ist am Ende des DropDown noch zu viel Luft...  Aber okay... Das muss halt jeder selber wissen... Ist ja nur meine Meinung...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste