Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Ausschließlich Unikate in extra Spalte
#1
Hallo,

SOS - ich bräuchte bitte eine Makro für folgende Aufgabe:

Zwei Text-Spalten miteinander vergleichen und ausschließlich die Unikate ausweisen. Doppelungen werden sowohl als auch gelöscht. Spalte 1 und 2 vergleichen Spalte drei zeigt alles was nicht doppelt war. 

Beispiel:
Spalte1.      Spalte2.          Spalte3.(Ergebnis)
Hund.         Hund.               Zebra
Katze          Katze.               Tiger
Maus.         Maus.               Hai
Zebra         Hai                   Delphin
Tiger.         Delphin

Ich hab schon alles durchsucht und werde nicht fündig - wer kann diese knifflige Aufgabe lösen? 
Freu mich - Danke und happy day
Engelchen
Antwortento top
#2
D2: =INDEX(A2:B99;ZEILE(2:99)/2;REST(ZEILE(2:99);2)+1)
E2: =ZÄHLENWENN(D:D;D2:D99)
G2: =FILTER(D:D;E:E=1)

(Kopieren nicht nötig)

klappt nur mit Excel 365 oder kostenlos mit Excel Online.
Antwortento top
#3
Hallo Engelchen,

auch ich habe dir statt einer VBA- eine Formellösung (mit einem kleinen Umweg):

1. Kopiere deine beiden zu vergleichenden Spalten untereinander.
2. Füge eine Hilfsspalte zum Ermitteln der relevanten Zeilennummer ein und
3. Ziehe deine Unikate mit INDEX() heraus.

Wenn du jetzt die Unikate kopierst und sie wieder als Werte einfügst, kannst du die Hilfsspalten löschen.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1HundHundHundZebra
2KatzeKatzeKatzeTiger
3MausMausMausHai
4ZebraHaiZebra4Delfin
5TigerDelfinTiger5
6Hund
7Katze
8Maus
9Hai9
10Delfin10

ZelleFormel
E1=WENN(ZÄHLENWENN($D$1:$D$10;D1)>1;"";ZEILE())
F1=WENNFEHLER(INDEX($D$1:$D$10;WENNFEHLER(KKLEINSTE($E$1:$E$10;ZEILE(A1));""));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Engel29
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste