Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auslesen eines Wertes und ihn zur Bedingung machen
#1
Hallo
Ich sitze derzeit an einem "gaaaanz einfachen" Entwurf für eine Klassentabelle, finde aber, da ich auch nur ein Gelegenheits-User bin, gerade keine Lösung das Auslesen einer Zelle mit einer Bedingung zu Verknüpfen.

Ziel: Eine Anwesenheitsliste bei der ich Anwesend, Entschuldigt und Unentschuldigt eintragen kann, das Fach für jeden Block eintragen kann und mir die Zahlen am Ende Ausspuckt.
Wie in der Tabelle (Anhang) möchte ich am Ende die Gesamtanwesenheit berechnen (AnzahlZellen zählen um den gesamten Kalender einzubeziehen), habe also eine Ist- Zahl und kann diese mit der Soll Zahl vergleichen...Prozente etc... alles kein Thema.
So nun soll danach aber eine Berechnung der Anwesenheiten der einzelnen Fächer Stattfinden. Das Sind die Fächer LF1- LF6, WPU und PBU. Ich möchte sozusagen die Summe der o.g. A's, E's und U's in den einzelnen Fachspalten angezeigt bekommen, was bedeutet das die Zählung nur stattfinden soll, wenn das entsprechende Fach ausgelesen wurde.

ICh habe mit der Wenn Funktion versucht eine Zählen wenn "E"...aber ich habe keine Idee wie ich die Zeile mit dem Fach als Bedungung integrieren kann, da ich  keine feste Zelle angeben kann. ICh habe Summewenn probiert...aber nichts davon hilft mir die so auszulesen ohne dass ich jede einzelne Spalte reinprogrammieren müsste...

Wäre toll wenn jemand eine Idee hat.
Viele Grüße


Angehängte Dateien
.xlsx   Entwurf Klassenbuch.xlsx (Größe: 61,89 KB / Downloads: 1)
Antwortento top
#2
Hola,

also ich finde in der Tabelle keine Buchstaben die man zählen könnte....nur 1er.

Gruß,
steve1da
Antwortento top
#3
Stimmt - völlig richtig... ich habe zum experimentieren mit Einsen gearbeitet, da ich die Zählfunktionen getestet habe...
Statt den Einsen sollen da künftig die E's und U's eingetragen werden.

Habs nochmal korrigiert...
Eine Kleinigkeit noch...wenn ich hinterher auf die Anwesendeintragung verzichten kann wäre das natürlich auch noch toll, so dass quasi nur die E's und U's eingetragen werden können....(Daher auch in dem einen Feld die Anzahll der Lehrzellen als Rechnung.


Angehängte Dateien
.xlsx   Entwurf Klassenbuch.xlsx (Größe: 61,95 KB / Downloads: 1)
Antwortento top
#4
Hola,

Code:
=ZÄHLENWENN(RN3:SG3;1)


Gruß,
steve1da
Antwortento top
#5
Probiere gerade diesen hier, aber dann zählt er die Anzahl der Fächer durch.. also aus Zeile 34.. diese Zahl soll aber nur Bedingung sein ob die entsprechende Schülerzeile ausgelesen wird oder nicht

=WENN(ZEILEN($34:$34);  ZÄHLENWENN($34:$34; "1");SUMME(B12:SG12))
Antwortento top
#6
Hola,

wenn du mal konkret sagen würdest, was für ein Ergebnis du genau erwartest, könnte man vielleicht gezielter helfen. Nur als Tipp: "1" zählt 1er die als TEXT vorliegen.

Gruß,
steve1da
Antwortento top
#7
Habs so umgebaut.. aber nun fehlt die Bedingung.

=WENN(ZEILEN($34:$34);  ZÄHLENWENN($B12:SG12;"E"))


Ok ich versuche es nochmal
Ich möchte gerne in diese Tabelle E#s und U#s für die Anwesenheiten von Schülern dokumentieren.
Unten steht das Fach. Hat der Schüler also Fach "1" und hat hier gefehlt, möchte ich das in der Spalte LF1 Anwesenheit eine Fehlzeit angezeigt wird. (2 UE pro Block). Fehlt ein Schüler z.B. am 27.1.2021 trage ich vier Blöcke (a 2UE) als "F" oder "E" ein. Da in der Spalte Soll, die Unterrichtstage zusammenaddiert werden, möchte ich im Endeffekt eine Prozentzahl des Fehlens PRO FACH.

Also Wenn der Schüler fehlt in Fach 1 soll die Fehlzeit in der Spalte LF1 Fehlzeit angezeigt werden, in Fach3 , dann soll die Zahl in die Spalte LF3.
ICh hoffe es ist so verständlicher.
LG
Antwortento top
#8
Hola,

ich würde vorschlagen du erstellst eine Beispieldatei die sich an deiner Beschreibung orientiert. Ich habe keine Ahnung welche 1 für welche UE stehen soll und aus deinen Formeln wird man auch nicht sehr schlau.
Diese Beispieldatei sollte auch ein händisch eingetragenes Wunschergebnis beinhalten.

Gruß,
steve1da
Antwortento top
#9
So ich habs nochmal versucht Darzustellen
Ich denke der Kern ist es die Zeile 34 jeweils auszulesen und aufgrund des Eingetragenen Wertes die Rechnung zu starten...
ICh freue mich über Hilfe

Sorry.. hab gepennt, es geht natürlich um Zeile 35


Angehängte Dateien Thumbnail(s)
   

.xlsx   Entwurf Klassenbuch Beispieltabelle.xlsx (Größe: 15,53 KB / Downloads: 3)
Antwortento top
#10
Hola,

für die Fehlzeiten:

Code:
=ZÄHLENWENN($B3:$U3;"e")*2
Für unentschuldigt:
Code:
=ZÄHLENWENN(B3:U3;"u")*2

Den Rest analog.

Für WPU:
Code:
=ZÄHLENWENNS(B3:U3;"<>";$B$35:$U$35;"wpu")*2

Der Rest analog.

Gruß, 
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste