Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Ausgeben eines Wertes aus einer Matrix
#1
Guten Abend Zusammen,

ich möchte eine Matrix mit mehreren Spalten und Zeilen nach einem Wert durchsuchen lassen.

Dargestellt ist in der Spalte die Betriebszugehörigkeit und dahinter in der Zeile das Alter. Aus der Kombination aus Zugehörigkeit und Alter, ergibt sich der Bonus, den ein Mitarbeiter erhält.
Ist er also 15 Jahre dabei und über 40, so erhält er einen Bonus von 8.

Aus der Abfrage der Zugehörigkeit und des Alters möchte ich mir den Wert "8" zurückgeben lassen.

Anbei die Matrix, damit ihr eine Vorstellung habt.

[ Bild bitte als Datei hochladen! ]

In einem anderen Tabellenblatt sind die Stammdaten der Mitarbeiter mit Zugehörigkeit und Alter aufgelistet.

Ist sowas mit "normalen" Excelfunktionen überhaubt möglich?

Vielen Dank für eure Hilfe!

Gruß

Alexander

Leider habe ich das Attachment vergessen.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Mit Index und Verweis ist das möglich. In ein Bild lassen sich leider keine Formeln bauen.
https://www.herber.de/excelformeln/pages...immen.html
Antwortento top
#3
Hallo, meinst du so..?


Arbeitsblatt mit dem Namen 'Sheet1'
ABCDEFGHI
1Alter

DienstZeit
<4040455055
232233
3523345DienstZeit15
4734567Alter41
5945679
611567911Bonus8
7136781012
8157891113
91789101214
1019910111315
11211011121416
122312131517
132513141618

ZelleFormatWert
B1[=0]"<40";Standard0

ZelleFormel
I6=WENNFEHLER(INDEX(B2:F13;VERGLEICH(I3;A2:A13;1);VERGLEICH(I4;B1:F1;1));0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Oder ..:

PHP-Code:
=WENNFEHLER(INDEX(B2:F13;ZÄHLENWENN(A2:A13;"<"&I3)+1;VERGLEICH(I4;B1:F1;1));0
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste