Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auflistung von Zeilen mit Werten
#1
Moin!

Ich stehe gerade auf dem Schlauch...

In einem Tabellenblatt befinden sich beispielhaft alle Lebensmittel, die ich regelmäßig esse.
Hier mal als Beispiel ein paar Früchte:

Ananas       0
Apfel          2
Banane       1
Birne          0
Erdbeeren   0

In der Spalte rechts daneben steht die Anzahl an Obst für den nächsten Einkauf.
In einem anderen Tabellenblatt möchte ich nun einen Einkaufszettel generieren, der mir alles an Obst auflistet, dass nicht 0 ist, also so:

Apfel          2
Banane       1

Erschwerend kommt hinzu, dass die Lebensmittelliste dynamisch ist... also es können beliebig viele Zeilen hinzugefügt oder gelöscht werden.
Der Einkaufszettel darf die Werte also nicht statisch auslesen, sondern immer aktuell.
Ich weiß nicht wie ich es besser formulieren soll...

Das kann doch nicht so schwer sein?
Ich dachte schon irgendwie an sverwweis, bekomme es aber nicht hin.

Würde mich sehr über Eure Hilfe freuen.
Antwortento top
#2
Hola,


Code:
=WENNFEHLER(INDEX(Tabelle1!$A$2:$A$20;AGGREGAT(15;6;ZEILE(Tabelle1!$A$2:$A$20)-1/(Tabelle1!$B$2:$B$20<>0);ZEILE(A1)));"")

Gruß,
steve1da
Antwortento top
#3
hey Steve...

also es kann doch schwer sein  19

Erster Versuch funktioniert. Jetzt werde ich mich dranmachen das zu verstehen.

Danke erst mal!

Könntest du mir ein Mal kurz in Worten sagen was die Formel macht?

das wäre echt nett
Antwortento top
#4
Hola,

sie ermittelt im Bereich Tabelle1!B2:B20 die erste Zeilennummer, also die kleinste, wo der Wert ungleich 0 ist. Kleinste = KKleinste = der Parameter 15 bei Aggregat(). Durch herunterziehen der Formel wird aus Zeile(A1) Zeile(A2) usw. Das ist ein Zähler der die 2. kleinste, 3. kleinste....Zeile sucht wo der Wert ungleich 0 ist.
Und von diesen Zeilenwerten wird jeweils der Wert aus Tabelle1!A2:A20 ausgegeben.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • peterle
Antwortento top
#5
Hallo Peterle,
du könntest die Nullwerte aus der Tabelle auch einfach per Filter ausblenden. Als Tabelle formatieren oder den Schnellfilter (Daten -> Filter) benutzen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste