Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Anzeige der Nachkommastellen
#1
Hallo,

ich habe eine Sortiments und Kalkulationstabelle mit Verkaufspreisen aus denen ich Preisschilder generiere. Welches wie folgt aussieht.

[ Bild bitte als Datei hochladen! ]

Der Artikel kostet 1,10. Leider werden die ,10 cent nicht richtig angezeigt. Die Zelle ist auf Zahl mit zwei Dezimalstellen eingestellt.
In der Zelle für 1,- steht =WENN(ISTFEHLER(GANZZAHL('Getränke Regalware'!R6));"";GANZZAHL('Getränke Regalware'!R6))
in der Zelle für 10 cent steht =WENN(ISTFEHLER(TEIL('Getränke Regalware'!R6;FINDEN(",";'Getränke Regalware'!R6)+1;2));"";TEIL('Getränke Regalware'!R6;FINDEN(",";'Getränke Regalware'!R6)+1;2))

Für eine Lösung wie ich die 10 cent richtig darstellen kann, wäre ich dankbar.

[ Bild bitte als Datei hochladen! ]
Antwortento top
#2
Hola,

das wird mit Rest() gemacht.
Ganzzahl() ist alles was vor dem Komma ist, Rest() alles was nach dem Komma ist.

Gruß,
steve1da
Antwortento top
#3
Also sollte ich Teil () durch Rest () ersetzen?



[ Bild bitte als Datei hochladen! ]
Antwortento top
#4
Hola,

=rest(R6;2)

Gruß,
steve1da
Antwortento top
#5
Hallo,

Kamilla, du musst die Datei uch hochladen. Folge dem roten Pfeil ...

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#6
Datei befindet sich im Anhang.

=rest(R6;2) funktioniert nicht!

Gruß
Kamilla


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 29,31 KB / Downloads: 8)
Antwortento top
#7
Hi Kamilla,

dein kompletter Aufbau ist etwas seltsam. Vor allem die verbundenen Zellen sind Gift.

Hier mal mein Vorschlag, so wie ich dich verstanden habe.

Arbeitsblatt mit dem Namen 'Getränkepreisschilder'
ABCDE
1Augustiner EdelstoffMEHRWEG
2
3110
4Flasche
5Pfand 0,08 €1,10 €2,20 € / l

ZelleFormel
C1=SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;2;0)
D3=SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;5;0)
E3=RECHTS(SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;5;0);1)*10
A4=WENN('Getränke Regalware'!H4=0;"";'Getränke Regalware'!H4)
B4=SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;4;0)
A5=WENN('Getränke Regalware'!K4=0;"";'Getränke Regalware'!K4)
B5=SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;5;0)
D5=WENN(ISTFEHLER('Getränke Regalware'!R4/'Getränke Regalware'!N4);"";'Getränke Regalware'!R4/'Getränke Regalware'!P4)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Im Blatt "Getränke Regalware" darf in C4 nur Augustiner Edelstoff stehen (ohne irgendwelche Zusätze).
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
vielen Dank.
Leider steht nicht immer das gleiche Preisschild an erster Stelle.
Somit wird mir beim einem anderen Preis z.B. -,99 durch die Formel nur -,90 angezeigt.

Gruß
Kamilla
Antwortento top
#9
Hi,

ein wenig Probiergeist?

Arbeitsblatt mit dem Namen 'Getränkepreisschilder'
ABCDE
1Augustiner EdelstoffMEHRWEG
2
30,99
4Flasche
5Pfand 0,08 €0,99 €2,20 € / l

ZelleFormel
B5=SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;5;0)
D3=SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;5;0)
E3=WENN(D3<1;"";RECHTS(SVERWEIS($A$1;'Getränke Regalware'!$C$4:$R$17;5;0);1)*10)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Hallöchen,

im Reste-Prinzip ?

Arbeitsblatt mit dem Namen 'Getränkepreisschilder'
DE
3090
4

ZelleFormel
D3=WENN(A1<>"";GANZZAHL('Getränke Regalware'!R4);"")
E3=WENN(A1<>"";REST('Getränke Regalware'!R4;1)*100;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg

so eine Prüfung
WENN('Getränke Regalware'!E4=0;"";'Getränke Regalware'!E4)
bräuchtest Du doch nur, wenn in der Zeile irgendwo noch irgendwelche Rester stehen. Kann das denn passieren?

Wie wechselst Du denn die Getränke im "gelben Bereich" und auf Deinem Schild in A1? Wenn Du den gelben Bereich später in einem Makro Zeile für Zeile abarbeiten willst, könntest Du auch mit INDEX verformeln. Du trägst einfach in eine Zelle eine Zeilenzahl ein und beziehst dich im INDEX darauf. Den INDEX kannst Du dann überall statt des SVERWEIS einsetzen.
Das hätte dann auch den Vorteil, dass Du mit Deinem Bier mehrere Zeilen füllen kannst, z.B. Kasten - 20er, 11er, 10er (halber 20er bei Paul., 6er Pack usw.


Ich hab hier mal für A1 ein Beispiel. die 1 steht in M1

Arbeitsblatt mit dem Namen 'Getränkepreisschilder'
ABCDEM
1Augustiner EdelstoffMEHRWEG1
2
3090
4Flasche

ZelleFormel
A1=INDEX('Getränke Regalware'!E4:AA8;M1;1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste