Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Das Update ist abgeschlossen, Ihr könnt unser Forum jetzt wieder wie gewohnt nutzen. Eventuelle Bugs und Auffälligkeiten postet Ihr bitte im entsprechenden Forum im Bereich Forumstechnik. x


Anhand eines Geburtstages soll einsternzeichen mit passenden Symbol ausgegeben werden
#1
hallo Leute,
ich möchte für ein Geburtsdatum das richtige Sternzeichen ausgeben haben, dass habe ich soweit hingekriegt, gibt ja viele Beispielvideos im Netz
jetzt möchte ich aber, dass das Programm mir noch dazu die passenden Symbole dafür ausspuckt, und die typische Charaktereigenschaften auflistet  idealerweise jeweils in einer Zelle folgend dahinter, geht das mit einer Wenn Bedingung ?
In der Formelleiste kann ich die Symbole ja nicht einfügen, wie mache ich das sinnvollerweise.
Freue mich auf eure klugen Beiträge.
Gruss
ExcelJünger


Angehängte Dateien Thumbnail(s)
   
Antworten Top
#2
Moin!
Gibt es die Sternzeichensymbole als Schriftzeichen?
Edit:
Nach sehr kurzer Suche: https://www.webmaster-seo.com/de/unicode/coding?cat=30
Dann mittels SVERWEIS() in einer Vergleichstabelle.
ABCDE
1WidderJungfrau
2Stier
3Zwillinge
4Krebs
5Löwe
6Jungfrau
7Waage
8Skorpion
9Schütze
10Steinbock
11Wassermann
12Fische

ZelleFormel
E1=SVERWEIS(D1;A:B;2;0)

(übrigens würde ich die Terme Deiner "Monsterformel" ebenso auslagern)

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top
#3
Ich habe es mal so umgesetzt, wie ich mir das vorstelle.
Sehr wahrscheinlich, dass noch eine Geburtsjahr_ist_Schaltjahr-Korrektur eingearbeitet werden muss.

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDEFG
1JahrestagSternzeichenSymbolGebDatSternzeichenSymbol
21Steinbock29.07.1978Löwe
321Wassermann20.11.1979Skorpion
451Fische11.10.1989Waage
581Widder19.11.1976Skorpion
6112Stier03.05.1963Stier
7142Zwillinge26.08.1939Jungfrau
8174Krebs03.12.1989Schütze
9205Löwe18.04.1988Widder
10237Jungfrau31.01.1999Wassermann
11268Waage03.01.1978Steinbock
12298Skorpion
13328Schütze
14357Steinbock

NameBezug
Sternzeichen=Tabelle2!$A$2:$C$14

ZelleFormel
F2=SVERWEIS(--(TEXT($E2;"T.M.")&1900);Sternzeichen;SPALTE(B9))
Formel aus F2 nach rechts und unten ziehen.


Angehängte Dateien
.xlsx   Sternzeichen.xlsx (Größe: 10,57 KB / Downloads: 10)
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top
#4
...zu den Symbolen kommt man noch schneller:

- Win Taste + Punkt
- Sternzeichen als Suchbegriff im Suchfeld eingeben
- Sternzeichen auswählen....

Kann aber sein, dass das in der 2007er Version noch nicht geht....
Der sicherste Ansatz für einen Irrtum ist der Glaube, alles im Griff zu haben.
Nur, weil ich den Recorder bedienen kann, macht mich das noch lange nicht zum Musiker.

Ciao, Ralf

Antworten Top
#5
Hallo zusammen,
ich habe mir vor Jahren mal eine Liste mit der Abfrage von Tierkreiszeichen erstellt.
Dort habe ich eine Formel aus dem Netz verwendet. Weiß aber nicht mehr woher.
Die Formel ist also nicht von mir:

Alles in einer Formel, 
Datum in E4

Code:
=VERWEIS(E4-DATUM(JAHR(E4);1;0)-((TAG(DATUM(JAHR(E4);3;0))=29)*(MONAT(E4)>2));{1;21;51;80;111;141;173;204;236;267;297;327;356};{"♑";"♒";"♓";"♈";"♉";"♊";"♋";"♌";"♍";"♎";"♏";"♐";"♑"})

oder

Code:
=VERWEIS(E4-DATUM(JAHR(E4);1;0)-((TAG(DATUM(JAHR(E4);3;0))=29)*(MONAT(E4)>2));{1;21;51;80;111;141;173;204;236;267;297;327;356};{"Steinbock";"Wassermann";"Fische";"Widder";"Stier";"Zwillinge";"Krebs";"Löwe";"Jungfrau";"Waage";"Skorpion";"Schütze";"Steinbock"})

LG Holger
Antworten Top
#6
Moin Holger!
In der von Dir gezeigten Formel gibt es ja die von mir angesprochene Geburtsjahr_ist_Schaltjahr-Korrektur.
Ich persönlich finde diese ellenlangen Text-Matrizen unübersichtlich und beim Schreiben Karpaltunnel-Syndrom-verdächtig.
Aber schließlich gibt es ja c&p Wink
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top
#7
Hallo,
auf das ellenlange Monster von Formel kannst du verzichten.
Es geht auch kürzer. Siehe Tabelle.
Die Symbole musst du mit Font Wingdings formatieren.

MfG Günter

.xlsx   Sternzeichen.xlsx (Größe: 17,63 KB / Downloads: 20)

oder so


Angehängte Dateien
.xlsx   Sternzeichen_2.xlsx (Größe: 18,08 KB / Downloads: 14)
Antworten Top
#8
Hi,

da hätte ich auch noch was:


Angehängte Dateien
.xlsx   Sternzeichen_Ed.xlsx (Größe: 11,76 KB / Downloads: 18)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#9
Webdings:

In @Bosko's Datei

PHP-Code:
=CHAR(MOD(INT((H2-DATE(YEAR(H2)-1;3;20))/29);12)+94
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antworten Top
#10
Hallöchen - @snb

irgendwie fehlt das worauf sich mancher am meisten freut - die Jungfrau Sad
.      \\\|///      Hoffe, geholfen zu haben.
       ( ô ô )      Grüße, André aus G in T  
  ooO-(_)-Ooo    (Excel 97-2019+365)
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste