Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Als Text gespeicherte Zahlen per SVERWEIS suchen
#1
Hallo Community,
ich habe ein Problem bei meinem Excel Sheet, und zwar bekomme ich aus einem SAP Programm eine Datei, in der alles als Text formatiert ist. Dort sind die erste Spalte die Personalnummern. Per SVERWEIS suche ich dann nach bestimmten Nummern und lasse mir dir Daten ausgeben. Das funktioniert einwandfrei, wenn ich die erste Spalte der SAP Daten von Hand formatiere. Ich hätte jedoch gerne, dass ich einfach nur die SAP Daten auf einem Blatt einfüge und dann läuft alles Automatisch.
Das Problem ist denke ich, dass ich auf dem Blatt auf dem ich die Personalnummern dann eingebe, nach denen ich Suche, diese Nummern als Zahl formatiert eingebe und der SVERWEIS sie somit nicht findet. Wie kann ich dieses Problem lösen? Kann ich mir eine weitere Spalte machen, in der mir Excel meine manuell eingegebenen Nummern als Text formatiert und suche dann die Werte in dieser Spalte per SVERWEIS? Wenn ja wie lautet dafür der Befehl? Oder gibt es einen anderen Lösungsansatz?
Das Ziel sollte sein, dass ich einfach nur die SAP Daten einfüge und sofort wenn ich eine Nummer eingebe das Ergebnis habe.
Liebe Grüße
Excel Blush
Antwortento top
#2
Hi,
wenn du die SAP Daten über Power Query importierst und anpasst, ergibt sich das Problem nicht.
Cadmus
Antwortento top
#3
Hola,

hatten wir doch gestern schon...

https://www.clever-excel-forum.de/Thread...#pid199014

Gruß,
steve1da
Antwortento top
#4
Danke für die schnelle Antwort,
ich bekomme die Daten leider schon auf einem Excel Sheet zugeschickt, sprich sie sind leider falsch formatiert.
Ich weiß nicht ob ich dann mit Power Querry weiter komme, das habe ich noch nie verwendet, bin noch relativ ungewandt in Excel
LG
Excel
Antwortento top
#5
Hallo


Weiß nicht, wie dein Sverweis aussieht...

Hier mal, eine Standardformel, die Nicht klappt und zwei Möglichkeiten, die funktionieren 

Code:
=SVERWEIS(E1;A:B;2;0)
=SVERWEIS(""&E1;A:B;2;0)
=SVERWEIS(TEXT(E1;"@");A:B;2;0)

LG UweD
Antwortento top
#6
Wieso wandelst du die entsprechende Spalte nicht einfach in echte Zahlen um? Spalte markieren, Reiter Daten - Text in Spalten - Fertig stellen. Wenige Mausklicks, die sich sogar mit dem Makrorekorder aufzeichnen lassen.
Schöne Grüße
Berni
Antwortento top
#7
@steve1da ja das was du mir gestern gesagt hast habe ich schon probiert, das funktioniert leider nicht, weil ich in meinem SVERWEIS ja nach einem TEXT suchen muss, aber mein TEXT muss die Personalnummer sein, die ich ja manuell eingebe. Ich glaube aber, dass meine manuell eingegebene Zahl eben als Zahl und nicht als TEXT formatiert ist.
Das ist mein SVERWEIS:
Code:
=WENNFEHLER(INDEX(Arbeitsdaten!$1:$1048576;VERGLEICH(SVERWEIS(Berechnung!$A3*1;Arbeitsdaten!$1:$1048576;1;FALSCH);Arbeitsdaten!$A:$A;0);B$2);"")

Hier gebe ich meine Personalnummer manuell in $A3 ein. Ich hab das mit dem *1 probiert, das funktioniert eben nicht. Ich habe es auch ohne das *1 aber da geht es auch nicht.
Es kann natürlich auch sein, dass ich mich einfach blöd anstelle.
Ich füge mal als Anhang hinzu, in welchem Format ich die Daten bekomme.
LG
Excel


Angehängte Dateien
.xlsx   FORMAT.xlsx (Größe: 8,46 KB / Downloads: 7)
Antwortento top
#8
Hi,

dann formatiere die Spalte, in der du deine Pers.-Nummern eingibst, als Text. Damit müsste dein SVERWEIS() funktionieren.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#9
HAllo nochmal

du musst es genau anders herum machen.

Das Suchkriterium als Text angeben..

PHP-Code:
E2:    =SVERWEIS(D2&"";A:B;2;0


LG UweD
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste