Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Alle Werte aus Spalte wiedergeben, aber nur einmal wiedergeben
#1
Hallo zusammen,

mit welcher Formel bekomme ich im Sheet "Auswertung" bei Personalnummer eine Auflistung aller in Spalte B vorhandenen Personalnummern aus Tabelle1 ohne Dopplungen?
Er soll jeden Wert nur einmal zählen.


.xlsx   CEF1.xlsx (Größe: 9,15 KB / Downloads: 3)
Antworten Top
#2
Moin

Was denn nun? Eine Auflistung oder die Anzahl?

Code:
=EINDEUTIG(Tabelle1!B6:B37)
Wir sehen uns!
... Detlef

Meine Beiträge können Ironie oder Sarkasmus enthalten.

Antworten Top
#3
Hola,
https://www.herber.de/excelformeln/pages...ikate.html
Gruß,
steve1da
[-] Folgende(r) 1 Nutzer sagt Danke an steve1da für diesen Beitrag:
  • Meliodas
Antworten Top
#4
Die Formel gibt es bei mir gar nicht
Es kommt die Fehlermeldung #Name?
Antworten Top
#5
Hi,

EINDEUTIG gibt es in Deiner Version noch nicht. Du solltest Dir villeicht mal eine etwas neuere Version zulegen.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Nutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Meliodas
Antworten Top
#6
Hallo,

vielen dank!

FUnktioniert.
Allerdings hätte ich noch eine Ergänzung

=WENN(MAX((Tabelle1!B$6:$B$5000
In der Arrayformel klappt das soweit gut. Das Ding ist jetzt nur, wenn ich die runterziehe kommt irgendwann eine leere Zelle und dann fängt es wieder von vorne an.
Wie kann ich das denn beheben? :D
Antworten Top
#7
Bei mir kommen nur die 4 Nummern in deiner Datei, keine sonst.
Zeig das bitte an einer neuen Datei.
Antworten Top
#8
Sofern sich das nicht wiederholen würde unten, wäre ich glaube ich wunschlos glücklich fürs erste.


Angehängte Dateien
.xlsx   CEF1.xlsx (Größe: 9,92 KB / Downloads: 5)
Antworten Top
#9
Wo du die Formel her hast weiß ich nicht - aus dem Link jedenfalls nicht.
In B6:=MIN(Tabelle1!B:B)
In B7 (keine Matrixformel):
=WENN(MAX(Tabelle1!B:B)=MAX(E$6:E6);"";KGRÖSSTE(Tabelle1!B:B;ZÄHLENWENN(Tabelle1!B:B;">"&E6)))
Antworten Top
#10
Die Formel hatte ich aus dem Link + etwas Eigenkreation.

Bei deiner Formel für B7 kommt allerdings die Fehlermeldung #Zahl!

Und worauf soll sich E6 beziehen? Das verstehe ich leider nicht.
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste