Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Abgleich von 2 Datentabellen
#1
Hallo zusammen,

ich benötige eure Hilfe bei der Erstellung einer Formel für die Spalte "D" in Tabelle 1 meiner unten angehängten Excel-Datei.

Die Formel soll folgende Anforderungen erfüllen:

1. Gehe jeden Namen aus Tabelle 1 durch und durchsuche Tabelle 2 nach dem Namen (Namen in Tabelle 2 können doppelt vorkommen)
2. Wenn dieser Name in Tabelle 2 vorkommt, überprüfe, ob das Startdatum2 in Tabelle 2 größer (neuer) als das Enddatum 1 in Tabelle 1 ist.
3. Außerdem sollte in Tabelle 2 in Spalte D "unser Kunde" stehen
4. Wenn alle diese Anforderungen erfüllt sind schreibe mir bitte ein "Ja" in die Spalte D "Erneut Veröffentlicht" in Tabelle 1

Ich hatte das ganze schon mit einer Wenn-Formel in Verbindung mit einem S-Verweis probiert, war jedoch erfolglos, da der S-verweis beim 1. identischen Namen, den er in Tabelle 2 gefunden hat gestoppt ist.
Ich hoffe ihr könnt mir weiterhelfen  Smile
 
Viele grüße 
Hugo


Angehängte Dateien
.xlsx   Erneue veröffentlichung Formel-Test.xlsx (Größe: 11,18 KB / Downloads: 3)
Antworten Top
#2
Hi,

D2:
=ZÄHLENWENNS('Tabelle 2'!A:A;A2;'Tabelle 2'!B:B;">"&C2;'Tabelle 2'!D:D;"unser Kunde")
und runterkopieren. Liefert 0 (nein) oder 1 (ja).
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste