Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Abfrage mit WENN() und ZÄHLENWENN() (war: Verzweifelt)
#1
Hallo zusammen

Ich bin an der Erstellung eines Schichtplanungsfiles und möchte nun differenziert die Absenzen auf Halbe Tage ausweisen können. 

Wenn ich in einer Zelle Wert a1 eingebe soll es mir den Wert 1 rausspucken.
Wenn ich in einer Zelle Wert a0 eingebe solle s mir den Wert 0.5 rausspucken.

Irgendwo mache ich einen Denkfehler, sodass es mir nie den korrekten Wert ergibt.

Cheers Dani
Antwortento top
#2
Hallöchen,

Deine Beschreipung scheint doch zu passen, Du musst sie nur richtig verformeln. Gib z.B. in B1 diese Formel ein:

=WENN(A1="a1";1;WENN(A1="a0";0,5;"was sonst?")
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
=WENN(A1="a1";1;WENN(A1="a0";0,5;"was sonst?")

Die zwei fettmarkierten A1 sind jeweils der Bereich wo dies auftreten soll, oder?

Ich bräuchte es theoretisch so:

=WENN(AHS9:AHT77="a1";1;WENN(AHS9:AHT77="a0";0,5;)

ich habe einen gewissen Zellberich, welchen ich abfragen muss. Leider funktioniert es so nicht  Confused
Antwortento top
#4
Hola,


Code:
=WENN(ZÄHLENWENN(AHS9:AHT77;"a1");1;WENN(ZÄHLENWENN(AHS9:AHT77;"a0");0,5;""))

Übrigens toller Betreff! Perfekt für spätere Recherchen.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Danny2391
Antwortento top
#5
(29.10.2020, 10:05)steve1da schrieb: Hola,


Code:
=WENN(ZÄHLENWENN(AHS9:AHT77;"a1");1;WENN(ZÄHLENWENN(AHS9:AHT77;"a0");0,5;""))

Übrigens toller Betreff! Perfekt für spätere Recherchen.

Gruß,
steve1da

Perfekt! 
Ich musste nur etwas ändern: 

0,5 muss 0.5 ausgeschrieben sein

=WENN(ZÄHLENWENN(AHS9:AHT77;"a1");1;WENN(ZÄHLENWENN(AHS9:AHT77;"a0");0,5;""))
Antwortento top
#6
Hallo Danny,

bitte bei zukünftigen Threads beachten, dass die Themenüberschriften das Problem wiederspiegeln. Später Suchende finden sonst nicht zum gelösten Problem (niemand sucht nach "Verzweifelt").
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
Hallo zusammen

Leider ist mein Problem doch nicht ganz gelöst. Ich hatte mir folgendes erhofft:

Bei W84 müsste es mir nun 2.0 anzeigen und bei X84 müsste es mir 0.5 anzeigen.

Könnt ihr mir da weiterhelfen?


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#8
Hallöchen,

was stehen da für Formeln drin? Was steht in AHS und AHT (siehe Formel von Steve1da)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#9
Hola,

in W und X stehen nur Xe drin, und zwar die gleiche Anzahl. Warum soll da auf einmal 2 und 0,5 rauskommen?

Gruß,
steve1da
Antwortento top
#10
(02.11.2020, 10:13)steve1da schrieb: Hola,

in W und X stehen nur Xe drin, und zwar die gleiche Anzahl. Warum soll da auf einmal 2 und 0,5 rauskommen?

Gruß,
steve1da

Ich beziehe mich nicht auf die direkt darüberstehenden Zeilen. Siehe Screenshot

Bei W84 =WENN(ZÄHLENWENN(Y9:Y18;"a1");1;WENN(ZÄHLENWENN(Z9:Z18;"a0");0.5;""))
Bei X84 =WENN(ZÄHLENWENN(Y9:Y18;"a1");1;WENN(ZÄHLENWENN(Z9:Z18;"a0");0.5;""))


Angehängte Dateien Thumbnail(s)
   
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste