Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

15min Datenreihe zu 30min Datenreihe
#1
Hallo Excel Experten,

Ich habe ein eher simples Problem, tüftel aber schon seit 2 Stunden und nichts bringt mir die gehofften Ergebnisse. 

Ziel: Datenreihe mit Werten im Intervall von 15min, umwandeln (in separater Spalte) zu einer Datenreihe mit 30min Werten.

Was ich schon probiert habe: 
Pivot Tabelle, geht nicht da ich 50 000+ Werte habe. 
Zwei Zeilen mit der gewünschten Addition vorgeben ( also E16=D16+D17 und E17=D18+D19), Excel generiert mir aber das Muster E16=D16+D17 und E17=D17+D18, was zu redundanten Zeilen/daten führt die ich löschen müsste, auch blöd.

Im Anhang befindet sich eine Tabelle mit 1/12 der Daten.


Ich freue mich über eurer HilfeSmile


Angehängte Dateien
.xlsx   Besipiel.xlsx (Größe: 66,26 KB / Downloads: 9)
Antwortento top
#2
E16: =SUMME(INDEX(D:D;ZEILE(D8)*2+{1.0}))/2
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • hans1337
Antwortento top
#3
Hi,

Danke für die schnelle Antwort und die Formel.Smile

Mfg
Antwortento top
#4
(entfällt)
Antwortento top
#5
(12.06.2020, 11:55)LCohen schrieb: E16: =SUMME(INDEX(D:D;ZEILE(D8)*2+{1.0}))/2

Also das Beispiel mit dem E16 war wahrscheinlich irreführend, so ist es nämlich in meinem Originaldokument.

Könntest du mir nochmal die erste Zeile der Formel schicken? Praktisch A1,2,3....= Daten und dann die Formel in B1.

Super nettSmile
Antwortento top
#6
In C2 Viertelstunden

PHP-Code:
=DATE(2019;1;1)+(ROW(A1)-1)/96 

In D2 halbe Stunden

PHP-Code:
=DATE(2019;1;1)+(ROW(A1)-1)/48 
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top
#7
Du darfst auch mal selbst mitdenken, Hans.

Warum hatte ich denn wohl ZEILE(D8)*2+{1.0}?
Und wie änderst Du das nun ab?

Ich muss das fragen, sonst bekommst Du immer nur den Fisch, ohne das Angeln zu lernen.
Antwortento top
#8
Ich kann deinen Ansatz schon verstehen, ich möchte das ja auch selber können, aber bis ich mich in die Indexfunktion eingelesen habe dauert es noch ein bisschen. 

Was ich gemacht habe war versuchen nachzuvollziehen, warum dort D8 steht, aber setzte ich diese Formel in z.B. B1 eind ersetze D8 durch eben B1 kommt nur Murks raus. Auch das verschieben der Tabelle, Eingeben in D16 und dann per Excel Formel bis D1 kopieren brachte nur vereinzelte Fehlermeldungen :(

Mfg
Antwortento top
#9
B1: =SUMME(INDEX(A:A;ZEILE(A1)*2-{1.0}))
Antwortento top
#10
Moin

Ich bin da eher bei snb mit der Hilfsspalte.
Dann ruck-zuck eine Pivot drüber ziehen und fertig.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste