Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Tageberechnung
#1
Hallo,
ich kenne mich mit Excel nicht aus. Deshalb mein Probelm:

in Spalte L steht ein Datum z. B. 01.07.14 und in Spalte N auch z. B. 15.09.14. Wenn die Anzahl der Tage vom 01.07.14 - 15.09.14 weniger als 89 sind dann darf in Spalte O keine Zahl erscheinen.
Wenn in Spalte N 05.10.14 steht und somit mehr als 89 Tage sind dann sollte in Spalte O die Zahl 1 stehen. Die Zahl 1 sollte dort auch stehen wenn in Spalte N kein Datum steht. Huh

Kann mir jemand dafür eine Formel geben? Wäre echt super und würde mir in vielen Dingen helfen.

Danke schon einmal.

radilo
to top
#2
Hallo radilo,

=WENN(ODER(N1-L1>89;N1="");1;0)

und was ist bei genau 89 Tagen?
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
to top
#3
Hi Radilo,

ich würde es so machen, wobei Connys Frage natürlich dabei offen bleibt:


Tabelle1
LMNO
101.07.2014  14.09.2014 

verwendete Formeln
Zelle Formel Bereich
O1 =WENN(N1="";1;WENN(N1-L1<89;"";1))

Tabellendarstellung in Foren Version 8.6 by Beverly's Excel-Inn

Mit freundlichen Grüßen  Smile
Michael

Win 7 64 bit / Excel 2007/2016
[-] Folgende(r) 1 Benutzer sagt Danke an Zwergel für diesen Beitrag:
radilo
to top
#4
... wenn es genau 89 Tage sind dann muß dort auch eine 1 erscheinen.

Vielen lieben Dank.
to top
#5
Hallo radilo,

dann setze hinter das">" noch ein "="

=WENN(ODER(N2-L2>=89;N2="");1;0)
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
[-] Folgende(r) 1 Benutzer sagt Danke an coemm für diesen Beitrag:
radilo
to top
#6
... schaut schon gut aus.

Jetzt erscheint allerdings bei weniger als 89 Tage die Zahl 0. Wenn ich jetzt die Spalte zusammenzählen will =SUMME(O3:O832) und alle 1 gezählt werden sollen funktioniert es nicht, da zwischenzeitlich die 0 erscheint.

Was kann man jetzt machen.

Danke noch einmal für die Hilfe

radilo
to top
#7
Hallo Radilo,

sorry, habe das mit leer wenn <89 übersehen,
deshalb so:
=WENN(ODER(N1-L1>=89;N1="");1;"")
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
[-] Folgende(r) 1 Benutzer sagt Danke an coemm für diesen Beitrag:
radilo
to top
#8
Jetzt erscheint ein leeres Feld. Das ist auch so gewollt und richtig.

Beim zusammenrechnen =summe(O3:O832) erscheint #WERT. Was ist denn jetzt falsch? Wenn ich
=summe(O650:O832) mache rechnet er es richtig aus und es erscheint die entsprechende Zahl.

Geht da noch was? Undecided

radilo
to top
#9
Hallo radilo,

da keiner deine Datei sieht, wird es schwer sein, deinen Fehler zu erkennen.
Schau mal nach, ob die Formatierung in der Spalte O überall gleich ist.
Gruß Conny Smile
_______________________________________________________________

Ich habe keine Lösung, aber ich bewundere dein Problem !
to top
#10
... alles erledigt. Es hatte sich ein Fehler eingeschlichen. Hinter einem Datum 14.07.14. war noch ein Punkt, der da nicht hingehört.

Jetzt funktioniert es super. Ganz lieben und vielen Dank.

Bis zum nächsten Mal.

radilo
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste