Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Problem Formel
#1
Ich habe folgende Tabellen:
Excel Jeanie HTMLTabelle1

ABCDE
1Gegenstand Einlauf GesamtmengeAuslauf
2
3Kiwi01.10.201420025.10.2014
4Erdbeeren02.10.201410
5Bananen03.10.20142025.10.2014
6Apfel04.10.201430
7Kiwi25.10.2014200

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


und die Tabelle 2:
Excel Jeanie HTMLTabelle2

ABC
1Übersichtvorhanden Ja Vorhanden nein
2
3Kiwix
4Erdbeerenx
5Bananenx
6Apfelx

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Das Problem ist folgendes: Auf der Tab. 1 habe ich Waren die ein Ein- und Ausgangsdatum haben. Diese Liste geht unendlich weiter. Beim Beispiel kiwi ist nun mein Problem, denn auf Tabelle Zwei sollte mir immer angezeigt werden, was noch vorhanden ist ( Also Kiwi sind in Tab.1 zwei posten, einer geschlossen und einer offen, so sollte auf Tab. 2 vorhanden ja angezeigt werden. Bei Bananen sollte wenn auf Tab. 1 ein auslaufdatum ist - auf Tab. zwei das x bei vorhanden nein sein ) Kann ich sowas mit einer formel regeln??
Für euere Hilfe wäre ich dankbar.
to top
#2
Hallo,

Formel in B3:
Code:
=(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;$A3;Tabelle1!$B$3:$B$6;"<>")>ZÄHLENWENNS(Tabelle1!$A$3:$A$6;$A3;Tabelle1!$E$3:$E$6;"<>"))*1

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDE
3Kiwi10.10.14200 12.10.14
4Erbeere10.10.1410  
5Banane11.10.1420 13.10.14
6Kiwi13.10.14200  
7     
8     
9 danicht da  
10KiwiX   
11Erdbeere X  
12Banane X  

ZelleFormatWert
B10[=1]"X";;1

ZelleFormel
B10=(ZÄHLENWENNS($A$3:$A$6;$A10;$B$3:$B$6;"<>")>ZÄHLENWENNS($A$3:$A$6;$A10;$E$3:$E$6;"<>"))*1
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Hallo Edgar,
irgendwie bring ich das nicht so hin, müssen jetzt die daten von tab 1 auch auf tab 2 stehen??
geht das nicht so wie ich oben angezeigt hab mit den tabellen ?
to top
#4
Hallo,

ich habe es zur Vereinfachung auf ein Blatt gemacht, habe Dir aber extra eine Formel für zwei Blätter hingeschrieben.
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hi,

ich hab' das so verstanden:

Tabelle1

ABCDE
1GegenstandEinlaufGesamt-mengeAuslauf
2
3Kiwi01.10.201420025.10.2014
4Erdbeeren02.10.201410
5Bananen03.10.20142025.10.2014
6Apfel04.10.201430
7Kiwi25.10.2014200

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8




Tabelle2

ABC
1Übersichtvorhanden javorhanden nein
2
3Kiwix
4Erdbeerenx
5Bananenx
6Apfelx
Formeln der Tabelle
ZelleFormel
B3=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A3;Tabelle1!$E$3:$E$7;"")>0;"x";"")
C3=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A3;Tabelle1!$E$3:$E$7;"")=0;"x";"")
B4=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A4;Tabelle1!$E$3:$E$7;"")>0;"x";"")
C4=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A4;Tabelle1!$E$3:$E$7;"")=0;"x";"")
B5=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A5;Tabelle1!$E$3:$E$7;"")>0;"x";"")
C5=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A5;Tabelle1!$E$3:$E$7;"")=0;"x";"")
B6=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A6;Tabelle1!$E$3:$E$7;"")>0;"x";"")
C6=WENN(ZÄHLENWENNS(Tabelle1!$A$3:$A$7;A6;Tabelle1!$E$3:$E$7;"")=0;"x";"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Edit:
Formeln in der Jeanie ergänzt
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
Hallo Günter,

gut! Habe ich schon wieder zuviel um die Ecke gedacht.
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#7
Hab jetzt alles so eingegeben und dann kommt immer
#NAME?
wo liegt der fehler ?
to top
#8
Hallo,

die Fehlermeldung #Name deutet auf einen Schreibfehler hin. Hast du die Formel eingetippt oder kopiert?

Welche XL-Version hast du?

Die Funktion Zählenwenns() gibt es erst ab XL2007 und bei XL2003 würde auch die Fehlermeldung kommen.
Gruß
Peter
to top
#9
(16.10.2014, 20:00)Fredl55 schrieb: Hab jetzt alles so eingegeben und dann kommt immer
#NAME?
wo liegt der fehler ?

Stell mal einen Tabellenausschnitt mit deiner eingegebenen Formel vor. Ich vermute, du hast einen Tippfehler in der Formel. Denn dass meine Formel funktioniert, siehst du ja an dem Tabellenausschnitt.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#10
Hallo,

mal aus der OH zu #Name? rauskopiert. Die Funktion Zählenwenns gibt es, wenn ich mich nicht irre seit Excel 2007).

Zitat:Überprüfen Sie die folgenden möglichen Ursachen und Lösungen.
AnzeigenVerwenden der Funktion EUROCONVERT, ohne dass das Add-In Eurowährungs-Tool geladen ist

Die Funktion EUROCONVERT benötigt das Add-In (Adresse: Der Pfad zu einem Objekt, Dokument, einer Datei, einer Seite oder einem anderen Zielobjekt. Hierbei kann es sich um eine URL (Webadresse) oder einen UNC-Pfad (Netzwerkadresse) handeln. Die Adresse kann auch auf eine spezielle Position innerhalb einer Datei verweisen, beispielsweise auf ein Lesezeichen in Word oder einen Zellbereich in Excel.) Eurowährungs-Tool.
AnzeigenInstallieren und Laden des Add-Ins Eurowährungs-Tool

Klicken Sie auf die Schaltfläche Microsoft Office Abbildung der Schaltfläche, klicken Sie auf Excel-Optionen und anschließend auf die Kategorie Add-Ins.
Wählen Sie im Listenfeld Verwalten die Option Excel-Add-Ins aus, und klicken Sie dann auf Gehe zu.
Aktivieren Sie in der Liste Verfügbare Add-Ins das Kontrollkästchen Eurowährungs-Tool, und klicken Sie dann auf OK.

--------------------------------------------------------------------------------

AnzeigenEin Name wurde verwendet, der nicht vorhanden ist

Stellen Sie sicher, dass der Name (Name: Ein Wort oder eine Zeichenfolge, das oder die für eine Zelle, einen Zellbereich, eine Formel oder eine Konstante steht. Verwenden Sie leicht verständliche Namen (beispielsweise "Produkte") statt schwer verständlichen Bereichen (beispielsweise "Umsatz!C20:C30").) vorhanden ist. Klicken Sie auf der Registerkarte Formeln in der Gruppe Definierte Namenauf Namens-Manager, und prüfen Sie, ob der Name aufgelistet ist. Wenn der Name nicht aufgelistet ist, fügen Sie ihn hinzu, indem Sie auf Namen definieren klicken.

AnzeigenDer Name wurde falsch geschrieben

Überprüfen Sie die Schreibweise. Markieren Sie den Namen auf der Bearbeitungsleiste (Bearbeitungsleiste: Eine Leiste am oberen Rand des Excel-Fensters, die zum Eingeben oder Bearbeiten von Werten oder Formeln in Zellen oder Diagrammen verwendet wird. Zeigt die Konstante oder die Formel an, die in der aktiven Zelle gespeichert ist.) Bearbeitungsleiste, drücken Sie F3, klicken Sie auf den Namen, den Sie verwenden möchten, und klicken Sie dann auf OK.
AnzeigenDer Name einer Funktion wurde falsch eingegeben

Korrigieren Sie die Schreibweise. Fügen Sie den korrekten Funktionsnamen ein, indem Sie auf der Registerkarte Formeln in der Gruppe Funktionsbibliothek auf Funktions-Assistent klicken.
AnzeigenText wurde in eine Formel ohne doppelte Anführungszeichen eingegeben

Excel versucht, den eingegebenen Text als Namen zu interpretieren.
Setzen Sie den Text in der Formel in doppelte Anführungszeichen. Die folgende Formel verknüpft den Text "Die Summe beträgt " mit dem Wert der Zelle B50:

="Die Summe beträgt "&B50

AnzeigenIn einem Bereichsbezug wurde der Doppelpunkt (Smile weggelassen

Stellen Sie sicher, dass bei allen Bereichsbezügen der Formel Doppelpunkte (Smile verwendet werden, z. B. SUMME(A1:C10).

AnzeigenEin Bezug auf ein anderes Blatt wurde erstellt, wobei die einfachen Anführungszeichen weggelassen wurden

Wenn die Formel einen Bezug auf Werte oder Zellen aus anderen Arbeitsblättern oder Arbeitsmappen enthält und der Name der anderen Arbeitsmappe oder des Arbeitsblatts ein nichtalphabetisches Zeichen oder ein Leerzeichen enthält, müssen Sie den Namen in einfache Anführungszeichen ( ' ) setzen.

AnzeigenÖffnen einer Arbeitsmappe mit einem Aufruf einer benutzerdefinierten Funktion (User-defined Function, UDF)

Eine benutzerdefinierte Funktion (UDF) wird über die Arbeitsmappe aufgerufen, ist aber auf dem Clientcomputer nicht verfügbar. Ein Entwickler kann eine UDF mit verschiedenen Methoden implementieren. Weitere Informationen hierzu finden Sie in der Visual Basic-Hilfe und im Microsoft Office SharePoint Server 2007 Software Development Kit (SDK).
Gruß Stefan
Win 7 / Office 2007
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Wink Problem mit Formel =Aggregat..... Tuempeltaucher 5 135 28.10.2016, 10:15
Letzter Beitrag: Tuempeltaucher
  formel problem excelnoobe 13 841 20.02.2016, 11:43
Letzter Beitrag: excelnoobe
  Problem mit Formel lewotheory 2 299 13.01.2016, 09:17
Letzter Beitrag: lewotheory
  Excel-Formel-Problem bei Zeiterfassung stefan.burr 13 2.118 28.11.2015, 10:15
Letzter Beitrag: schauan
  Excel Formel Problem Atram 6 1.123 01.09.2015, 14:13
Letzter Beitrag: BoskoBiati
  Excel Formel Problem LarsPB 1 636 30.03.2015, 14:12
Letzter Beitrag: steve1da
  Formel Problem b.wolff78 7 1.423 17.12.2014, 14:42
Letzter Beitrag: Jockel

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste