Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

bedingte Formatierung
#1
Hallo,

habe ein kleines Problem.
Wer kann helfen?
Ich habe eine Tabelle mit mehreren Spalten.In der Spalte C wird ein Feld über bedingte Formatierung"wenn man rot schreibt,
rot mit weißer schrift ausgefüllt.
grün mit schwarzer Schrift usw.

Nun soll in Spalte B bei rot-rt bei grün-gr blau-bl usw.eingetragen werden.
Geht so etwas?


Huh Bernd
to top
#2
Hallo,

du könntest die Bedingung in der Bedingten Formatierung für die Wenn-Funktion verwenden.

Als Beispiel: Du hast in der Bedingten Formatierung stehen, dass die Schrift rot werden soll wenn der Wert der Zelle größer 10 ist.

In der Wenn-Formel kannst du dann darauf Bezug nehmen: =Wenn(C1>10;"rot";Wenn(C1>5;"grün";"blau")

Wenn du mit diesem Hinweis nicht weiterkommst dann wäre es interessant zu erfahren welche Bedingungen du in der der Bedingten Formatierung verwendest du wie viele unterschiedliche du hast, zumindest lässt das usw. darauf schließen, dass es nicht bei rt, gr und bl bleibt.
Gruß
Peter
to top
#3
Hi Bernd,

wenn ich dich richtig verstanden habe, dann schreibst du in B1:

=WENN(C1="ROT";"rt";"")
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo,

die Variante von Günter geht mit rot.
Wie muss aber die wenn Funktion aussehen,wenn ich die Möglichkeit habe 7 Farben einzutragen,
rot;grün;gelb;blau;braun;grau;weiß



Bernd
to top
#5
Hallo,

bei 7-Wenn-Verschachtelungen könnte die Formel so aussehen:

=WENN(C1="rot";"rt";WENN(C1="Grün";"gr";WENN(C1="Gelb";"ge";WENN(C1="Blau";"bl";WENN(C1="Braun";"br";WENN(C1="Grau";"gr";WENN(C1="weiß";"we";"")))))))

Du könntest aber auch einen Matrix aufbauen, z.B. in E1 bis E7 die Farben und in D1 bis D7 die Abkürzungen und dann einen Sverweis verwenden:

=Sverweis(C1;E:D;2;0)

Das hätte den Vorteil, dass du, falls notwendig weitere ergänzende Farben und Beschreibungen problemlos hinzufügen kannst.
Gruß
Peter
to top
#6
Danke Peter,

klappt bestens.
Habe die wenn Funktion genutzt.
Bei der Matrix habe ich so meine Probleme.

Schönes WE

Bernd
to top
#7
Hallo,

die Variante mit Sverweis würde so aussehen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDE
1AAntonAntonA
2A BertaB
3  CäsarC
4  DoraD
5    

ZelleFormel
B1=SVERWEIS(C1;D:E;2;0)
B2=VERWEIS({"Anton"."Berta"."Cäsar"."Dora"};{"A"."B"."C"."D"})
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Und wenn du jetzt in D5 und E5 einen weiteren Namen/Farbe eingibst dann wird das sofort in der Formel berücksichtigt - und die Formel ist übersichtlicher.

Man könnte auch auf die Matrix verzichten und z.B. wie in B2 mit einer Funktion wie Verweis() arbeiten - nur so als Hinweis.
Gruß
Peter
to top
#8
Danke

auch das habe ich jetzt verstanden.Nun habe ich alle Möglichkeiten.

Nochmals ein schönes WE

Bernd
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Fehler ausblenden nicht anzeigen - Bedingte Formatierung? einervonvielen2013 11 115 24.03.2017, 11:25
Letzter Beitrag: WillWissen
  bedingte Formatierung mit Wenn Formel psychodennis89 9 158 20.03.2017, 13:12
Letzter Beitrag: o0Julia0o
  Bedingte Formatierung >=0,9 dann grün ->Auch "" = grün o0Julia0o 12 128 20.03.2017, 11:49
Letzter Beitrag: steve1da
  Bedingte Formatierung tw3aker 11 110 14.03.2017, 18:34
Letzter Beitrag: BoskoBiati
  Bedingte Formatierung mit "wenn + und" freiminute 2 46 10.03.2017, 12:28
Letzter Beitrag: freiminute
  Bedingte Formatierung von Zellen die sich dynamisch verändern Skar 2 113 04.03.2017, 12:41
Letzter Beitrag: Skar
  Bedingte Formatierung: Symbolsatz Michael479 6 123 03.03.2017, 10:39
Letzter Beitrag: Michael479
  Bedingte Formatierung in Tabelle moe_zzarella 3 98 02.03.2017, 09:11
Letzter Beitrag: steve1da
  Farbiger Hintergrund als Bedingung für bedingte Formatierung möglich? Calafati 2 105 01.03.2017, 09:42
Letzter Beitrag: Calafati
  Bedingte Formatierung fhares 10 334 28.02.2017, 17:31
Letzter Beitrag: Rabe

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste