Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


bedingte Formatierung
#1
Hallo,

habe ein kleines Problem.
Wer kann helfen?
Ich habe eine Tabelle mit mehreren Spalten.In der Spalte C wird ein Feld über bedingte Formatierung"wenn man rot schreibt,
rot mit weißer schrift ausgefüllt.
grün mit schwarzer Schrift usw.

Nun soll in Spalte B bei rot-rt bei grün-gr blau-bl usw.eingetragen werden.
Geht so etwas?


Huh Bernd
to top
#2
Hallo,

du könntest die Bedingung in der Bedingten Formatierung für die Wenn-Funktion verwenden.

Als Beispiel: Du hast in der Bedingten Formatierung stehen, dass die Schrift rot werden soll wenn der Wert der Zelle größer 10 ist.

In der Wenn-Formel kannst du dann darauf Bezug nehmen: =Wenn(C1>10;"rot";Wenn(C1>5;"grün";"blau")

Wenn du mit diesem Hinweis nicht weiterkommst dann wäre es interessant zu erfahren welche Bedingungen du in der der Bedingten Formatierung verwendest du wie viele unterschiedliche du hast, zumindest lässt das usw. darauf schließen, dass es nicht bei rt, gr und bl bleibt.
Gruß
Peter
to top
#3
Hi Bernd,

wenn ich dich richtig verstanden habe, dann schreibst du in B1:

=WENN(C1="ROT";"rt";"")
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo,

die Variante von Günter geht mit rot.
Wie muss aber die wenn Funktion aussehen,wenn ich die Möglichkeit habe 7 Farben einzutragen,
rot;grün;gelb;blau;braun;grau;weiß



Bernd
to top
#5
Hallo,

bei 7-Wenn-Verschachtelungen könnte die Formel so aussehen:

=WENN(C1="rot";"rt";WENN(C1="Grün";"gr";WENN(C1="Gelb";"ge";WENN(C1="Blau";"bl";WENN(C1="Braun";"br";WENN(C1="Grau";"gr";WENN(C1="weiß";"we";"")))))))

Du könntest aber auch einen Matrix aufbauen, z.B. in E1 bis E7 die Farben und in D1 bis D7 die Abkürzungen und dann einen Sverweis verwenden:

=Sverweis(C1;E:D;2;0)

Das hätte den Vorteil, dass du, falls notwendig weitere ergänzende Farben und Beschreibungen problemlos hinzufügen kannst.
Gruß
Peter
to top
#6
Danke Peter,

klappt bestens.
Habe die wenn Funktion genutzt.
Bei der Matrix habe ich so meine Probleme.

Schönes WE

Bernd
to top
#7
Hallo,

die Variante mit Sverweis würde so aussehen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDE
1AAntonAntonA
2A BertaB
3  CäsarC
4  DoraD
5    

ZelleFormel
B1=SVERWEIS(C1;D:E;2;0)
B2=VERWEIS({"Anton"."Berta"."Cäsar"."Dora"};{"A"."B"."C"."D"})
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Und wenn du jetzt in D5 und E5 einen weiteren Namen/Farbe eingibst dann wird das sofort in der Formel berücksichtigt - und die Formel ist übersichtlicher.

Man könnte auch auf die Matrix verzichten und z.B. wie in B2 mit einer Funktion wie Verweis() arbeiten - nur so als Hinweis.
Gruß
Peter
to top
#8
Danke

auch das habe ich jetzt verstanden.Nun habe ich alle Möglichkeiten.

Nochmals ein schönes WE

Bernd
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Bedingte Formatierung - Telefonnummer promenade 1 58 02.12.2016, 19:53
Letzter Beitrag: WillWissen
  Bedingte Formatierung offen / erledigt cuba 9 60 02.12.2016, 14:40
Letzter Beitrag: cuba
  bedingte Formatierung: wenn Zellwert>anderer Zellwert Stefan Link 6 66 02.12.2016, 07:23
Letzter Beitrag: BoskoBiati
Shocked Bedingte Formatierung funktioniert nicht Osccon 6 76 01.12.2016, 21:21
Letzter Beitrag: WillWissen
  Bedingte Formatierung zum hervorheben ob Termine eingehalten werden Annette 1 71 20.11.2016, 14:59
Letzter Beitrag: BoskoBiati
  Datumsüberprüfung/Bedingte Formatierung keineahnungvonnix 2 54 17.11.2016, 10:34
Letzter Beitrag: keineahnungvonnix
  Bedingte Formatierung: Wert zwischen zwei Datumsfelder anzeigen Sunny2000N 2 50 15.11.2016, 16:06
Letzter Beitrag: Sunny2000N
  Bedingte Formatierung mit 3 Bedingungen Wulfgar 4 58 10.11.2016, 12:44
Letzter Beitrag: Wulfgar
  Bei bedingter Formatierung die Formatierung der Zelle berücksichtigen SGMP 7 118 04.11.2016, 13:50
Letzter Beitrag: SGMP
  Bedingte Formatierung Datum Sunny2000N 2 78 02.11.2016, 11:34
Letzter Beitrag: Sunny2000N

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste