Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Ersten drei Stellen einer Zeile ersetzen
#1
Question 
Hallo Leute,

Bsp:
A1(ProduktID)=100
B1(EAN)=8812312
A2(ProduktID)=101
B2(EAN)=08999999
A3(ProduktID)=102
B3(EAN)=008999998

Ich versuche jetzt, alle EAN's einheitlich mit einer 0 an erster Stelle zu versehen.
Ich habe es jetzt schonmal versucht:
=ERSETZEN(B1;SUCHEN(C1;B1);1;"08") <- das hat auch soweit geklappt, jetzt sind alle EAN's die mit einer "8" anfangen mit "08".
Doch wie suche ich jetzt in der gleichen Zeile nach "008", ohne das ich die andere Formel zerstöre ?


Danke für eure Mühen.
to top
#2
Hallo,

war da vielleicht der Ansatz schon falsch? Wo kommen die 008-Nummern her? Gab es schon Nummern mit 08 am Anfang, dann wurde daraus eben 008.
Mit dieser Formel gäbe es das Problem nicht:

Code:
=0&WECHSELN(B8;0;"";1)

oder auch so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCD
888123120881231208812312
9089999990899999908999999

ZelleFormel
C8=0&WECHSELN(B8;0;"";1)
D8=WENN(LINKS(B8;1)="8";0;"")&B8
C9=0&WECHSELN(B9;0;"";1)
D9=WENN(LINKS(B9;1)="8";0;"")&B9
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Guten Tag Edgar,
ich habe von unterschiedlichen Quellen, diese EAN's bekommen.
Halt einmal mit 008..., einmal mit 08.. und einmal mit 88.
Und ich will die jetzt einheitlich alle auf 08.. setzen.
to top
#4
Hi,

und was gefällt Dir an Ingos Vorschlag im MOF nicht?!

=TEXT(B1;"000000000")

Er hat sich nur mit der Anzahl der Nullen vertan. Anstatt 9 müssten es eben nur 8 sein:

=TEXT(B1;"00000000")

Gruß Uwe
to top
#5
So ich bin die Antwort von Edgar nochmal durchgegangen.
Meine tabelle sieht wie folgt aus:

Zeile
A B
1 Art. 101 Ean: 0088381654579
2 Art. 199 Ean: 088381654512
3 Art.1547 Ean: 88381654559

wenn ich in C1=WENN(LINKS(B1;1)="8";0;"")&B1 dann würde Excel die zwei "00" drin lassen.
Also C1=WENN(LINKS(B1;1)="8";0;WENN(LINKS(B1;2)="00";0;"")&B8
<- so würde Excel bei "00" auf "0" konvertieren und bei "8" würde er "08".

Doch leider funktioniert die Formel so nicht.
to top
#6
Hallo,

versuchs mal so

Code:
=WENN(LINKS(B1;1)="8";"0"&B1;WENN(LINKS(B1;2)="00";RECHTS(B1;12);B1))
Gruß Stefan
Win 7 / Office 2007
to top
#7
Hallo!
Wo genau ist denn jetzt das Problem, Uwes resp. Ingos Formel umzusetzen?

 AB
10088381654579088381654579
2088381654512088381654512
388381654559088381654559

ZelleFormatWert
A1@0088381654579

ZelleFormel
B1=TEXT(A1;"000000000000")

Gruß, Ralf
to top
#8
hat funktioniert, vielen vielen dank an allen.

kurz noch eine frage,
zur erläuterung der formel.
wenn links an der ersten stelle 9 steht dann setze ein 0 plus den rest.
wenn links an den ersten zwei stellen eine 00 steht, dann rechts ?! was ist dann mit rechts gemeint und was hat das mit der 12 auf sich ?
to top
#9
hätte das ganz auch einfach ohne links rechts funktioniert ?
also b1;an stelle 1;...
to top
#10
Hallo,

(13.10.2014, 10:45)plissken90 schrieb: kurz noch eine frage,
zur erläuterung der formel.
wenn links an der ersten stelle 9 steht dann setze ein 0 plus den rest.
wenn links an den ersten zwei stellen eine 00 steht, dann rechts ?! was ist dann mit rechts gemeint und was hat das mit der 12 auf sich ?

Du weißt was deine Links-Formel macht? Wenn ja, dürfte es kein Problem sein, die Rechts-Formel zu verstehen. Wenn dein EAN die Doppelnull enthält, hat die EAN bei deinem Muster genau 13 Stellen. Ich lasse damit einfach das erste Zeichen weg.

Persönlich finde ich die Formel von Ingo, Uwe und Ralf viel besser.
Gruß Stefan
Win 7 / Office 2007
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Ersetzen von Bestandteilen in Hyperlinks Icepic 2 41 29.11.2016, 17:23
Letzter Beitrag: Fennek
  #Wert! mit "Text" ersetzen VBA GustavL 10 124 29.11.2016, 14:47
Letzter Beitrag: GustavL
  Ersetzen mit "Zelleninhalt" bei Makro madcorby 4 79 11.11.2016, 17:56
Letzter Beitrag: schauan
Lightbulb VBA Zeile in eine Arbeitsmappe kopieren wenn in der Zeile eine 1 steht Olossos 8 108 11.11.2016, 17:08
Letzter Beitrag: Kuwer
Question Anzahl der Einträge in einer Zeile zählen (nicht Zahlen) Olivenbaum2013 6 84 11.11.2016, 10:35
Letzter Beitrag: Olivenbaum2013
  Bestimmte Zeile aus einer Zelle ausgeben Julian22 7 148 09.11.2016, 09:17
Letzter Beitrag: Julian22
  Excel VBA: Suchen und Ersetzen Goleo 1 50 08.11.2016, 14:52
Letzter Beitrag: Kuwer
  Suchen und Ersetzen innerhalb einer Zelle Nelson 4 98 04.11.2016, 14:16
Letzter Beitrag: Kuwer
  7 Stellen in einer Zelle zulassen stefanberg 2 93 28.10.2016, 10:15
Letzter Beitrag: schauan
  Gleiche Werte einer Spalte in eine Zeile überführen jepjep 15 259 16.10.2016, 11:05
Letzter Beitrag: shift-del

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste