Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Monatskalender erstellen
#1
Hallo, Excel-Freunde!

Für eine bestimmte Aufgabenstellung suche ich mir gerade einen Wolf, ob es eine einfache Lösung gibt - finde aber nichts.

Die Aufgabe sieht so aus:
In Zelle A1 steht die Nummer des Monats (z. B. 8 für August), in Zelle B1 steht das Jahr (z. B. 2012).
In den Zellen A3 bis G3 stehen die Kürzel für die Wochentage ("MO" ... "SO")
In den nächsten Zeilen, also 4 bis ..., sollen jetzt die Tageszahlen des Monats erscheinen, natürlich passend zum jeweiligen Wochentag.
Für den August 2012 wäre also die "1" in der Zelle C4 zu sehen (A4 und B4 bleiben leer; in D4 steht eine "2" usw., A5 enthält eine "6" usw.)

Gibt es dafür in Excel eine "einfache" Lösung? Momentan breche ich mir bei einem Work-around die Finger, indem ich das Startdatum 01.08.2012 auf seinen Wochentag untersuche, damit die "1" in die richtige Spalte gesetzt wird. Die nachfolgenden Tage rechne ich dann einfach durch (vorherige Zelle + 1).

Hat jemand eine praktikable Lösung?

Besten Dank schon mal!

Der Roadie
to top
#2
Hi,


Schau doch mal hier rein

http://www.excelformeln.de/formeln.html?welcher=284
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
Hallo,

ich bin momentan etwas in Eile, deswegen nur ganz kurz:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGHIJK
2Januar 2010 MonatJahr
3MDMDFSS Januar2010
4    123   
545678910   
611121314151617   
718192021222324   
825262728293031   
9          

ZelleFormel
B2=DATUM(K3;MONAT(J3&0);1)
B4=WENN(MONAT($B$2+SPALTE(A$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2))=MONAT($B$2);$B$2+SPALTE(A$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2);"")
C4=WENN(MONAT($B$2+SPALTE(B$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2))=MONAT($B$2);$B$2+SPALTE(B$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2);"")
D4=WENN(MONAT($B$2+SPALTE(C$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2))=MONAT($B$2);$B$2+SPALTE(C$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2);"")
E4=WENN(MONAT($B$2+SPALTE(D$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2))=MONAT($B$2);$B$2+SPALTE(D$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2);"")
F4=WENN(MONAT($B$2+SPALTE(E$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2))=MONAT($B$2);$B$2+SPALTE(E$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2);"")
G4=WENN(MONAT($B$2+SPALTE(F$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2))=MONAT($B$2);$B$2+SPALTE(F$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2);"")
H4=WENN(MONAT($B$2+SPALTE(G$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2))=MONAT($B$2);$B$2+SPALTE(G$1)+7*(ZEILE($A1)-1)-WOCHENTAG($B$2;2);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Anpassung auf die von dir genannten Zellen solltest du selbst hinbekommen, oder?
Gruß
Peter
to top
#4
@ WillWissen
Danke für deinen Tipp. Den hatte ich auch schon ausprobiert, hat mir aber nicht weitergeholfen

@Peter
Exakt das ist es, was ich brauche! Vielen Dank! 18

Ich schließe damit diesen Trööt.
to top
#5
Hallo auch von mir ein Lösungsvorschlag..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1102014     
2       
3MoDiMiDoFrSaSo
4  12345
56789101112
613141516171819
720212223242526
8272829303112
93456789

ZelleFormel
A4=WENN(WOCHENTAG($A$1&"/"&$B$1;2)=SPALTE(A$1);($A$1&"/"&$B$1)+0;"")
B4=WENN(A4<>"";A4+1;WENN(WOCHENTAG($A$1&"/"&$B$1;2)=SPALTE(B$1);($A$1&"/"&$B$1)+0;""))
C4=WENN(B4<>"";B4+1;WENN(WOCHENTAG($A$1&"/"&$B$1;2)=SPALTE(C$1);($A$1&"/"&$B$1)+0;""))
D4=WENN(C4<>"";C4+1;WENN(WOCHENTAG($A$1&"/"&$B$1;2)=SPALTE(D$1);($A$1&"/"&$B$1)+0;""))
E4=WENN(D4<>"";D4+1;WENN(WOCHENTAG($A$1&"/"&$B$1;2)=SPALTE(E$1);($A$1&"/"&$B$1)+0;""))
F4=WENN(E4<>"";E4+1;WENN(WOCHENTAG($A$1&"/"&$B$1;2)=SPALTE(F$1);($A$1&"/"&$B$1)+0;""))
G4=WENN(F4<>"";F4+1;WENN(WOCHENTAG($A$1&"/"&$B$1;2)=SPALTE(G$1);($A$1&"/"&$B$1)+0;""))
A5=MAX(A4:G4)+1
B5=A5+1
C5=B5+1
D5=C5+1
E5=D5+1
F5=E5+1
G5=F5+1

Zellebedingte Formatierung...Format
A41: =MONAT(A4)<>$A$1abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
@Jockel

Auch dir vielen Dank! Ich teste eure Vorschläge!
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  dynamischer Monatskalender mit Zwischensummen(/-zeilen) für Wochen lmnh 6 101 15.11.2016, 14:46
Letzter Beitrag: Jockel
Question Über bed. Formatierung Geburtstage im Monatskalender anzeigen lassen Lusche800 21 755 01.09.2016, 09:23
Letzter Beitrag: Lusche800

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste