Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Bei Problemen mit der Erreichbarkeit der Foren bitte den Link / Favoriten prüfen und ersetzen. Dazu über die Startseite ins gewünschte Forum wechseln und zu den Favoriten hinzufügen. Excel ist derzeit z.B. unter http://www.clever-excel-forum.de/forum-2.html zu erreichen.


Maximale Summe ohne definierten Bereich finden
#1
Hallo liebe Forenmitglieder,
ich stehe gerade irgendwie auf dem Schlauch. Vielleicht könnt ihr mir helfen.

In vereinfachter Form:
Ich habe folgende Tabelle:
Code:
    A
1    3
2    5
3    2
4    4
5    6
6    8
7    9
8    3
9    4
10    1


Mein Ziel ist es, die maximale Summe und die zugehörige Anfangszeile von 3 hintereinanderstehenden Zahlen zu finden, also hier (6+8+9 mit Beginn A5) und das im Bereich von A1 bis A10. Wenn es sich irgendwie vermeiden lässt, würde ich ungern eine weitere Spalte anlegen.

Hat jemand eine Idee?

Habe schon eine Schleife als Makro überlegt, aber da ich da nicht so fit drin bin, hoffe ich, dass es auch einfacher geht. Und ich wüsste nicht, ob ich so überhaupt ein Maximum ermitteln kann.

Ganz liebe Grüße
Blesbie
to top
#2
Moin,

verwende eine Hilfsspalte. In B3 die Formel =SUMME(A1:A3) und ndann bis zur letzten belegten Zeile (Spalte_A) runter ziehen. Dann per =MAX(B:B) den höchsten Wert errechnen.
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
[-] Folgende(r) 1 Benutzer sagt Danke an GMG-CC für diesen Beitrag:
  • Blesbie
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste