Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Tabelle automatisch vervollständigen
#1
Hallo,

habe momentan ein Projekt am laufen und ich muss bzw möchte ein bisschen Punkten Tongue

Ich habe eine riesen große Tabelle wo Artikel mit ArtNr, ArtBez, Größe, Gewicht usw...
Das habe ich als Datenblatt.

Nun habe ich auf einen Neuen Reiter diese Tabelle kopiert, aber ohne Inhalt.
Ich möchte jetzt dass wenn ich die Artikelnummer eingebe sich die Tabelle automatisch vervollständigt.
Also das Gewicht Größe Artikelbezeichnung automatisch auftauchen.

Ich hoffe es kann mir jemand weiterhelfen.

Vielen Dank
to top
#2
Hallo

das ist eine Sache für den SVerweis()

MfG Tom
to top
#3
Hallo,

ein kleines Beispiel (der Übersichtlichkeit halber in einem Tabellenblatt):

Tabelle1

ABCDEFGHI
1ArtNrArtikelGrößeA10Art11
2A10Art11A30Art33
3A20Art22
4A30Art33
Formeln der Tabelle
ZelleFormel
H1=SVERWEIS($G1;Tabelle1!$A:$C;SPALTE(B1);0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Die Formel in H1 kannst du nach rechts und nach unten kopieren.
Gruß
Peter
to top
#4
(06.10.2014, 18:28)Peter schrieb: Hallo,

ein kleines Beispiel (der Übersichtlichkeit halber in einem Tabellenblatt):

Tabelle1

ABCDEFGHI
1ArtNrArtikelGrößeA10Art11
2A10Art11A30Art33
3A20Art22
4A30Art33
Formeln der Tabelle
ZelleFormel
H1=SVERWEIS($G1;Tabelle1!$A:$C;SPALTE(B1);0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Die Formel in H1 kannst du nach rechts und nach unten kopieren.


Leider kann ich dir nicht ganz Folgen.
Habe deine Tabelle abkopiert und es versucht und auch bei excel die Hilfe zu SVerweis angeschaut...
to top
#5
Hallo,

und wo ist dein Problem genau? Bekommst du eine Fehlermeldung? Passen die Ergebnisse nicht?

Die Spalten A bis C sind die eigentliche Datentabelle. In G1 und G2 gibst du die gesuchte Artikelnummer ein. Die Formel kommt in H1 und wird nach rechts und nach unten kopiert.

Den Tabellenblattnamen 'Tabelle1' in der Formel musst du evtl. auf deine Verhältnisse anpassen.

Achte auch darauf, dass du Zahl mit Zahl oder Text mit Text vergleichst: Wenn z.B. in Tabelle1 die Art.Nr. ein Text ist und in Tabelle2 eine Zahl dann findet der Sverweis keine Übereinstimmung und gibt dir ein #NV aus.
Gruß
Peter
to top
#6
Hallo Peter, Hallo djmcp,

@Peter: Wenn ich mir die Frage von dem TE anschaue, scheint es so als wenn er in seiner "neuen" Tabelle die Daten anders herum auflisten lassen will.

Zitat:Ich habe eine riesen große Tabelle wo Artikel mit ArtNr, ArtBez, Größe, Gewicht usw
Zitat:Also das Gewicht Größe Artikelbezeichnung

@djmcp: Wichtig ist erst einmal, dass Du den SVERWEIS verstehst. Dann hat Dir Peter noch einen wichtigen Hinweis mit dem Tabellenblattnamen gegeben.

Du mußt in diesem Fall die Formel: =SVERWEIS($G1;Tabelle1!$A:$C;SPALTE(B1);0) in =SVERWEIS($G1;Dein_Tabellenblattname!$A:$C;SPALTE(B1);0) umbenennnen.

Schlüsseln wir den SVERWEIS auf:
So wäre, auch das hat Peter bereits geschrieben, $G1 der gesuchte "Wert" z.B. A20. Dieser Eintrag wird in dem Bereich Dein_Tabellenblattname!$A:$C gesucht. Bei einem Treffer können Dir Daten ausgegeben werden. Peter hat es Dir hier einfach gemacht, in dem er dort SPALTE(B1) eingetragen hat. Das trifft aber nur zu, wenn Du die Daten so ausliest, wie Du sie in der Haupttabelle eingetragen hast.
Was macht SPALTE? Dieser Teil der Formel liest die Spaltenzahl aus. A=1, B=2, C=3, usw. In der "normalen" Sverweis - Formel wird das auch so eingetragen. Das heißt Dein Artikel stände im o.g. Beispiel in Spalte 2 und die Größe in Spalte 3.
Das wiederum bedeutet, dass, wenn wir mit dem normalen SVERWEIS arbeiten und die Größe ermitteln wollten, sähe die Formel so aus: =SVERWEIS($G1;Dein_Tabellenblattname!$A:$C;3;0). Der Artikel würde mit =SVERWEIS($G1;Dein_Tabellenblattname!$A:$C;2;0) gegriffen.

Am Schluß der Formel steht noch eine "0". Der brauchst Du hier keine Beachtung zu schenken. Nur um es einmal genannt zu haben, handelt es sich dabei um einen Wahrheitswert. Die 0 sagt, es muss genau der gesuchte "Wert" in der Tabelle stehen. Würde da eine 1 stehen, so würde es ausreichen, einen ungefähren Wert zu finden.

Ich hoffe, ich konnte Dir mit meiner kurzen Ausführung etwas helfen. Es ist nicht einfach, solche Formeln in einem Beitrag festzuschreiben. Solltest Du weitere Fragen haben, so frag. Wir versuchen es Dir zu erläutern.

Gruß
Marcus

Erklärung ein bißchen strukturiert.
Moderator
?mage

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#7
Hi,

wenn Du nicht nur an einer fertigen Lösung (die Du wahrscheinlich nicht nachvollziehen und bei Änderungen anpassen könntest) interessiert bist, sondern die Funktion =SVERWEIS() auch verstehen möchtest, schau Dir doch mal diesen kleinen Workshop [KLICK] an ...
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Tabelle automatisch füllen Falco 6 96 16.11.2016, 17:21
Letzter Beitrag: Falco
  Tablle nach Auswahl anzeigen/Vervollständigen donangel85 9 193 29.10.2016, 19:40
Letzter Beitrag: donangel85
  Werte von einer Tabelle in die andere übertragen (automatisch) TheBug 9 328 19.09.2016, 10:52
Letzter Beitrag: TheBug
  einen Feldwert automatisch vervollständigen Leinberger 4 239 01.08.2016, 11:29
Letzter Beitrag: Leinberger
  Formularvorlage mit Daten aus Tabelle automatisch ausfüllen vicky 9 512 28.04.2016, 11:47
Letzter Beitrag: vicky
  Daten automatisch in eine andere Tabelle übernehmen Kai von Goetz 5 707 11.03.2016, 07:59
Letzter Beitrag: Kai von Goetz
  Tabelle automatisch für mehrere Jahre füllen Jenna91 24 1.754 09.01.2016, 12:36
Letzter Beitrag: schauan
  Daten aus anderer Tabelle automatisch auf Spalten verteilen milano49 3 491 06.01.2016, 01:23
Letzter Beitrag: WillWissen
  Tabelle automatisch erstellen Tarkrai 9 760 28.12.2015, 15:17
Letzter Beitrag: RPP63
  automatisch erweiternde Tabelle ohne Dublikat auf neuem Blatt wernqq 5 687 12.12.2015, 05:29
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste