Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Zellen nach Hintergrundfarben zählen
#1
Moin zusammen,

hatt hier einer einen Plan oder einen Lösungsansatz wie ich ohne Makro Zellen nach ihrer Hintergrundfrabe zählen kann. So in etwa:=ZÄHLENWENN(A1:A13;"Colorindex gelb").

Danke
Hagen
to top
#2
Hallo Hagen, das kommt darauf an, wie die Zellen gefärbt wurden... Wenn sie händisch (also ohne bedingte Formatierung) gefärbt wurden, geht's nicht ohne Makro bzw. Makro4...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo,

es ist keine gute Idee Berechnungen aufgrund von Formatierungen durchzuführen, da dies in XL so nicht vorgesehen ist.

Ich würde mir überlegen, ob es andersherum nicht sinnvoller ist:

Eine Kennziffer in die Zelle und dann über die Bedindgte Formatierung die Zelle entsprechend einfärben.

Alternativ könntest du es mit einer Hilfsspalte auch so versuchen und den Colorindex über ein Excel4-Makro bestimmen:

Menü Formeln - Namen definieren - Name in der Arbeitsmappe: 'Schrift' - bezieht sich auf:

=ZELLE.ZUORDNEN(63;INDIREKT("ZS(-1)";FALSCH))

Wenn du nun die folgende Formel eingibst wird die Hintergrundfarbe der jeweils links davon stehenden Zelle ausgegeben:

=Schrift

und dann kannst du wieder mit Zählenwenn() arbeiten.

Aber Achtung: Alle Verfahren, die sich auf die Farbe von Zellen oder Schriften beziehen, haben gemeinsam dass sie sich bei der Veränderung der Farbe nicht automatisch aktualisieren.
Gruß
Peter
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Buchstaben von verschiedenen Zellen zählen loxer 15 313 17.01.2017, 15:37
Letzter Beitrag: loxer
  Feldauffüllung eines Feldes f mit natürlichen Zahlen nach Muster Diamant 6 205 15.01.2017, 16:37
Letzter Beitrag: schauan
  Unterschiedliche Zellen zählen und quantitativ bewerten joshua 1 74 03.12.2016, 23:46
Letzter Beitrag: schauan
  Überprüfung von Zellen nach Buchstaben in unterschiedlicher Reihenfolge Maya14 9 146 02.12.2016, 12:45
Letzter Beitrag: BoskoBiati
  Krankentage je nach Wochentag zählen Christiane W. 3 141 28.11.2016, 14:15
Letzter Beitrag: BoskoBiati
Question Anzahl der Einträge in einer Zeile zählen (nicht Zahlen) Olivenbaum2013 6 170 11.11.2016, 10:35
Letzter Beitrag: Olivenbaum2013
  Zellen nach ausfüllen dauerhaft schützen bietho 18 742 27.10.2016, 09:42
Letzter Beitrag: headloose
Wink Listen von vorne (nach gewisser Anzahl von Zellen) wiederholen JoJo2807 6 154 26.10.2016, 20:22
Letzter Beitrag: snb
Sad leere Zellen zählen von der letzten Befüllten Zelle aus loga 36 1.558 13.09.2016, 15:39
Letzter Beitrag: schauan
Brick Zellen nach Eintrag bereinigen BIGE.l.f.e 20 945 12.09.2016, 08:06
Letzter Beitrag: BIGE.l.f.e

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste