Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Zellen nach Hintergrundfarben zählen
#1
Moin zusammen,

hatt hier einer einen Plan oder einen Lösungsansatz wie ich ohne Makro Zellen nach ihrer Hintergrundfrabe zählen kann. So in etwa:=ZÄHLENWENN(A1:A13;"Colorindex gelb").

Danke
Hagen
to top
#2
Hallo Hagen, das kommt darauf an, wie die Zellen gefärbt wurden... Wenn sie händisch (also ohne bedingte Formatierung) gefärbt wurden, geht's nicht ohne Makro bzw. Makro4...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo,

es ist keine gute Idee Berechnungen aufgrund von Formatierungen durchzuführen, da dies in XL so nicht vorgesehen ist.

Ich würde mir überlegen, ob es andersherum nicht sinnvoller ist:

Eine Kennziffer in die Zelle und dann über die Bedindgte Formatierung die Zelle entsprechend einfärben.

Alternativ könntest du es mit einer Hilfsspalte auch so versuchen und den Colorindex über ein Excel4-Makro bestimmen:

Menü Formeln - Namen definieren - Name in der Arbeitsmappe: 'Schrift' - bezieht sich auf:

=ZELLE.ZUORDNEN(63;INDIREKT("ZS(-1)";FALSCH))

Wenn du nun die folgende Formel eingibst wird die Hintergrundfarbe der jeweils links davon stehenden Zelle ausgegeben:

=Schrift

und dann kannst du wieder mit Zählenwenn() arbeiten.

Aber Achtung: Alle Verfahren, die sich auf die Farbe von Zellen oder Schriften beziehen, haben gemeinsam dass sie sich bei der Veränderung der Farbe nicht automatisch aktualisieren.
Gruß
Peter
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Zellen für Formel nach Kategorien ordnen Askyneedsclouds 10 161 13.03.2017, 19:28
Letzter Beitrag: shift-del
  Zellen je nach Farbe sperren Ralf1 1 123 17.02.2017, 20:05
Letzter Beitrag: schauan
  Zahlen aus mehreren Zellen zusammenfügen / Zahlen auch mit 0 beginnend JoergPorsch 3 114 09.02.2017, 22:32
Letzter Beitrag: JoergPorsch
  Zellen aufwärts nach Merkmal durchsuchen UnionJack 4 138 08.02.2017, 15:47
Letzter Beitrag: Rabe
  Zählen nach Datum wenn/oder sash! 28 579 03.02.2017, 14:05
Letzter Beitrag: sash!
  Zellen nach Punkten ausrichten Alexandraa 2 121 28.01.2017, 11:34
Letzter Beitrag: Alexandraa
  Buchstaben von verschiedenen Zellen zählen loxer 15 531 17.01.2017, 15:37
Letzter Beitrag: loxer
  Feldauffüllung eines Feldes f mit natürlichen Zahlen nach Muster Diamant 6 291 15.01.2017, 16:37
Letzter Beitrag: schauan
  Unterschiedliche Zellen zählen und quantitativ bewerten joshua 1 156 03.12.2016, 23:46
Letzter Beitrag: schauan
  Überprüfung von Zellen nach Buchstaben in unterschiedlicher Reihenfolge Maya14 9 358 02.12.2016, 12:45
Letzter Beitrag: BoskoBiati

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste