Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Excel Formel nur die größten 5 Werte einer Kategorie addieren
#1
Hallo,

ich brauche Hilfe um nur die größten 5 Werte einer Kategorie zu addieren. Und die zwei Kategorien mit den Höchsten Werten anzuzeigen zu lassen.

Vielen Dank schonmal im voraus

z.B


1 Hans 95 Wer hat nun die größten 5 Werte zusammen gerechnet Hans oder Peter?
2 Peter 96
3 Peter 90
4 Hans 91
5 Hans 0
6 Peter 97
7 Hans 93
8 Peter 95
9 Hans 90
10 Hans 92
11 Peter 93
to top
#2
Hallo,

Woran machst Du bei Deinem Beispiel die Kathegorie fest? Ich sehe dort keine. Bei deinem Beispiel, nur die 5 größten Werte, ginge ungefähr so:

=SUMMENPRODUKT(KGRÖSSTE(A1:A11;ZEILE(1:11))*1)

Kann das jetzt aber nachprüfen, da ich mit dem IPad dran bin (da gibt es kein richtiges Excel). Versuche es mal so. Natürlich muss das Wort Kathegorie gegen deine ausgetauscht werden.

=SUMMENPRODUKT(KGRÖSSTE(A1:A11;ZEILE(1:11))*1*Kathegorie)
Grüße
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#3
Vielen Dank für die schnelle Antwort.

Das Funktioniert leider nicht. Die Kategorie soll Hans oder Peter sein. Und nur die größten 5 Werte dahinter (95,96,92,...) von Hans sollen addiert werden.

Gruß Seddy
to top
#4
Hallo noch einmal,

hat mir jetzt keine Ruhe gelassen und ich habe mir meinen kleinen Laptop geholt. So würde ein Schuh draus:

Tabelle1

ABCDEF
1HansEssen15111
2PeterTrinken25
3PeterEssen30
4HansTrinken24
5PeterSaugen23
6HansKochen23
7PeterKochen15
8PeterKochen40
9HansKochen11
10HansKochen22
Formeln der Tabelle
ZelleFormel
F1{=SUMME(KGRÖSSTE(WENN(B1:B10="Kochen";C1:C10);ZEILE(1:5)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#5
In der Zeit wo ich geantwortet habe hast auch Du gepostet ... Brauchst Du nur so anpassen

Tabelle1

ABCDE
1Hans1595
2Peter25
3Peter30
4Hans24
5Peter23
6Hans23
7Peter15
8Peter40
9Hans11
10Hans22
Formeln der Tabelle
ZelleFormel
E1{=SUMME(KGRÖSSTE(WENN(A1:A10="Hans";B1:B10);ZEILE(1:5)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#6
Hallo,

oder ohne Formeln mit einer einfachen Pivottabelle:

Arbeitsblatt mit dem Namen 'Tabelle3'
 ABCDF
1NameWert   
2Hans15  Hans
3Peter25   
4Peter30  Summe von Wert
5Hans24  11
6Peter23  15
7Hans23  22
8Peter15  23
9Peter40  24
10Hans11  95
11Hans22   
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
to top
#7
Hallo Markus und Peter,

Ich bekomme den Fehler #ZAHL!
Habe das eingegeben: =SUMME(KGRÖSSTE(WENN(A3:A27="Fritz";B3:B27);ZEILE(1:5))).
Muss man sonst noch irgendwas einstellen??


Hab leider keine Ahnung von Pivottabellen.

Gruß Seddy
to top
#8
Hallo,

Enthält Matrixformel:
Umrandende { } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!

Hast Du das beachtet?

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#9
Hallo,

wenn die Darstellung der Pivottabelle für dich eine Alternative ist dann kann ich dir gerne erläutern wie ich das erstellt habe.

Ich wollte das nur nicht im Vorfeld machen weil die Beschreibung deutlich länger geht als das Erstellen selbst und wenn dann der Hinweis kommt, dass eine PT aus irgendwelchen Gründen nicht möglich ist dann war das verlorene Zeit.

Zur Fehlermeldung Zahl: Hast du beachtet, dass die Formel mit Strg-Shift-Enter abgeschlossen werden muss (die Klammern dürfen nicht mit eingegeben/kopiert werden, sondern werden dann durch diese Tastenkombination erzeugt).
Gruß
Peter
to top
#10
Ja das habe ich beachtet. Habe sie nicht mit eingegeben und mit Strg+shift+return eingegeben
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Formel für Mittelteil einer Zelle Felix T. 9 82 19.01.2017, 16:40
Letzter Beitrag: BoskoBiati
  Werte in einer Zeile addieren bis Zielwert erreicht und verwendete Werte markieren hoteu 2 60 12.01.2017, 13:04
Letzter Beitrag: hoteu
  Formel von Excel 2016 in Excel 2007 verwenden Thomas78 2 61 11.01.2017, 10:22
Letzter Beitrag: Thomas78
  Excel Formel Berechnung Uwe 2 60 10.01.2017, 08:48
Letzter Beitrag: Uwe
  Eine klassische Excel-Formel... benediktstoeber 15 277 09.01.2017, 14:11
Letzter Beitrag: lupo1
  Werte aus verschiedenen Zellen auslesen und in einer Zelle eintragen Robbie1985 2 46 07.01.2017, 10:39
Letzter Beitrag: WillWissen
  Werte addieren/subtrahieren - je nach Bedingung Zweiundzwanzig 4 100 05.01.2017, 09:55
Letzter Beitrag: Zweiundzwanzig
  MW der letzten 5 Werte einer Spalte tröntken 6 97 05.01.2017, 07:57
Letzter Beitrag: tröntken
  Addieren von Namen Tobias159 1 51 03.01.2017, 16:44
Letzter Beitrag: schauan
  2 Werte mit definierten Kriterien aus einer Zelle Multiplizieren heppi14 6 141 28.12.2016, 23:29
Letzter Beitrag: Jockel

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste