Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Excel Formel nur die größten 5 Werte einer Kategorie addieren
#1
Hallo,

ich brauche Hilfe um nur die größten 5 Werte einer Kategorie zu addieren. Und die zwei Kategorien mit den Höchsten Werten anzuzeigen zu lassen.

Vielen Dank schonmal im voraus

z.B


1 Hans 95 Wer hat nun die größten 5 Werte zusammen gerechnet Hans oder Peter?
2 Peter 96
3 Peter 90
4 Hans 91
5 Hans 0
6 Peter 97
7 Hans 93
8 Peter 95
9 Hans 90
10 Hans 92
11 Peter 93
to top
#2
Hallo,

Woran machst Du bei Deinem Beispiel die Kathegorie fest? Ich sehe dort keine. Bei deinem Beispiel, nur die 5 größten Werte, ginge ungefähr so:

=SUMMENPRODUKT(KGRÖSSTE(A1:A11;ZEILE(1:11))*1)

Kann das jetzt aber nachprüfen, da ich mit dem IPad dran bin (da gibt es kein richtiges Excel). Versuche es mal so. Natürlich muss das Wort Kathegorie gegen deine ausgetauscht werden.

=SUMMENPRODUKT(KGRÖSSTE(A1:A11;ZEILE(1:11))*1*Kathegorie)
Grüße
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#3
Vielen Dank für die schnelle Antwort.

Das Funktioniert leider nicht. Die Kategorie soll Hans oder Peter sein. Und nur die größten 5 Werte dahinter (95,96,92,...) von Hans sollen addiert werden.

Gruß Seddy
to top
#4
Hallo noch einmal,

hat mir jetzt keine Ruhe gelassen und ich habe mir meinen kleinen Laptop geholt. So würde ein Schuh draus:

Tabelle1

ABCDEF
1HansEssen15111
2PeterTrinken25
3PeterEssen30
4HansTrinken24
5PeterSaugen23
6HansKochen23
7PeterKochen15
8PeterKochen40
9HansKochen11
10HansKochen22
Formeln der Tabelle
ZelleFormel
F1{=SUMME(KGRÖSSTE(WENN(B1:B10="Kochen";C1:C10);ZEILE(1:5)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#5
In der Zeit wo ich geantwortet habe hast auch Du gepostet ... Brauchst Du nur so anpassen

Tabelle1

ABCDE
1Hans1595
2Peter25
3Peter30
4Hans24
5Peter23
6Hans23
7Peter15
8Peter40
9Hans11
10Hans22
Formeln der Tabelle
ZelleFormel
E1{=SUMME(KGRÖSSTE(WENN(A1:A10="Hans";B1:B10);ZEILE(1:5)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#6
Hallo,

oder ohne Formeln mit einer einfachen Pivottabelle:

Arbeitsblatt mit dem Namen 'Tabelle3'
 ABCDF
1NameWert   
2Hans15  Hans
3Peter25   
4Peter30  Summe von Wert
5Hans24  11
6Peter23  15
7Hans23  22
8Peter15  23
9Peter40  24
10Hans11  95
11Hans22   
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
to top
#7
Hallo Markus und Peter,

Ich bekomme den Fehler #ZAHL!
Habe das eingegeben: =SUMME(KGRÖSSTE(WENN(A3:A27="Fritz";B3:B27);ZEILE(1:5))).
Muss man sonst noch irgendwas einstellen??


Hab leider keine Ahnung von Pivottabellen.

Gruß Seddy
to top
#8
Hallo,

Enthält Matrixformel:
Umrandende { } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!

Hast Du das beachtet?

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#9
Hallo,

wenn die Darstellung der Pivottabelle für dich eine Alternative ist dann kann ich dir gerne erläutern wie ich das erstellt habe.

Ich wollte das nur nicht im Vorfeld machen weil die Beschreibung deutlich länger geht als das Erstellen selbst und wenn dann der Hinweis kommt, dass eine PT aus irgendwelchen Gründen nicht möglich ist dann war das verlorene Zeit.

Zur Fehlermeldung Zahl: Hast du beachtet, dass die Formel mit Strg-Shift-Enter abgeschlossen werden muss (die Klammern dürfen nicht mit eingegeben/kopiert werden, sondern werden dann durch diese Tastenkombination erzeugt).
Gruß
Peter
to top
#10
Ja das habe ich beachtet. Habe sie nicht mit eingegeben und mit Strg+shift+return eingegeben
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Matrix bzw. Schnittpunkt der gesuchten Werte in einer Tabelle suchen Wolf59 5 57 Vor 2 Stunden
Letzter Beitrag: Wolf59
  Rezepte in einer Excel-Datenbank speichern Dude 8 169 Heute, 09:25
Letzter Beitrag: Dude
  Werte Zusammenzählen mit Suchkriterium in einer anderen Spalte EDmen 6 71 05.12.2016, 20:49
Letzter Beitrag: EDmen
  Excel Formel mit mehreren Verschachtelungen? Mike1893 9 115 02.12.2016, 12:00
Letzter Beitrag: Mike1893
  Excel-Formel für 15 übereinstimmende Antworten MrPeabody87 7 140 28.11.2016, 17:02
Letzter Beitrag: Fennek
  Excel Formel für Lagerbestand und Bestellung Mocki 4 88 25.11.2016, 21:29
Letzter Beitrag: schauan
  Werte in Excel dauerhaft speichern (loggen) Höpp 3 82 25.11.2016, 20:46
Letzter Beitrag: schauan
  Formel in VBA statt in Excel? Spike87 14 246 23.11.2016, 09:42
Letzter Beitrag: Spike87
  ZählenWenn-Formel - Excel 2010 Clownfisch 1 68 08.11.2016, 09:50
Letzter Beitrag: RPP63
  Zellen prüfen und dann addieren h76469 1 53 05.11.2016, 08:53
Letzter Beitrag: WillWissen

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste