Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Differenz von Kalenderwochen
#1
Hallo,

aufgrund einer Diskussion zur Berechnung der Differenz zwischen zwei Kalenderwochen, habe ich mal ein paar Formeln erstellt:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJ
1Beginn (Jahr/ KW)Ende (Jahr/ KW)      
2201650201710 1212121212

ZelleFormel
F2=REST(D2-B2;52+(B2>D2)*(KALENDERWOCHE(--("1.1."&C2);21)=53))
G2=(7*RUNDEN((7&1-C2)/7+D2;0)+177-(7*RUNDEN((7&1-A2)/7+B2;0)+177))/7
H2=RUNDEN((7&1-C2)/7+D2;0)-RUNDEN((7&1-A2)/7+B2;0)
I2=D2-B2+RUNDEN((7&1-C2)/7;0)-RUNDEN((7&1-A2)/7;0)
J2=REST(D2-B2;52+(REST(7&1-C2;7)>3)*(REST(7&1-A2;7)<4))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Alle Formeln berechnen die Differenz zwischen Montag der ersten und Montag der zweiten KW! Sollen beide KW´en berücksichtigt werden ist generell noch 1 zu addieren!


Teilweise beruhen sie auf den Formeln die hier vorgestellt wurden (mit *).

*=(7*RUNDEN((7&1-C2)/7+D2;0)+177-(7*RUNDEN((7&1-A2)/7+B2;0)+177))/7
*=RUNDEN((7&1-C2)/7+D2;0)-RUNDEN((7&1-A2)/7+B2;0)
*=D2-B2+RUNDEN((7&1-C2)/7;0)-RUNDEN((7&1-A2)/7;0)
=REST(D2-B2;52+(B2>D2)*(KALENDERWOCHE(--("1.1."&C2);21)=53))

=REST(D2-B2;52+(REST(7&1-C2;7)>3)*(REST(7&1-A2;7)<4))
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Zitatantwort to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste