Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Wenn Zelle leer, dann ""
#1
Hallo,

ich habe folgende Formel: INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)) und möchte erreichen, dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Dazu habe ich folgende Formeln gefunden:

=WENN(Formel)=0,"",(Formel)) oder
=WENN(ISTLEER(Formel),"",Formel)

Folgende Formel funktioniert einwandfrei:
=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)))))

Leider kann taucht beim ziehen der Formel nach rechts oder unten "FEHLER" auf. Was mache ich falsch?
Vorab vielen Dank!

Liebe Grüße
to top
#2
Ich hab's!

=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1))))

:-)
to top
#3
Hallo,

Zitat: dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Ich würde in diesem Fall einfach mit einem benutzerdefinierten Zahlformat arbeiten. Das könnte z.B. so aussehen:

#.##0,00;-#.##0,00;

oder auch so

0;-0;

Wichtig ist das letzte Semikolon dass die Null ausblendet.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
veve
to top
#4
Das ist ein super Tipp!
Danke!

Liebe Grüße
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Aktion ausführen wenn Zelle verlassen wird Wilfried 4 41 Vor 5 Stunden
Letzter Beitrag: schauan
  WENN DANN FUNKTION MIT SVERWEIS? lilkfa 4 56 Vor 10 Stunden
Letzter Beitrag: coemm
  Wenn Dann Zelle leeren pingu312 4 78 23.02.2017, 17:59
Letzter Beitrag: atilla
  Wenn Dann Verschachtelte Funktion snoopy4000_0 5 70 15.02.2017, 11:00
Letzter Beitrag: Luffy
Sad Zählenwenn Zeilen leer Hammsi 12 161 13.02.2017, 18:52
Letzter Beitrag: Hammsi
  nur wenn spalte ="A", dann Formel... ravi 6 83 13.02.2017, 11:24
Letzter Beitrag: steve1da
  Wenn dann sonst anders Lefixe 7 175 10.02.2017, 12:33
Letzter Beitrag: lupo1
  Text in Textfeld ändern, wenn bestimmte Zelle aktiv ist michi89287 4 90 04.02.2017, 07:55
Letzter Beitrag: michi89287
  Wenn-Dann-Formel Mukikuki 1 70 30.01.2017, 09:08
Letzter Beitrag: lupo1
Question Wenn ZelleA=Datum, dann=Tabelle/Spalte/Zelle Royle 3 100 28.01.2017, 20:23
Letzter Beitrag: Ego

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste