Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Wenn Zelle leer, dann ""
#1
Hallo,

ich habe folgende Formel: INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)) und möchte erreichen, dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Dazu habe ich folgende Formeln gefunden:

=WENN(Formel)=0,"",(Formel)) oder
=WENN(ISTLEER(Formel),"",Formel)

Folgende Formel funktioniert einwandfrei:
=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)))))

Leider kann taucht beim ziehen der Formel nach rechts oder unten "FEHLER" auf. Was mache ich falsch?
Vorab vielen Dank!

Liebe Grüße
to top
#2
Ich hab's!

=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1))))

:-)
to top
#3
Hallo,

Zitat: dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Ich würde in diesem Fall einfach mit einem benutzerdefinierten Zahlformat arbeiten. Das könnte z.B. so aussehen:

#.##0,00;-#.##0,00;

oder auch so

0;-0;

Wichtig ist das letzte Semikolon dass die Null ausblendet.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
veve
to top
#4
Das ist ein super Tipp!
Danke!

Liebe Grüße
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  WENN 5 Zellen ISTLEER dann... Argre 7 97 Gestern, 22:48
Letzter Beitrag: schauan
  WENN/DANN Bedingung möglich? stella_gen 22 183 02.12.2016, 00:01
Letzter Beitrag: stella_gen
  summen wenn leere zelle entdeckt ist evera 7 69 30.11.2016, 15:59
Letzter Beitrag: BoskoBiati
  Excel VBA, Bild aus nebenstehender Zelle kopieren wenn Zelle ausgewählt ist xChristianx 5 74 30.11.2016, 11:32
Letzter Beitrag: xChristianx
  WENN/DANN Gesamtsumme nach Kriterien Baldi 5 80 28.11.2016, 16:53
Letzter Beitrag: Baldi
  Wenn Zelleninhalt > 0 dann die 5 linken Zellen farbig Daniel Albert 5 80 22.11.2016, 18:48
Letzter Beitrag: Daniel Albert
  Wenn Dann Funktion in Komb. mit Bedingter Formatierung snoopy4000_0 9 90 21.11.2016, 16:19
Letzter Beitrag: snoopy4000_0
  wenn in tabelle wert in spalte dann neue spalte in neuer tabelle merzens 4 85 16.11.2016, 13:44
Letzter Beitrag: schauan
  VBA: Wenn Datei offen dann schließen mit Speicherabfrage Kash 1 61 15.11.2016, 23:24
Letzter Beitrag: AlterDresdner
  Registerfarbe ändern wenn Zelle Farbe hat michel34497 9 200 06.11.2016, 11:39
Letzter Beitrag: michel34497

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste