Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Wenn Zelle leer, dann ""
#1
Hallo,

ich habe folgende Formel: INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)) und möchte erreichen, dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Dazu habe ich folgende Formeln gefunden:

=WENN(Formel)=0,"",(Formel)) oder
=WENN(ISTLEER(Formel),"",Formel)

Folgende Formel funktioniert einwandfrei:
=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)))))

Leider kann taucht beim ziehen der Formel nach rechts oder unten "FEHLER" auf. Was mache ich falsch?
Vorab vielen Dank!

Liebe Grüße
to top
#2
Ich hab's!

=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1))))

:-)
to top
#3
Hallo,

Zitat: dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Ich würde in diesem Fall einfach mit einem benutzerdefinierten Zahlformat arbeiten. Das könnte z.B. so aussehen:

#.##0,00;-#.##0,00;

oder auch so

0;-0;

Wichtig ist das letzte Semikolon dass die Null ausblendet.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
veve
to top
#4
Das ist ein super Tipp!
Danke!

Liebe Grüße
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  WENN DANN mit Abfragewert < 1 einmalrund 4 76 13.01.2017, 15:23
Letzter Beitrag: Jockel
  Excel Zelle blinken lassen wenn leer hbboy15 6 127 02.01.2017, 14:33
Letzter Beitrag: Winny
  Wenn-Dann in einer Summe Weylin 12 207 26.12.2016, 20:46
Letzter Beitrag: Jockel
  Wenn Dann Funktion trotz Dropdown Jenny Ring 2 106 19.12.2016, 16:31
Letzter Beitrag: Rabe
  Steuerelemente ausblenden wenn Zelle leer Hansimglück 2 76 15.12.2016, 08:48
Letzter Beitrag: Kuwer
  Wenn in Zeile X steht dann in Zeile Y folgendes technoente 11 149 14.12.2016, 16:15
Letzter Beitrag: BoskoBiati
  Wenn-Dann funktion an Nachkommastellen einer Zahl knüpfen ako82 4 101 13.12.2016, 16:27
Letzter Beitrag: BoskoBiati
  Wenn dann Funktion Jenny Ring 2 80 13.12.2016, 15:47
Letzter Beitrag: BoskoBiati
Exclamation Problem:Zwei Spalten vergleichen wenn wahr dann bereich kopieren und einfügen CherryX 5 116 12.12.2016, 09:18
Letzter Beitrag: steve1da
  WENN DANN MITTELWERT stella_gen 5 100 07.12.2016, 15:01
Letzter Beitrag: stella_gen

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste