Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Wenn Zelle leer, dann ""
#1
Hallo,

ich habe folgende Formel: INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)) und möchte erreichen, dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Dazu habe ich folgende Formeln gefunden:

=WENN(Formel)=0,"",(Formel)) oder
=WENN(ISTLEER(Formel),"",Formel)

Folgende Formel funktioniert einwandfrei:
=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)))))

Leider kann taucht beim ziehen der Formel nach rechts oder unten "FEHLER" auf. Was mache ich falsch?
Vorab vielen Dank!

Liebe Grüße
to top
#2
Ich hab's!

=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1))))

:-)
to top
#3
Hallo,

Zitat: dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Ich würde in diesem Fall einfach mit einem benutzerdefinierten Zahlformat arbeiten. Das könnte z.B. so aussehen:

#.##0,00;-#.##0,00;

oder auch so

0;-0;

Wichtig ist das letzte Semikolon dass die Null ausblendet.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
veve
to top
#4
Das ist ein super Tipp!
Danke!

Liebe Grüße
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Funktion die überprüft ob ein feld leer ist Rjinxil 11 182 Vor 4 Stunden
Letzter Beitrag: schauan
  Zeilen kopieren wenn Spalte A nicht leer ist Safety-Tussi 2 30 22.03.2017, 11:31
Letzter Beitrag: Safety-Tussi
  wenn<->dann mit sverweis matty1970 10 92 22.03.2017, 08:45
Letzter Beitrag: shift-del
  Wenn dann Creami 2 42 20.03.2017, 17:07
Letzter Beitrag: WillWissen
  Wenn 3 Kriterien erfüllt, dann zeige alle Werte Dschules 11 126 15.03.2017, 14:11
Letzter Beitrag: Gast 123
  wenn-dann ? composer 10 155 12.03.2017, 18:56
Letzter Beitrag: composer
  Wenn Dann Funktion dindu 4 107 09.03.2017, 18:11
Letzter Beitrag: dindu
  Zählen nur wenn andere Zelle nicht leer styriandi 3 93 03.03.2017, 19:41
Letzter Beitrag: GMG-CC
  Wenn dann Formel mit Daten zur berechnen Monikahelena 12 309 02.03.2017, 14:02
Letzter Beitrag: Rabe
  mit Formel Zelle leer lassen . . . Diagramm macht nicht mit :( Souluddi 2 110 28.02.2017, 11:30
Letzter Beitrag: Souluddi

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste