Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Formel umstellen
#1
Hallo

Ich habe ein eingabeblat wo alles ungefiltert reinkommt
und ein Ausgabeblatt wo man einiges Rausfiltert.

Ich möchte im Ausgaberegister nur die Namen drinstehen haben die
im Eingabeblatt (VIP) in der Spalte T ein B haben alle anderen Namen sollen wechfallen.

wenn das B in der Zeile 5 ist und der Name in Zeile 1 geht die Formel so
Code:
{=WENN(ZEILEN(VIP!$1:1)>ZÄHLENWENN(VIP!$5:$5;"B");"";INDEX(VIP!$1:$1;KKLEINSTE(WENN(VIP!$5:$5="B";SPALTE(VIP!1:1));ZEILE(VIP!E1))))}
darunter die Zeile
Code:
{=WENN(ZEILEN(VIP!$1:2)>ZÄHLENWENN(VIP!$5:$5;"B");"";INDEX(VIP!$1:$1;KKLEINSTE(WENN(VIP!$5:$5="B";SPALTE(VIP!2:2));ZEILE(VIP!E2))))}
aber ich habe das nunmal in Spalten und der Name soll auch in einer Spalte wiedergegeben werden....

die Umstellung klappt nicht, wie mache ich es richtig?
und am besten noch wie die zeile drunter ist.

Danke
to top
#2
Hi,

so ganz verstehe ich dein Anliegen nicht.

Stelle uns doch bitte (d)eine (Beispiel)Datei vor. Unterhalb des Antwortformulars findest du die Möglichkeit, die Datei hochzuladen. Deine Daten kannst du ja einfach anonymisieren.

Trage darin (händisch) dein gewünschtes Ergebnis ein.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
delenn
to top
#3

.xlsx   Test.xlsx (Größe: 50,18 KB / Downloads: 3)
OK
mal ne Testdatei ...
also dort in der Ausgabe sollten 27 namen sein...
wird so vielleicht klarer
to top
#4
Hallo, das geht z.b. so..:

Arbeitsblatt mit dem Namen 'Ausgabe'
 ABCD
3GesamtVornameNachnameHilfe bei
4Namen (= vor und zuname)
8 Gesamt Tagesessen 
91Vorname3Nachname2Vorname3 Nachname2
102Vorname4Nachname3Vorname4 Nachname3
113Vorname5Nachname4Vorname5 Nachname4
124Vorname6Nachname5Vorname6 Nachname5

ZelleFormel
B9{=WENNFEHLER(INDEX(VIP!B$3:B$52;KKLEINSTE(WENN(VIP!$E$3:$E$52="B";ZEILE($A$1:$A$49));$A9));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

oder mit dem SpezialFilter ohne Formeln..:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCD
1VornameNachnameB 
2  B 
3    
4VornameNachnameHilfe beiB
5Vorname3Nachname2Vorname3 Nachname2B
6Vorname4Nachname3Vorname4 Nachname3B
7Vorname5Nachname4Vorname5 Nachname4B
8Vorname6Nachname5Vorname6 Nachname5B
9Vorname7Nachname6Vorname7 Nachname6B
10Vorname8Nachname7Vorname8 Nachname7B
11Vorname9Nachname8Vorname9 Nachname8B
12Vorname10Nachname9Vorname10 Nachname9B
13Vorname11Nachname10Vorname11 Nachname10B
14Vorname13Nachname12Vorname13 Nachname12B
15Vorname14Nachname13Vorname14 Nachname13B
16Vorname15Nachname14Vorname15 Nachname14B
17Vorname16Nachname15Vorname16 Nachname15B
18Vorname17Nachname16Vorname17 Nachname16B
19Vorname18Nachname17Vorname18 Nachname17B
20Vorname19Nachname18Vorname19 Nachname18B
21Vorname20Nachname19Vorname20 Nachname19B
22Vorname22Nachname21Vorname22 Nachname21B
23Vorname23Nachname22Vorname23 Nachname22B
24Vorname24Nachname23Vorname24 Nachname23B
25Vorname25Nachname24Vorname25 Nachname24B
26Vorname26Nachname25Vorname26 Nachname25B
27Vorname27Nachname26Vorname27 Nachname26B
28Vorname28Nachname27Vorname28 Nachname27B
29Vorname29Nachname28Vorname29 Nachname28B
30Vorname34Nachname33Vorname34 Nachname33B
31Vorname35Nachname34Vorname35 Nachname34B
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
delenn
to top
#5
Super
das wars,
Hilfsspalte hätte ich gernicht gebraucht....
Danke
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  WERT Formel umstellen Thund3r 8 125 21.11.2016, 20:08
Letzter Beitrag: Thund3r
  Bestehende Hyperlinks nachträglich auf absoluten Pfad umstellen dbuckl 1 1.819 27.11.2014, 16:50
Letzter Beitrag: atilla

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste