Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Bei Problemen mit der Erreichbarkeit der Foren bitte den Link / Favoriten prüfen und ersetzen. Dazu über die Startseite ins gewünschte Forum wechseln und zu den Favoriten hinzufügen. Excel ist derzeit z.B. unter http://www.clever-excel-forum.de/forum-2.html zu erreichen.


Sverweis mit mehreren Treffern - wie auslesen?
#1
Hallo ich hab eine Tablle aus der ich verschiedene Werte mit einem Sverweis auslesen möchte und zwar wie folgt:

Ich habe die Tabelle hochgeladen und in Anhang gestellt.
ich möchte, dass nach der zahl in K2 gesucht wird in der Spalte B.
Dann soll der Wert von Spalte E ausgelesen werden der in der gleichen Zeile ist.

Leider verrutscht er IMMER um 2Spalten und ich weiß nicht wie ich das in den Griff bekomme. Habe schon 1000 Dinge versucht aber es klappt nicht.

Ich hoffe jemand vone uch kann mir helfen?!

Grüße


Angehängte Dateien
.xlsx   upload.xlsx (Größe: 8,53 KB / Downloads: 4)
to top
#2
Hallo, meinst Du so..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 JKL
2Suchefeld:0001 
31Dieter und KlausHallo
42#BEZUG!Tschüss
53 ist los
6   
7   
8   
9   

ZelleFormel
K3{=WENN(ZEILEN($1:1)>ZÄHLENWENN($B$3:$B$5;$K$2);"";INDEX($E$3:$E$5;KKLEINSTE(WENN($B$3:$B$5=$K$2;ZEILE($3:$5));ZEILE(A1))))}
L3{=WENNFEHLER(INDEX(E:E;KKLEINSTE(WENN($B$1:$B$100=$K$2;ZEILE($A$1:$A$100));ZEILE(A1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Piotor04
to top
#3
Oh man.... Fragen 5 Minuten warten und es geht...
Selber probieren 60-80MInuten es geht nicht...

Dank dir recht herzlich :-)
to top
#4
Hallo,

es hätte auch gereicht, Zeile($1:$3) zu schreiben statt Zeile($3:$5):

Arbeitsblatt mit dem Namen 'Tabelle1'
 K
3Hallo

ZelleFormel
K3{=WENN(ZEILEN($1:1)>ZÄHLENWENN($B$3:$B$7;$K$2);"";INDEX($E$3:$E$7;KKLEINSTE(WENN($B$3:$B$7=$K$2;ZEILE($1:$5));ZEILE(A1))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste