Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Transponieren bzw. Werte in Nebenzelle ersetzen
#1
Hallo Liebe Exel-Profis,

für euch ein Leichtes, für mich Kopfschmerzen...... ich habe bereits diverse Beiträge gegoogelt aber nichts passendes gefunden, ich glaube es geht nur mit einem Makro?

Und zwar habe ich eine Datei mit ca. 1400 Zeilen.
es handelt sich hier um ein Beispiel.

Tabelle 1 Tabelle 2 Tabelle 3 ( Ergebnis )
Spalte A Spalte B Spalte A Spalte B Spalte A Spalte B

Text 9250 9250 1478529 Text 1478529


Für das Ergebnis sollte also in Tabelle 2 nach der Nummer in Spalte A gesucht werden und wenn diese Nummer gefunden wurde soll die daneben stehende Zahl dann ersetzt werden und neben dem in Tabelle 1 Spalte A stehenden Text stehen.

Ich hoffe ich hab es verständlich beschrieben ?!
to top
#2
Hi,

Zitat:Ich hoffe ich hab es verständlich beschrieben ?!

für mich leider nicht.

Ich nehme an, deine Datei sieht so aus:


Tabelle1

ABCDEFGH
1Tabelle 1Tabelle 2Tabelle 3
2ABABAB
3Text925092501478529Text1478529
4wieder Text925192511478530wieder Text1478530
5noch'n Text925292521478531noch'n Text1478531

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

(Übrigens, du würdest den Helfern sehr entgegenkommen, wenn du deine Beispiele ebenfalls als Tabellenausschnitt einstellst.)

Ich suche also in Tab2 in Spalte A nach der Nummer-hier im Bsp. gelb hinterlegt. Soweit klar. Jetzt soll die daneben stehende Zahl ersetzt werden-hier blau hinterlegt.

1. Frage:
Nach welchen Kriterien suchst du denn die Nummer?

2. Frage:
Mit was soll die Zahl in Sp. B ersetzt werden?

Nun soll eben diese in deinem Tab.-Bl. 1 neben dem Text eingefügt werden.

Sorry, aber das verstehe ich nun auch nicht. Daneben hast du doch schon Nummern stehen.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
Hallo,

Du redest von Tabelle 1 und 2, hast aber drei Tabellen vorgestellt. Wie soll das passen?
Machbar ist sowas wohl nur mit Hilfe eines Makros.
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#4
hey, ihr seid ja fix

WillWissen hats schon gut erkannt, sorry das ich keine Excel datei angefügt aber.

Herausforderung hierbei ist das die Zahlen nicht neben einander stehen sondern wild verteilt sind in der Tabelle 2 Spalte A

sonst könnte man ja einfach Kopieren einfügen machen.


Im Anhang eine Datei.

So ca. sieht meine Datei unfertig aus. Die Tabelle 3 ist nur dafür gedacht das dort das ergebnis landet.


Angehängte Dateien
.xls   Test.xls (Größe: 22,5 KB / Downloads: 8)
to top
#5
Hallo,

wenn das ergebnis sowieso in Tabelle 3 stehen soll, dann geht das recht einfach:

Arbeitsblatt mit dem Namen 'Tabelle3'
 AB
1752147Hallo hier steht text
212579965zweiter text

ZelleFormel
A1=WENN(B1="";"";INDEX(Tabelle2!B:B;VERGLEICH(Tabelle1!B1;Tabelle2!$A:$A;0)))
B1=WENN(Tabelle1!A1="";"";Tabelle1!A1)
A2=WENN(B2="";"";INDEX(Tabelle2!B:B;VERGLEICH(Tabelle1!B2;Tabelle2!$A:$A;0)))
B2=WENN(Tabelle1!A2="";"";Tabelle1!A2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
superkot1
to top
#6
Hey Edgar,

ich habe deinen Code eingetragen in Tabelle 3, irgendwie funktioniert es aber nicht :-(
Spalte A Spalte B
#NV 1 x Stahlfelge ALFA ROMEO 147 - TYP 937 Zoll 6x15 ET 37,5 Lochkreis 5x98
#NV 1 x Stahlfelge ALFA ROMEO 147 - TYP 937 Zoll 6.5x15 ET 41,5 Lochkreis 5x98


das steht bei mir in Tabelle 3 dann.....
to top
#7
Hallo,

Edgar hat immer ganz clevere Lösungen parat und die funktionieren auch in Deiner Excel-Beispieltabelle. Jetzt wäre die Frage, was in Deiner produktiven Tabelle anders ist. Erst mal nur zwei Vermutungen als Ursache für #NV

- hast Du eventuell die gesuchten Zahlen nicht in jeder Tabelle?
- sind die Zahlen wirklich Zahlen und nicht eventuell Text mit zusätzlichen Leerzeichen?
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
superkot1
to top
#8
Hey,

Also es kann durchaus sein das eine Zahl nicht in beiden Tabellen ist.
Es handelt Sich ausschließlich um Zahlen. Liegt es evtl daran das die Spalte als Text formatiert ist?

Verwende ich den Code in der Beispiel Datei funktioniert er pflege ich meine Daten in Tabelle 1 und 2 ein geht es nicht.
to top
#9
Hallo,

eventuell kannst Du die kompletten Daten für die beiden Stahlfelgen hier posten, damit man das vergleichen kann.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#10
Hi,

(03.09.2014, 19:58)superkot1 schrieb: Es handelt Sich ausschließlich um Zahlen. Liegt es evtl daran das die Spalte als Text formatiert ist?

wenn die Spalte als Text formatiert ist, sind es keine Zahlen, sondern Text!
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
superkot1
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  vba - viele matrixformeln ersetzen? Klaus 45 1.026 30.01.2017, 07:15
Letzter Beitrag: Klaus
  Muster in einem String ersetzen Quantum 3 156 24.01.2017, 14:22
Letzter Beitrag: Quantum
  Ersetzen von Zeichen an bestimmter Stelle Quantum 22 685 21.01.2017, 19:38
Letzter Beitrag: Castor
  Werte in einer Zeile addieren bis Zielwert erreicht und verwendete Werte markieren hoteu 2 141 12.01.2017, 13:04
Letzter Beitrag: hoteu
  suchen/ersetzen die 2. Fami 3 173 30.12.2016, 11:58
Letzter Beitrag: GMG-CC
  Hilfe bei suchen/ersetzen Fami 2 124 29.12.2016, 11:05
Letzter Beitrag: Fami
  Transponieren abhängig von Werten: wie mache ich das? chilly_bang 9 306 08.12.2016, 16:46
Letzter Beitrag: lupo1
  Mehrere TXT-Files transponieren und zusammenfahren AlexJesse 1 139 08.12.2016, 15:41
Letzter Beitrag: Gast 123
  Ersetzen von Bestandteilen in Hyperlinks Icepic 2 264 29.11.2016, 17:23
Letzter Beitrag: Fennek
  #Wert! mit "Text" ersetzen VBA GustavL 10 492 29.11.2016, 14:47
Letzter Beitrag: GustavL

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste