Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Sumprodukt alphabetisch oder numerisch anordnen ?
#1
Hallo @all,
eine allgemeine Verständnisfrage hätte ich da
Wie mit Summenproduktformel umgehen?
Ergebnis = 21 ist korrekt bei der Formel
PHP-Code:
{=WENN(C3=$B18;SUMMENPRODUKT(WENN(ISTZAHL(E3:G3);E3:G3;VERWEIS(E3:G3;{"aa";"k";"x";"s"};{4;8;9;3}))*1))} 
aber bei der Konstruktion, kommt die Fehlermeldung
#NV
PHP-Code:
{=WENN(C3=$B18;SUMMENPRODUKT(WENN(ISTZAHL(E3:G3);E3:G3;VERWEIS(E3:G3;{"x";"k";"aa";"s"};{9;8;4;3}))*1))} 
Welcher Fehler liegt hier vor?
Feedback ist erwünscht.
Danke vorab
mfg
?mage
to top
#2
Hallo

Der Suchvektor in VERWEIS() muss immer aufsteigend sortiert sein.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
(28.08.2014, 15:42)shift-del schrieb: ..aufsteigend...
Danke für die schnelle Antwort shift-del

mfg
?mage
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Question Wie ordne ich Zeilen entsprechend einer Spalte alphabetisch? Olivenbaum2013 9 94 08.12.2016, 11:57
Letzter Beitrag: BoskoBiati
Question Zeilen entsprechend den Einträgen in einer Spalte automatisch alphabetisch ordnen. Olivenbaum2013 7 89 06.12.2016, 08:37
Letzter Beitrag: Olivenbaum2013
  VBA und Grafik- Objekte alphabetisch sortieren sheffield 1 137 26.08.2016, 16:36
Letzter Beitrag: schauan
  Pivot oder Konsolidierung, oder doch nur filtern? Ratlose 3 392 11.07.2016, 10:35
Letzter Beitrag: chris-ka
Star Liniendiagramm versetzt anordnen Yuki 2 383 02.07.2016, 19:19
Letzter Beitrag: Yuki
  Über 3 Brücken musst du gehen oder Pivot oder waaas? night-auditor 2 408 27.04.2016, 17:25
Letzter Beitrag: night-auditor
  Spalten sortieren und Anordnen ulumulu 9 703 06.04.2016, 09:06
Letzter Beitrag: ulumulu
Question Unterschiedliche Matrizen aus verschiedenen Tabs untereinander anordnen Zelt 9 896 14.12.2015, 19:30
Letzter Beitrag: schauan
  Alphabetisch sortieren Michael Arriens 10 1.340 06.10.2015, 13:06
Letzter Beitrag: Michael Arriens
  Fenster anordnen in Excel 2013 tonibert 2 773 23.09.2015, 20:58
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste