Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


SVerweis über 4 Tabellen
#1
Hallo zusammen,

ich hab ein Problem bei meiner Formel "Sverweis" und zwar funktioniert meine Formel, wenn ich über 3 Tabellen suche, sobald ich über 4 Tabellen suche will, meckert Excel "zuviel Argumente".

Hier die Formel:
Code:
=Wenn(Istfehler(SVERWEIS($A$3;Tabelle2!$B40:$H69;2;0));SVERWEIS($A$3;Tabelle3!B40:H89;2;0);SVERWEIS($A$3;Tabelle4!$B40:$H89;2;0);SVERWEIS($A$3;Tabelle5!$B40:$H69;2;0))

Wo ist mein Fehler?
Grüße aus Bremen
Bernie

"Wenn du jemanden triffst ohne lächeln, schenke ihm deins !!!"

MS Office 2010 Pro - Win 7 Home Premium
Haftungshinweis: Trotz sorgfältiger inhaltlicher Kontrolle übernehmen ich keine Haftung für die Inhalte externer Links. Für den Inhalt der verlinkten Seiten sind ausschließlich deren Betreiber verantwortlich.
to top
#2
hi Bernie, kannst du mal bitte (D)eine (Beispiel)Datei posten..?
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo Jockel,

hier meine Datei: [URL=Dateiupload bitte im Forum - wie's geht: http://www.clever-excel-forum.de/thread-326.html ..net/download-9437819/Indizes.xlsm.html]Indizes.xlsm[/URL]

Sverweis ist auf Tabelle 6

Danke schon mal im Voraus für deine Hilfe.
Grüße aus Bremen
Bernie

"Wenn du jemanden triffst ohne lächeln, schenke ihm deins !!!"

MS Office 2010 Pro - Win 7 Home Premium
Haftungshinweis: Trotz sorgfältiger inhaltlicher Kontrolle übernehmen ich keine Haftung für die Inhalte externer Links. Für den Inhalt der verlinkten Seiten sind ausschließlich deren Betreiber verantwortlich.
to top
#4
Hallo Bernie, Du kannst hier Deine Datei(en) direkt hochladen...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hallo Bernie, meinst du so..?

Als Fehlerabfrage einfach WENNFEHLER() umzu tun...

Arbeitsblatt mit dem Namen 'Limitüberwachung'
 ABCDE
1Portfolio    
2NameKaufkursakt. KursGuV %Order
3Fielmann56,0050,08-10,56verkaufen
4Continental140,00166,8019,14halten

ZelleFormel
C3=SVERWEIS($A3;INDIREKT("'"&INDEX({"DAX";"MDAX";"SDAX";"TECDAX"};VERGLEICH(1;(ZÄHLENWENN(INDIREKT("'"&{"DAX";"MDAX";"SDAX";"TECDAX"}&"'!B:B");$A3)>0)+0;0))&"'!$B40:H69");2;0)
D3=WENN(A3="";"";(C3-B3)/B3%)
E3=WENN(A3="";"";WENN(D3<-9,99;"verkaufen";"halten"))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo Jockel,

passt wie Faust auf's Auge, Danke sehr!!!

Kurze Frage noch "wie kann ich Dateien direkt hochladen, hab gesucht im Forum, aber nichts gefunden.
Grüße aus Bremen
Bernie

"Wenn du jemanden triffst ohne lächeln, schenke ihm deins !!!"

MS Office 2010 Pro - Win 7 Home Premium
Haftungshinweis: Trotz sorgfältiger inhaltlicher Kontrolle übernehmen ich keine Haftung für die Inhalte externer Links. Für den Inhalt der verlinkten Seiten sind ausschließlich deren Betreiber verantwortlich.
to top
#7
Hallo,

auf dieser Seite http://www.clever-excel-forum.de/Forum-Excel ganz oben im Abschnitt 'Wichtige Themen' oder direkt http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
Bernie
to top
#8
Hallo,

ginge ohne größeren Aufwand auch so:

Code:
=WENNFEHLER(SVERWEIS($A$3;Tabelle2!$B40:$C69;2;0);WENNFEHLER(SVERWEIS($A$3;Tabelle3!B40:C89;2;0);WENNFEHLER(SVERWEIS($A$3;Tabelle4!$B40:$C89;2;0);WENNFEHLER(SVERWEIS($A$3;Tabelle5!$B40:$C69;2;0);"nicht da"))))
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#9
Hallo

Hier noch zwei Varianten von mir.
 ABCDEFGHIJKLM
2NameKaufkursakt. KursGuV %Order        
3Fielmann56,0050,08-10,56verkaufen #NV50,084#NV#NV50,084 50,084
4Continental140,00#NV#NV#NV 166,8#NV#NV#NV166,8 166,8

ZelleFormel
G3=SVERWEIS(A3;DAX!$B$40:$C$100;2;FALSCH)
H3=SVERWEIS(A3;MDAX!$B$40:$C$100;2;FALSCH)
I3=SVERWEIS(A3;SDAX!$B$40:$C$100;2;FALSCH)
J3=SVERWEIS(A3;TECDAX!$B$40:$C$100;2;FALSCH)
K3=VERWEIS(9^9;G3:J3)
M3=SVERWEIS(A3;INDIREKT(VERWEIS(42;1/ZÄHLENWENN(INDIREKT({"DAX"."MDAX"."SDAX"."TECDAX"}&"!B:B");A3);{"DAX"."MDAX"."SDAX"."TECDAX"})&"!B40:C100");2;FALSCH)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die zweite Variante ist eine Abwandlung von Jörgs Formel.

Ein Geschwindigkeitsvergleich auf Basis der Hilfsspalten-Lösung zeigt:
HilfsspaltenINDIREKT()Verschachtelt
11,62,2
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Wie lese ich diese Daten aus? SVERWEIS? Über mehrere Zeilen... Woofer 18 193 26.10.2016, 21:50
Letzter Beitrag: WillWissen
  Filtern über mehrere Tabellen anne.degroot 3 205 16.08.2016, 16:11
Letzter Beitrag: Luffy
  Bedingte Formatierung über mehrere Tabellen tomthe77st 4 434 29.06.2016, 14:11
Letzter Beitrag: tomthe77st
  SVERWEIS über mehrer Tabellen Kreck2 5 601 27.02.2016, 21:52
Letzter Beitrag: WillWissen
  SVERWEIS über mehrere Reiter Noé 8 1.437 04.01.2016, 20:16
Letzter Beitrag: Noé
  SVerweis nach Links über 2 Dateien Bremi 6 999 13.11.2015, 01:57
Letzter Beitrag: Bremi
  SVERWEIS (für sehr viele Zeilen) über VBA friedensbringer 3 1.482 28.07.2015, 10:47
Letzter Beitrag: Winny
  SVerweis über 2 Kriterien mikeho 2 844 02.06.2015, 13:12
Letzter Beitrag: mikeho
  Sverweis aktualisiert nicht automatisch und Sverweis mit Trennen von einer Zelle vivendo 15 3.357 27.05.2015, 08:13
Letzter Beitrag: BoskoBiati
  Excel-tabellen mit Daten Aus anderen Tabellen automatisch aktualisieren Slaydark 9 2.483 07.05.2015, 14:06
Letzter Beitrag: Slaydark

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste