Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Wenn 29.Februar dann =D34 sonst =D33
#1
Hallo in die Runde.

wie kann ich Folgendes in eine Formel packen ?

Wenn es im Bereich D33Big Grin34 einen 29.02. gibt,
dann =D34+1, - sonst D33+1

Is klar ? - ich hab nen Kalender wo ich zu
jedem Tag +1 addiere

Seitenumbruch ist jeweils der letzte eines Monats

Auf der neuen Seite geht es jeweils mit dem 1. des Monats weiter.

Das funzt in jedem Monat,- bis auf den Februar
wegen der Schaltjahre.

Weiß jemand wie ich das anstelle, dass im Schaltjahr entweder
zu D34 +1 addiert wird, sonst =D33, - oder was ja auch ginge, -
wenn es den 29.02 gibt, dann =D33 +2; sonst +1

Ich danke Euch schon mal !

Grüßle Nick
eenemeenemi und raus bin i
to top
#2
Wenn 29.Februar, mach dies, sonst mach das

... habs selbst hinbekommen:

=WENN(REST(JAHR(A1);4)=0;$D$34+1;$D$33+1)
(in A1 steht das Datum z.B: 1.1.2012)

Gr. Nick
eenemeenemi und raus bin i
to top
#3
Hallo Nick,

auch wenn Du jetzt eine Lösung hast, verstanden hab ich es nicht.
Excel macht das doch automatisch:

DE
3328.02.201428.02.2016
3401.03.201429.02.2016
3502.03.201401.03.2016
Formeln der Tabelle
ZelleFormel
D33=D32+1
E33=E32+1
D34=D33+1
E34=E33+1
D35=D34+1
E35=E34+1

Gruß Uwe
[-] Folgende(r) 1 Benutzer sagt Danke an Kuwer für diesen Beitrag:
nobody
to top
#4
Hallo,

vielleicht meint Nick auch sowas?

In D2 steht der Monatserste in

Arbeitsblatt mit dem Namen 'Tabelle1'
 D
2827.02.2014
2928.02.2014
30 
31 

ZelleFormel
D28=D27+1
D29=WENN(TAG(D$28+ZEILE(D1))<4;"";D28+1)
D30=WENN(TAG(D$28+ZEILE(D2))<4;"";D29+1)
D31=WENN(TAG(D$28+ZEILE(D3))<4;"";D30+1)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Wobei mir in in diesem Zusammenhang auffällt, dass das Jahr 2100 kein Schaltjahr sein dürfte (Wikipedia: st jedes Jahr ein Schaltjahr mit 29tägigem Februar, das durch 4, aber nicht auch durch 100 ohne Rest teilbar ist, mit der Ausnahme, dass ein durch 400 ohne Rest teilbares Jahr wiederum ein Schaltjahr ist (z. B. das Jahr 2000)).

In diesem Jahr müsste die Formel von Nick dann falsch rechnen (wobei ihn das dann vermutlich nicht mehr interessieren wird). 19
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
nobody
to top
#5
he hallo Danke !

ich hab nen Kalender da stehen pro Seite 16 Zeilen in 5 Spalten.

In Spalte A:A steht das Datum vom 01.Monat bis 15.Monat
und in Spalte D: D stehen jeweils die "Datums :-)" 16.Monat bis 31.Monat
Neben A:A und D: D sind die leere Spalten für die händischen Eintragungen und
Spalte C:C ist eine leere Spalte, mit der ich den Abstand einstellen kann.

Dann kommt eine neue Seite die genau so aussieht und ebenfalls
mit dem 01.des Monats in Spalte A:A anfangen soll,
mit dem 16.des Monats in Spalte D: D

Das Ganze ist 12 Seiten lang und wird von mir für jedes Projekt beidseitig
ausgedruckt.

Damit es auf jeder Seite mit dem 01. eines Monats anfängt, nehm ich den
jeweils letzten des Vormonats und addiere +1 .

Da ja alle Monate jährlich immer die gleiche Anzahl an Tagen haben, außer dem Februar,-
ist das auch völlig easy außer dem März -
weil ich da manchmal von der Zelle wo der 28.Feb. steht, ausgehen muß und manchmal
- eben alle 4 Jahre - von der Zelle darunter, wo der 29.Feb. steht.

Mit: =WENN(REST(JAHR(A1);4)=0;$D$34+1;$D$33+1)
guck ich in A1 ob die Jahreszahl durch 4 ohne Rest teilbar ist und wenn ja, dann wird die Zelle
D34 übernommen, wenn Rest nicht "0" ist, - wird die Zelle D33 übernommen.

Hab mal n Bildchen beigepackt - damit wirds vielleicht verständlicher.

p.s. damit in Zelle D34: =WENN(REST(JAHR(A1);4)=0;$D$33+1;"")
blende ich D34 aus, wenn kein Schaltjahr ist, sonst würde dort bereits der 01.03. stehen.

Hoffe, es ist nu bissl verständlicher Big Grin

Grüßle
_________ Nick

?mage
eenemeenemi und raus bin i
to top
#6
Hallo Nick,

sowas hab ich mir schon gedacht. Und warum einfach, wenn es umständlicher geht? 05

ABCD
3328.02.2014
34
35
36
37
38
3901.03.2014
4002.03.2014
Formeln der Tabelle
ZelleFormel
D33=D32+1
D34=WENN(TAG(D33+1)=1;"";D33+1)
A39=DATUM(A1;3;1)
A40=A39+1

Gruß Uwe
[-] Folgende(r) 1 Benutzer sagt Danke an Kuwer für diesen Beitrag:
nobody
to top
#7
33 Whistle 23 ....

tja.... hm .... jo ... was soll ich sagen ?...... Big Grin

Danke !

EDIT:

habs mal eingesetzt -
und bekomme nach Eingabe von:
=DATUM(A1;3;1)
das Ergebnis: # Zahl ! (wird ab da in allen weiteren Zellen angezeigt)

Bei mir steht in A1: 01.01.2012
eenemeenemi und raus bin i
to top
#8
Hola,

du musst JAHR() noch mit reinschreiben:

Code:
=DATUM(Jahr(A1);3;1)

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
nobody
to top
#9
33 ... ah - ok ... Danke Dir !
eenemeenemi und raus bin i
to top
#10
Hallo Nick,

ich hatte nicht vermutet, dass in A1 ein Datum, sondern eben nur das vierstellige Jahr steht. :-)

Gruß Uwe
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  WENN 5 Zellen ISTLEER dann... Argre 7 103 03.12.2016, 22:48
Letzter Beitrag: schauan
  WENN/DANN Bedingung möglich? stella_gen 22 212 02.12.2016, 00:01
Letzter Beitrag: stella_gen
  WENN/DANN Gesamtsumme nach Kriterien Baldi 5 80 28.11.2016, 16:53
Letzter Beitrag: Baldi
  Wenn Zelleninhalt > 0 dann die 5 linken Zellen farbig Daniel Albert 5 82 22.11.2016, 18:48
Letzter Beitrag: Daniel Albert
  Wenn Dann Funktion in Komb. mit Bedingter Formatierung snoopy4000_0 9 92 21.11.2016, 16:19
Letzter Beitrag: snoopy4000_0
  wenn in tabelle wert in spalte dann neue spalte in neuer tabelle merzens 4 90 16.11.2016, 13:44
Letzter Beitrag: schauan
  VBA: Wenn Datei offen dann schließen mit Speicherabfrage Kash 1 65 15.11.2016, 23:24
Letzter Beitrag: AlterDresdner
Question Zeiterfassung mit "wenn;und;dann;sonst">als;<als falsch durchdacht thoju 8 248 19.10.2016, 14:24
Letzter Beitrag: BoskoBiati
Video SVerweis mit Wenn Dann Sonst Funktion Verknüpfung HollyBoy 16 435 14.10.2016, 05:56
Letzter Beitrag: WillWissen
  Wenn-dann-Formel Tukan 6 132 11.10.2016, 14:55
Letzter Beitrag: Tukan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste