Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Bestimmte Werte kopieren
#1
Hallo zusammen.

Ich habe mal wieder ein Problem.

Als Basis habe ich mehrere Tabellenblätter mit folgenden Informationen:

Produkt;Kunde;Menge

Für jeden Tag wird ein neues Tabellenblatt hinzugefügt.
Die Produkte sowie die Kunden und Mengen können von Tag zu Tag unterschiedlich sein.

Zum Monatsende möchte ich gern eine Zusammenfassung erstellen lassen.

In dieser Zusammenfassung sollen alle zusammen gehörenden Mengen addiert werden.

Manche Produkte können zu mehreren Kunden gehen.

Bsp. Tag 1: Produkt1 Kunde1 Menge1000
Tag 2: Produkt1 Kunde1 Menge300
Tag 3: Produkt1 Kunde2 Menge500
Tag 4: Produkt2 Kunde1 Menge800

Zusammen: Produkt1 Kunde1 Menge1300
Produkt1 Kunde2 Menge500
Produkt2 Kunde1 Menge800



Ich wäre super glücklich wenn mir jemand helfen könnte.


Danke.

Marc
to top
#2
Hi Marc,

nimm dazu die Fkt. SUMMENPRODUKT

Tabelle1

ABCDEFG
1ProduktKundeMengeProdukt1Kunde1300
2Produkt1Kunde1300
3Produkt1Kunde2500
4Produkt2Kunde1800
Formeln der Tabelle
ZelleFormel
G1=SUMMENPRODUKT((C2:C4)*(A2:A4=E1)*(B2:B4=F1))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

In E1 und F1 kannst du eintragen, von welcher Konstellation du das Ergebnis möchtest.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
Hallo,

Zitat:Für jeden Tag wird ein neues Tabellenblatt hinzugefügt.

hat das einen bestimmten Grund?

Ich persönlich würde einfach eine Spalte mit einem Datum hinzufügen und nur ein Tabellenblatt verwenden. In dieser Konstellation ist eine Auwertung, z.B. über eine Pivottabelle, dann nur noch eine Affäre von ein paar Mausklicks.
Gruß
Peter
to top
#4
@WillWissen: Die Formel gilt dann aber nur für das eine Tabellenblatt, oder?

Ich möchte aber mehrere Daten aus mehreren Tabellenblättern zusammenführen.

@Peter: Ist leider ein vorgeschriebenes Dokument und muss so verwendet werden. SRY
to top
#5
Hallo Marc, ich würde eine PivotTable dafür nutzen (kommt ohne Formeln aus...)

@Günter, hier passt das, aber besser wäre..:
PHP-Code:
=SUMMENPRODUKT((A2:A4=E1)*(B2:B4=F1);(C2:C4)) 

Arbeitsblatt mit dem Namen 'Blatt1'
 ABCDEFGHIJKL
1ProduktKundeMenge Produkt1Kunde1#WERT!300 Summe von Menge  
2Produkt1Kunde1300 Produkt2Kunde1#WERT!800 ProduktKundeErgebnis
3Produkt1Kunde2       Produkt1Kunde1300
4Produkt2Kunde1800       Kunde20
5         Produkt2Kunde1800
6         Gesamtergebnis 1100

ZelleFormel
G1=SUMMENPRODUKT(($C$2:$C$4)*($A$2:$A$4=E1)*($B$2:$B$4=F1))
H1=SUMMENPRODUKT(($A$2:$A$4=E1)*($B$2:$B$4=F1);($C$2:$C$4))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo,

schade.

Dann könntest du dir vielleicht mal dieses Addin ansehen

http://www.rondebruin.nl/win/addins/rdbmerge.htm

Damit kannst du die Werte aus den einzelnen Tabellenblättern einlesen und dann wären wir wieder bei der Pivot als Auswertungsinstrument.
Gruß
Peter
to top
#7
Hi Marc,

Zitat:@WillWissen: Die Formel gilt dann aber nur für das eine Tabellenblatt, oder?

Ich möchte aber mehrere Daten aus mehreren Tabellenblättern zusammenführen.

Das ist richtig. Ich hatte das irgenwie überlesen, dass du die Summen über mehrere Blätter addieren willst.

Sowohl von Peter als auch von Jörg wurde die Pivottabelle angesprochen, die sicherlich das geeignetste Instrument sein dürfte. Was aber auch noch geht:

Mache deine Auswertungen auf allen Tabellenblättern immer in den selben Bereichen. Dann erstelle ein leeres Tabellenblatt ganz am Anfang, benenne es in "Anfang" um und wiederhole das für das letze Tabellenblatt, das du dann z.B. "Ende" nennst. Dazwischen liegen deine Tabellenblätter mit deinen Daten. Dann brauchst du nach der Auswertung in den einzelnen Blättern nur noch in deinem Übersichtsblatt diese Formel (angepasst natürlich auf deine tatsächlichen Bereiche):

=SUMME(Anfang:Ende!A1)
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#8
Hi Jörg,

Zitat:@Günter, hier passt das, aber besser wäre..:
PHP-Code:
=SUMMENPRODUKT((A2:A4=E1)*(B2:B4=F1);(C2:C4))

ich habe versucht nachzuvollziehen, warum in deinem Beispiel mit meiner Formel #WERTrauskommt - ohne Erfolg.

Tabelle1

ABCDEFG
1ProduktKundeMengeProdukt1Kunde1300
2Produkt1Kunde1300Produkt1Kunde20
3Produkt1Kunde2
4Produkt2Kunde1800
Formeln der Tabelle
ZelleFormel
G1=SUMMENPRODUKT(($C$2:$C$4)*($A$2:$A$4=E1)*($B$2:$B$4=F1))
G2=SUMMENPRODUKT(($C$2:$C$4)*($A$2:$A$4=E2)*($B$2:$B$4=F2))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#9
Hallo,

Zitat:Die Produkte sowie die Kunden und Mengen können von Tag zu Tag unterschiedlich sein.

mit dieser Beschreibung habe ich meine Zweifel ob die Summenformel =SUMME(Anfang:Ende!A1) in diesem Fall immer richtig rechnet.

Zitat:ich habe versucht nachzuvollziehen, warum in deinem Beispiel mit meiner Formel #WERTrauskommt - ohne Erfolg.

Was ich mir auf die Schnelle vorstellen könnte: Ein Text bzw. ein Leerzeichen in der Spalte C was mit der Formel von Jockel abgefangen wird.
Gruß
Peter
to top
#10
(07.08.2014, 05:17)Peter schrieb: mit dieser Beschreibung habe ich meine Zweifel ob die Summenformel =SUMME(Anfang:Ende!A1) in diesem Fall immer richtig rechnet.

könnte man nicht mit Anfang:Ende aus den ganzen Tabellen die Daten auf einer Gesamt-Tabelle konsolidieren (evtl. per VBA oder Matrix-Formel o.ä.) und dann davon eine Pivot-Auswertung erstellen?
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Bestellung/Spalten: nur bestimmte Spalten kopieren teufelchenbs 14 294 25.11.2016, 20:55
Letzter Beitrag: schauan
  Zellbereiche von Excel nach Word an bestimmte Stelle kopieren Timo 4 99 22.11.2016, 19:14
Letzter Beitrag: schauan
  Zeilen kopieren und mit Formeln und Format, aber ohne Werte einfügen Peter Pan 7 114 18.11.2016, 08:17
Letzter Beitrag: Kuwer
  BESTIMMTE ZEILEN IN EINE ANDERE TABELLEN KOPIEREN Berndt 3 257 17.10.2016, 06:44
Letzter Beitrag: Berndt
  Mittelwert und Anzahl für bestimmte Werte JeJo 2 136 09.09.2016, 08:35
Letzter Beitrag: JeJo
  Werte suchen, folgewerte in Tabelle kopieren Sagulum 9 391 08.09.2016, 16:24
Letzter Beitrag: Sagulum
  Werte auf kleinste/größte Werte einer anderen Spalte zuordnen MaxiL 2 228 21.07.2016, 10:24
Letzter Beitrag: MaxiL
  Regelmäßiges Löschen bestimmter Zeilen + kopieren bestimmter Werte dansoi 1 247 23.06.2016, 22:29
Letzter Beitrag: steve1da
  Bestimmte Werte aus Outlook in Excel importieren BadHabiit 6 548 07.06.2016, 06:50
Letzter Beitrag: Fennek
  Werte Kopieren mit Bedingungen aus anderem Tabellenblatt B7One 4 333 23.05.2016, 12:41
Letzter Beitrag: B7One

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste