Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Listenerstellung
#1
Hallo
habe ein Tabellenblatt mit den Spalten
Tag, Ziel, Name, Tel, gebucht, bez.....

nun möchte ich ein neues Blatt erstellen das:
wenn ich in A1 einen bestimmten Tag einstelle
in B1 das Ziel erscheint das klappt auch,

aber in den zeilen 2-10
sollen die Namen erscheinen die sich für das Ziel gemeldet haben.
Das klappt bei mir noch nicht, klappt das wirklich nicht ohne Makros?

Wie bekomme ich das hin?

Danke
to top
#2
Hallo,

das hört sich nach sowas an:

http://www.excelformeln.de/formeln.html?welcher=28

Das könnte z.B. so aussehen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1TagZielName 30.07.2014N1
230.07.2014Z1N1  N2
330.07.2014Z2N2  N6
429.07.2014Z1N3   
528.07.2014Z1N4   
629.07.2014Z1N5   
730.07.2014 N6   
8      

ZelleFormel
F1{=WENN(ZEILEN($1:1)>ZÄHLENWENN(Tabelle1!A:A;$E$1);"";INDEX(Tabelle1!C:C;KKLEINSTE(WENN(Tabelle1!A$1:A$99=$E$1;ZEILE($1:$99));ZEILE(A1))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Formel in F1 kopierst du einfach soweit wie notwendig nach unten.

Weitere Möglichkeiten (teilweise mit VBA oder Hilfsspalten):

* http://excelformeln.de/formeln.html?welcher=224
* der Autofilter
* Spezialfilter von Thomas Ramel: http://netcult.ch/MVP_Ramel/Files/spezia...rt-neu.xls
* VERGLEICH- und INDEX-Lösung von Lupo http://xxcl.de/0054.htm (dort blaue Links klicken)
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
delenn
to top
#3
Hallo oder PivotTable ... @Peter: AutoFilter in einem anderen TabellenBlatt..?

Arbeitsblatt mit dem Namen 'Tabelle3'
 AB
1Tag30.07.2014
2  
3Name 
4N1 
5N2 
6N6 
7Gesamtergebnis 
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
Hallo,

Zitat: @Peter: AutoFilter in einem anderen TabellenBlatt..?

das sind die Gefahren des C&P. 19
Gruß
Peter
to top
#5
Hallo Peter,
Das klappt wunderbar,
nur statt ner 0 kommt da #ZAHL!
kann man das auch in so einer Formel unterdrücken?
Danke
to top
#6
(30.07.2014, 09:24)delenn schrieb: Hallo Peter,
Das klappt wunderbar,
nur statt ner 0 kommt da #ZAHL!
kann man das auch in so einer Formel unterdrücken?
Danke

Hallo, bitte ff. beachten ..: Achtung, Matrixformel enthalten!

Verlassen Sie den Zelleneditor mit Strg+Shift+Enter, statt Enter alleine.
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hallo Jockel
habe ich gemacht...
es kommen auch immer die richtigen namen, nur wenn keine mehr sind kommt halt dieser Fehler...
Daher die FRage ob man das auch in einer Matrixformel unterbinden kann...
Danke
to top
#8
(30.07.2014, 09:54)delenn schrieb: ...Matrixformel unterbinden kann...
Hallo
führend =wennfehler(deineFormel;"")
auch wieder als Matrixf. speichern
mfg
?mage
to top
#9
Hallo,

bist du wirklich sicher, dass du die Matrixformel richtig erzeugt hast?

Bei mir kommt dieser Fehler nämlich nicht:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1TagZielName 30.07.2014N1
230.07.2014Z1N1  N2
330.07.2014Z2N2  N6
429.07.2014Z1N3   
528.07.2014Z1N4   
629.07.2014Z1N5   
730.07.2014 N6   
8      

ZelleFormel
F1{=WENN(ZEILEN($1:1)>ZÄHLENWENN(Tabelle1!A:A;$E$1);"";INDEX(Tabelle1!C:C;KKLEINSTE(WENN(Tabelle1!A$1:A$99=$E$1;ZEILE($1:$99));ZEILE(A1))))}
F2{=WENN(ZEILEN($1:2)>ZÄHLENWENN(Tabelle1!A:A;$E$1);"";INDEX(Tabelle1!C:C;KKLEINSTE(WENN(Tabelle1!A$1:A$99=$E$1;ZEILE($1:$99));ZEILE(A2))))}
F3{=WENN(ZEILEN($1:3)>ZÄHLENWENN(Tabelle1!A:A;$E$1);"";INDEX(Tabelle1!C:C;KKLEINSTE(WENN(Tabelle1!A$1:A$99=$E$1;ZEILE($1:$99));ZEILE(A3))))}
F4{=WENN(ZEILEN($1:4)>ZÄHLENWENN(Tabelle1!A:A;$E$1);"";INDEX(Tabelle1!C:C;KKLEINSTE(WENN(Tabelle1!A$1:A$99=$E$1;ZEILE($1:$99));ZEILE(A4))))}
F5{=WENN(ZEILEN($1:5)>ZÄHLENWENN(Tabelle1!A:A;$E$1);"";INDEX(Tabelle1!C:C;KKLEINSTE(WENN(Tabelle1!A$1:A$99=$E$1;ZEILE($1:$99));ZEILE(A5))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
to top
#10
(30.07.2014, 09:54)delenn schrieb: Hallo Jockel
habe ich gemacht...
es kommen auch immer die richtigen namen, nur wenn keine mehr sind kommt halt dieser Fehler...
Daher die FRage ob man das auch in einer Matrixformel unterbinden kann...
Danke

Hallo, da gibt's verschiedene Möglichkeiten (je nachdem, welche XL-Version du benutzt...) erste: die Variante von Peter anpassen... ... das sollte in jedem Fall funzen, zweite: wenn deine XL-version >= XL2007 einfach WENNFEHLER() umzu zaubern...

{edited} habe Peters Beitrag zu spät gesehen... ... ein PivotTable funzt ohne Formel... (!)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste