Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Bei Problemen mit der Erreichbarkeit der Foren bitte den Link / Favoriten prüfen und ersetzen. Dazu über die Startseite ins gewünschte Forum wechseln und zu den Favoriten hinzufügen. Excel ist derzeit z.B. unter http://www.clever-excel-forum.de/forum-2.html zu erreichen.


Teil-Tabelle aus Tabelle erstellen
#1
Hallo liebe Excelianer,
habe ein kleines Problem und hoffe auf Eure Hilfe und Unterstützung.
Ich möchte aus der Basistabelle "Tabelle1" die neue "Tabelle2" erstellen und zwar nur mit Datensätzen der "Tabelle1", die in Spalte "C" den Wert "A" enthalten. Die Spalte "E" in "Tabelle1" ist aufsteigend sortiert.
Wer kann mir da Tipps geben, wie das am elegantesten über Formeln zu lösen ist.
Für Eure Hilfe schon mal vielen Dank.

Tabelle1
CDEFG
2KZSortIndex  Anzahl Sätze (A)
3        2
4  Excel-1100   
5AWord-1101   
6  Powerpoint-1102   
7  Access-1103   
8  Powerpoint-2104   
9AWord-2105   

verwendete Formeln
Zelle Formel Bereich
G3 =ZÄHLENWENN(C4:C15;"A")

Tabellendarstellung in Foren Version 5.26



Tabelle2
CDE
2KZSortIndex
3     
4AWord-1101
5AWord-2105

Tabellendarstellung in Foren Version 5.26



Viele Grüße
Günther (Excel 2003)
Viele Grüße
Günther

(MS Office 2013)
to top
#2
Hallo Günther

Daten mittels Filterkriterium an eine andere Stelle kopieren:
Mit einfachen Bordmitteln: Autofilter (+ Kopieren/Einfügen) bzw. Spezialfilter.
Mit Matrix-Formeln:
Mit INDEX() und KKLEINSTE().
Die Variante ohne Duplikate.
Mit normalen Formeln:
Mit VERGLEICH() und ZÄHLENWENN()-
Die Erweiterung zu Vorteil von VERGLEICH gegenüber SVERWEIS.
Mit VBA: Autofilter bzw. Spezialfilter in Kombination mit einem Makro.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Hallo,

wie groß ist denn die Tabelle?

Das wäre z.B. eine Möglichkeit:

http://www.excelformeln.de/formeln.html?welcher=28

oder, bei größeren Tabellen, diese Variante:

http://excelformeln.de/formeln.html?welcher=224

Alternativ auch der Spezialfilter von Thomas Ramel:

http://netcult.ch/MVP_Ramel/Files/spezia...rt-neu.xls
Gruß
Peter
to top
#4
Hi Günther, hier mal zwei Varianten, eine mit Formeln und einmal mit SpezialFilter..:

Arbeitsblatt mit dem Namen 'Tabelle2'
 CDEFGHI
2KZSortIndex KZSortIndex
3    A  
4AWord-1101 KZSortIndex
5AWord-2105 AWord-1101
6    AWord-2105

ZelleFormel
D4{=WENNFEHLER(INDEX(Tabelle1!D$4:D$9;KKLEINSTE(WENN(Tabelle1!$C$4:$C$9=$C4;ZEILE($A$1:$A$6));ZEILE(A1)));"")}
E4{=WENNFEHLER(INDEX(Tabelle1!E$4:E$9;KKLEINSTE(WENN(Tabelle1!$C$4:$C$9=$C4;ZEILE($A$1:$A$6));ZEILE(B1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hallo Euch allen,

vielen Dank für die zahlreichen Hinweise und Lösungsansätze. Habe einiges ausprobiert und meine Lösung gefunden - klappt bestens.

Bis zum nächsten Mal, einen schönen Abend noch und viele Grüße
Günther
Viele Grüße
Günther

(MS Office 2013)
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste