Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Rangfolge ermitteln bei unterschiedlichen Suchbedingungen
#1
Hallo Excel- & Fussballdeutschland
hier direkt die Anschaudatei
.xlsx   Rangfolge richtig auslesen.xlsx (Größe: 12,06 KB / Downloads: 4)
Was mich seit Tagen plagt ist das erstellen einer Warenliste bezogen auf Verkaufsmenge am Tag, mit Rangfolge der Wochentage unterschiedlicher Produkte.
Formel unter "klick" gefunden.
Code:
{=WENN(B2=B2;RANG(E2;$E$1:$E$19;0);"")}

vorher versucht mit:[F3]
Code:
=WENN(B3=B2;KGRÖSSTE($E$2:$E$19;ZEILE()-1);"")
Nur hier wird das wenn nicht unterstützt, weil ich die ganze Tabelle mit einbeziehe, verwende ich die Matrix nur bezogen auf $E$2:$E$7, klappt es.

mfg
?mage
to top
#2
Hallo Frank, warum arbeitest Du nicht mit einer Tabelle...? Welche(s) Ergebnis(se) willst Du denn ausgeben lassen..? Und: was soll denn diese Formel..:

PHP-Code:
=SUMME(C2+0,1/ZEILE())+D2+0,1/ZEILE() 
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo Jörg
danke für dein Statement
(13.07.2014, 18:34)Jockel schrieb: ...warum arbeitest Du nicht mit einer Tabelle...? Welche(s) Ergebnis(se) willst Du denn ausgeben lassen..
Die zweite Tabelle ist als Fehlerinterpretation gedacht.
(13.07.2014, 18:34)Jockel schrieb: ...was soll denn diese Formel... =SUMME(C2+0,1/ZEILE())+D2+0,1/ZEILE()
Die Formel lässt zu das an 2 Tagen identisch verkaufte Waren den ersten anzeigt dann den zweiten Tag (Formel hier aus dem Forum)

In der ersten Tabelle sind extra keine Werte, weil diese direkt das Ergebnis verfälschen im jetzigen Formelzustand

mfg
?mage
to top
#4
Hallo Frank, ich meinte nicht zwei Tabellen oder eine, sondern ich meine eine Tabelle (Strg+T)... Ich vermisse händisch eingtragene Beispielergebnisse... Was willst Du ausgegeben haben..?

Die Summenformel hast Du hier aus dem Forum...? Da bin ich gespannt woher... Kannst Du das mal verlinken... die Formel macht m.E. keinen Sinn...!!!!
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi Frank, schau mal hier --> http://www.excelformeln.de/formeln.html?welcher=473 geht das in die richtige Richtung..?
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo Jörg
Formel stammt meine ich aus dem Thread Rangfolge, habe nur die Nachkommastellen gekürzt, will mich aber nicht festlegen.
Strg + T, achso das meinst du habe die unter Tabelle als solche deklariert.
anbei neue Datei
.xlsm   Rangfolge.xlsm (Größe: 18,84 KB / Downloads: 5)
Was ich versuche ist, die Produkte einzeln in Rangfolge zustellen. Ausgabeliste sieht wie in der Tabellendarstellung aus (untereinander). Siehe Tabelle (blau) Spalte F Nicht korrekt
Habe zwei Makro mit eingesetzt. Einfügen und leeren der besagten Zellen
mfg
?mage
to top
#7
Hallo, ich gestehe: Ich verstehe es immer noch nicht... ... meinst du so..?

Arbeitsblatt mit dem Namen 'Auslesen'
 ABCDEF
1  VormittagNachmittaggesamt VerkaufRangfolge
2MontagZitrone1511263
3DienstagZitrone124164
4MittwochZitrone83116
5DonnerstagZitrone67135
6FreitagZitrone2527521
7SamstagZitrone1016262
8MontagApfel  0 
9DienstagApfel  0 
10MittwochApfel  0 
11DonnerstagApfel  0 
12FreitagApfel  0 
13SamstagApfel  0 
14MontagOrange  0 
15DienstagOrange  0 
16MittwochOrange  0 
17DonnerstagOrange  0 
18FreitagOrange  0 
19SamstagOrange  0 

ZelleFormel
E2=WENN(C2*D2;(C2+D2)+ZÄHLENWENN($B$2:B2;B2)%%;0)
F2=WENN(C2*D2;RANG(E2;$E$2:INDEX($E$1:$E$19;VERWEIS(2;1/($E$2:$E$19>0);ZEILE($A$2:$A$19)));0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Hallo Jörg
Tag auch, so Schicht ist Schicht nun hier zum Thema.
Ja, so soll es aussehen. Nur, wie die Formel erweitern um auch die anderen Produkte zu erfassen und in Rangfolge nur bei identischem Namen. Zitronen Rangfolge:Apfel Rangfolge : Orange Rangfolge.
Habe schon mal an Summenprodukt gedacht, aber dort wird ja addiert.
Wie sieht das in VBA aus mit Schleife (oder wie das heisst): Suche zuerst alle Zitronen, setz diese in Rangfolge, ist das geschehn, nimm das nächste Produkt.
Ich weiss ein einfacheres wäre getrennt Tabellenabschnitte, nur die Daten kommen so untereinander zustande.
Auch kann es sein das ein verkaufsoffener Sonntag mal dabei ist. Mit festen Suchbereich wäre das dann wohl nichts, Variable (Matrixen) auf Produktsuche wäre da sinnvoller, aber wie konstruieren.

mfg
und noch Danke für deine Hilfe Jörg
?mage
to top
#9
(14.07.2014, 16:14)WergibtmirRat schrieb: Hallo Jörg
Tag auch, so Schicht ist Schicht nun hier zum Thema.
Ja, so soll es aussehen. Nur, wie die Formel erweitern um auch die anderen Produkte zu erfassen und in Rangfolge nur bei identischem Namen. Zitronen Rangfolge:Apfel Rangfolge : Orange Rangfolge.
Habe schon mal an Summenprodukt gedacht, aber dort wird ja addiert.
...
mfg
und noch Danke für deine Hilfe Jörg

Hallo Frank, ich hatte Dir einen link mitgeschickt. Dort wird mit SUMMENPRODUKT() gearbeitet... ... ansonsten hier mein neuer Vorschlag..:

Arbeitsblatt mit dem Namen 'Auslesen'
 ABCDEF
1  VormittagNachmittaggesamt VerkaufRangfolge
2MontagZitrone1511263
3DienstagZitrone124164
4MittwochZitrone83116
5DonnerstagZitrone67135
6FreitagZitrone2527521
7SamstagZitrone1016262
8MontagApfel115165
9DienstagApfel158232
10MittwochApfel830381
11DonnerstagApfel6286
12FreitagApfel215174
13SamstagApfel116173
14MontagOrange245295
15DienstagOrange3121521
16MittwochOrange2724512
17DonnerstagOrange2116373
18FreitagOrange1217294
19SamstagOrange1513286

ZelleFormatWert
E2026,0001

ZelleFormel
E2=WENN(C2*D2;(C2+D2)+ZÄHLENWENN($B$2:B2;B2)%%;0)
F2=WENN(C2*D2;RANG(E2;INDEX($E$1:$E$19;VERGLEICH(B2;$B$1:$B$19;0)):INDEX($E$1:$E$19;VERWEIS(2;1/($B$2:$B$19=B2);ZEILE($A$2:$A$19)));0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

oder ..:

Arbeitsblatt mit dem Namen 'Auslesen'
 ABCDEF
1  VormittagNachmittaggesamt VerkaufRangfolge
2MontagZitrone1511263
3DienstagZitrone124164
4MittwochZitrone83116
5DonnerstagZitrone67135
6FreitagZitrone2527521
7SamstagZitrone1016262
8MontagApfel  0 
9DienstagApfel  0 
10MittwochApfel  0 
11DonnerstagApfel  0 
12FreitagApfel  0 
13SamstagApfel  0 
14MontagOrange  0 
15DienstagOrange  0 
16MittwochOrange  0 
17DonnerstagOrange  0 
18FreitagOrange  0 
19SamstagOrange  0 

ZelleFormatWert
E2026,0001

ZelleFormel
E2=WENN(C2*D2;(C2+D2)+ZÄHLENWENN($B$2:B2;B2)%%;0)
F2=WENN(C2*D2;RANG(E2;INDEX($E$1:$E$19;VERGLEICH(B2;$B$1:$B$19;0)):INDEX($E$1:$E$19;VERWEIS(2;1/($B$2:$B$19=B2);ZEILE($A$2:$A$19)));0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#10
(14.07.2014, 16:48)Jockel schrieb: ...ich hatte Dir einen link mitgeschickt...
Hallo Jörg, den Link habsch mir schon angeschaut, aber noch nicht die Zeit gehabt das mir zu verinnerlichen bzw. in der Tabelle zu verwenden.

Edit:
habe den Link und die neuen Tabellen gesichtet:
Formel für C2 passt Super
Tabellen sind genau das was gebraucht wird.
Edit End

Danke für die Hilfe, auch diese Tabelle muss ich mir erst anschauen. Hab ein bissel Stress, Töff Töff schnurrt nimmamehr (bin lauter als die neuen Auspuffanlagen der Formel1).
mfg
?mage
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Preisliste mit unterschiedlichen Gültigkeiten ZwergB 4 61 05.12.2016, 17:57
Letzter Beitrag: lupo1
  Wochenzahl ermitteln dindu 5 89 19.11.2016, 11:41
Letzter Beitrag: dindu
  Bewertung einer Rangfolge sharky51 6 172 25.10.2016, 13:37
Letzter Beitrag: sharky51
  Alter des Hundes ermitteln Gurch 5 171 28.09.2016, 19:45
Letzter Beitrag: Gurch
  Mittelwert Indirekt ermitteln Norcoc 10 417 04.09.2016, 22:01
Letzter Beitrag: Norcoc
  Nachtstundenberechnung/zählung mit unterschiedlichen Zuschlägen brutality 10 672 06.07.2016, 21:10
Letzter Beitrag: Ego
  Rangfolge anpassen nach Kategorie (Office 2010) dicken 10 849 19.04.2016, 14:42
Letzter Beitrag: BoskoBiati
  Ist Arbeitszeit ermitteln joerg0606 1 341 06.04.2016, 09:20
Letzter Beitrag: shift-del
  tagescode ermitteln joerg0606 2 369 24.03.2016, 08:24
Letzter Beitrag: BoskoBiati
  Rang ermitteln Helmut0209 2 429 23.02.2016, 18:20
Letzter Beitrag: Helmut0209

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste