Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Summenwerte in feste Werte umwandeln
#1
Einen schönen guten Morgen an alle,
im ersten Augenblick erscheint mein Anliegen in der Betreff Zeile kein Problem.
Aber in meiner Tabelle, die ich hochgeladen habe, sieht es etwas anders aus.
Weitere Informationen sind in der Beispieltabelle "Übung" hinterlegt.
Günther


Angehängte Dateien
.xls   Übung.xls (Größe: 49 KB / Downloads: 4)
to top
#2
Hi Günther,

probier mal so (die Summenbildung in C3 ist überflüssig):

 ABCDE
3  1279 23
4     
5     
610.06.2014100 123 
7Ja  
811.06.201430 153 
9Ja  
1012.06.2014100   
11   
1213.06.201450 303 
13Ja  
1414.06.2014999 1302 
15Ja  
1615.06.2014    
17   
1816.06.2014    
19   

ZelleFormel
C3=SUMME(B6:B25)
D6=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D8=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D10=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D12=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D14=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D16=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D18=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))

ZelleGültigkeitstypOperatorWert1Wert2
C7Liste =$I$2:$I$4 
C9Liste =$I$2:$I$4 
C11Liste =$I$2:$I$4 
C13Liste =$I$2:$I$4 
C15Liste =$I$2:$I$4 
C17Liste =$I$2:$I$4 
C19Liste =$I$2:$I$4 

Wobei sich allerdings die Frage stellt, was mit den Summen in Spalte D /E passieren soll, wenn zwischendrin mal nicht "ja" gewählt ist: Sollen die Werte in Spalte B dann weiter unten mitsummiert werden oder nicht ?
to top
#3
Hallo Kl@us-M.
Danke für Deine Überlegungen, so habe ich mir es vorgestell. Die Summe in Zelle "C3" ist für mich der Gesamtüberblick.
Wenn ich in Spalte "Ja" auswähle, habe ich jetzt Werte die ich weiter nutzen kann. Um "Ja" zu wählen gibt es die unterschiedlichsten Gründe (Ermittlung von Stückzahlen während einer Periode; der Verbrauch an Finanzen usw.). Wichtig ist nur das an einen X-beliebigen Tag (der mit "Ja") bestimmt wird, ein fester Wert erscheint.
Danke für die Antwort, wie gesagt es FUNKTIONIERT!
Günther
to top
#4
Hallo Kl@us-M., die Formeln habe ich in meine Original-Tabelle übertragen. Auch dort funktioniert es Super.
Aber mir ist aufgefallen, dass die Zelle "C3" für mich wichtig ist, denn dort finden sich auch die Überträge aus Januar bis Mai wieder.
=Januar!...+Februar!... usw.
Das habe ich leider vergessen zu erwähnen. Entschuldigung
Gruß
Günther
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Umwandeln von Kleinbuchstaben in Großbuchstaben Matt87 14 159 18.11.2016, 13:28
Letzter Beitrag: Matt87
  Zahl umwandeln herbert0803 11 217 21.10.2016, 16:07
Letzter Beitrag: herbert0803
  Datum umwandeln mabis 13 272 12.10.2016, 08:03
Letzter Beitrag: Jockel
  Werte auf kleinste/größte Werte einer anderen Spalte zuordnen MaxiL 2 234 21.07.2016, 10:24
Letzter Beitrag: MaxiL
  Tilgungsrechner in Jahre statt Monate umwandeln konstantin 3 325 29.06.2016, 10:27
Letzter Beitrag: konstantin
  Datum zurück in eine Zahl umwandeln crichton 8 477 25.05.2016, 14:28
Letzter Beitrag: Jockel
  Werte mit bestimmtem Merkmal andere Werte zuweisen miesi 6 649 20.05.2016, 14:04
Letzter Beitrag: steve1da
  Datum umwandeln Baltic86 9 528 10.05.2016, 13:38
Letzter Beitrag: coemm
  Makro umwandeln und erweitern sveninho11 4 431 31.03.2016, 13:12
Letzter Beitrag: Rabe
  Umwandeln Kanonisches Datum FloKo 9 637 30.03.2016, 20:14
Letzter Beitrag: Castor

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste