Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Erweiterung mit WENN Funktion
#1
Einen schönen guten Morgen an alle Exelfreunde,
Ich habe eine Formel (von Jockel) die ich gern erweitern würde.
Folgende Formel:
=WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1
Mein Wunsch wäre, wenn ich Zelle "C4" ein X einsetze soll als Ergebnis 0,00 betragen.
Diese Option hat sich erst jetzt ergeben.
Zelle "C4" Uhrzeit 7:00
Zelle "C5" Uhrzeit 10:15
Danke für Eure Hilfe
Günther
to top
#2
Hi,

meinst du das so?
=WENN(C4="X";0;WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1)

lg

EDIT.. True, False vertauscht
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 ?mage

to top
#3
hi Günther, da geht doch einfach...:

PHP-Code:
=WENN(C4="x";0;WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1

oder..?
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
Guenther52
to top
#4
Danke Chris-ka, leider nicht,
In Zelle "C4" erfolgen folgende Einträge:
K=Kran; U=Urlaub; F=Feiertag werden diese Kürzel in Zelle "C4" geschrieben muß in Zelle "C6" die gearbeiteten 6,00 Stunden erscheinen.
In Zelle "C4"; X=nicht gearbeitet muß also in Zelle "C6" entweder 0,00 Stunden stehen!
Ansonsten wird die Arbeitszeit als postiv angezeigt. C4=7:00 C5=13:15 ist gleich Zelle C6=0,00
ist die Arbeitszeit kürzer als 6,00 stunden soll sie negativ angezeigt werden.
Gruß
Günther
to top
#5
(25.06.2014, 08:46)Jockel schrieb: hi Günther, da geht doch einfach...:

PHP-Code:
=WENN(C4="x";0;WENN(ODER(C4="U";C4="K";C4="F");$AI$1;WENN(ANZAHL(C4:C5)=2;(C5-C4-$AK$1)*24;0))-$AM$1

oder..?
Es ist einfach nur Super. Für Euch vielleicht einfach, für mich ein Problem!
Danke für die Hilfe!
to top
#6
Vielen dank an alle!
Günther
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Hilfe bei Wenn-Funktion benötigt MichaelaV. 2 24 Heute, 07:45
Letzter Beitrag: MichaelaV.
  Wenn Dann Funktion in Komb. mit Bedingter Formatierung snoopy4000_0 9 92 21.11.2016, 16:19
Letzter Beitrag: snoopy4000_0
  Erweiterung Formel WENN+Zählenwenn Excelmonsta 3 72 17.11.2016, 15:39
Letzter Beitrag: BoskoBiati
  "Wenn"Funktion Maik1010 2 51 11.11.2016, 14:23
Letzter Beitrag: Maik1010
  Summieren und Wenn Funktion Strong 2 68 31.10.2016, 10:20
Letzter Beitrag: coemm
  Formeln (Wenn Funktion) Kickban 4 95 25.10.2016, 13:08
Letzter Beitrag: Kickban
  Hilfe bei WENN- Funktion alnourx 8 190 17.10.2016, 13:47
Letzter Beitrag: alnourx
  Zirkelbezugwarnung bei Wenn Funktion. Thanatos 7 171 14.10.2016, 07:17
Letzter Beitrag: BoskoBiati
Video SVerweis mit Wenn Dann Sonst Funktion Verknüpfung HollyBoy 16 435 14.10.2016, 05:56
Letzter Beitrag: WillWissen
  Verschaltung der Wenn Oder Funktion thecrazykaktus 2 150 09.09.2016, 11:34
Letzter Beitrag: thecrazykaktus

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste