Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Vergleich zweier Tabellen
#1
Hallo liebe Excelianer,

ich versuche mal, mein Problem zu beschreiben.

Ich habe zwei Tabellen (Alt + Neu), die ich miteinander vergleichen will und zwar in folgender Weise:

Ich möchte die Unterschiede zwischen den zwei Tabellen (beide sind aufsteigend sortiert) sehen mit entsprechenden Hinweisen, wo ein Eintrag fehlt.

Ich hoffe, dass ich mich einigermaßen verständlich ausgedrückt habe, ansonsten bitte nachfragen.


Test
BCDEF
2AltHinweis  NeuHinweis
3         
4Name 1    Name 1 
5Name 2    Name 2 
6Name 3fehlt in "neu"  Name 4 
7Name 4    Name 5fehlt in "alt"
8Name 6    Name 6 
9Name 7fehlt in "neu"  Name 9 
10Name 8fehlt in "neu"  Name 10 
11Name 9    Name 11fehlt in "alt"
12Name 10    Name 12 
13Name 12    Name 13 
14Name 13    Name 14fehlt in "alt"
15      Name 15fehlt in "alt"
16      Name 16fehlt in "alt"

Tabellendarstellung in Foren Version 5.26



Wer kann mir da einen Tipp geben, wie man das lösen könnte.
Für Eure Hilfe schon mal vorab besten Dank.

Viele Grüße
Günther

Ich habe Excel 2003 im Einsatz.
Viele Grüße
Günther

(MS Office 2013)
to top
#2
Hi Günther,

hier mal zwei verschiedene Möglichkeiten:

Tabelle1

ABCDE
1Liste altListe aktuellmit VERGLEICHmit ZÄHLENWENN
2Artikel 1Artikel 1
3Artikel 2Artikel 3nicht mehr vorhandennicht mehr vorhanden
4Artikel 3Artikel 50
5Artikel 4Artikel 70nicht mehr vorhandennicht mehr vorhanden
6Artikel 5Artikel 9nicht mehr vorhandennicht mehr vorhanden
7Artikel 6Artikel 11nicht mehr vorhandennicht mehr vorhanden
8Artikel 7Artikel 13nicht mehr vorhandennicht mehr vorhanden
9Artikel 8Artikel 15nicht mehr vorhandennicht mehr vorhanden
10Artikel 9Artikel 17
11Artikel 10Artikel 19nicht mehr vorhandennicht mehr vorhanden
12Artikel 11Artikel 21
13Artikel 12Artikel 23nicht mehr vorhandennicht mehr vorhanden
14Artikel 13Artikel 25
15Artikel 14Artikel 27nicht mehr vorhandennicht mehr vorhanden
16Artikel 15Artikel 29
Formeln der Tabelle
ZelleFormel
C2=WENN(ISTNV(VERGLEICH(A2;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D2=WENN(ZÄHLENWENN($B$2:$B$16;A2);"";"nicht mehr vorhanden")
C3=WENN(ISTNV(VERGLEICH(A3;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D3=WENN(ZÄHLENWENN($B$2:$B$16;A3);"";"nicht mehr vorhanden")
C4=WENN(ISTNV(VERGLEICH(A4;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D4=WENN(ZÄHLENWENN($B$2:$B$16;A4);"";"nicht mehr vorhanden")
C5=WENN(ISTNV(VERGLEICH(A5;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D5=WENN(ZÄHLENWENN($B$2:$B$16;A5);"";"nicht mehr vorhanden")
C6=WENN(ISTNV(VERGLEICH(A6;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D6=WENN(ZÄHLENWENN($B$2:$B$16;A6);"";"nicht mehr vorhanden")
C7=WENN(ISTNV(VERGLEICH(A7;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D7=WENN(ZÄHLENWENN($B$2:$B$16;A7);"";"nicht mehr vorhanden")
C8=WENN(ISTNV(VERGLEICH(A8;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D8=WENN(ZÄHLENWENN($B$2:$B$16;A8);"";"nicht mehr vorhanden")
C9=WENN(ISTNV(VERGLEICH(A9;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D9=WENN(ZÄHLENWENN($B$2:$B$16;A9);"";"nicht mehr vorhanden")
C10=WENN(ISTNV(VERGLEICH(A10;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D10=WENN(ZÄHLENWENN($B$2:$B$16;A10);"";"nicht mehr vorhanden")
C11=WENN(ISTNV(VERGLEICH(A11;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D11=WENN(ZÄHLENWENN($B$2:$B$16;A11);"";"nicht mehr vorhanden")
C12=WENN(ISTNV(VERGLEICH(A12;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D12=WENN(ZÄHLENWENN($B$2:$B$16;A12);"";"nicht mehr vorhanden")
C13=WENN(ISTNV(VERGLEICH(A13;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D13=WENN(ZÄHLENWENN($B$2:$B$16;A13);"";"nicht mehr vorhanden")
C14=WENN(ISTNV(VERGLEICH(A14;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D14=WENN(ZÄHLENWENN($B$2:$B$16;A14);"";"nicht mehr vorhanden")
C15=WENN(ISTNV(VERGLEICH(A15;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D15=WENN(ZÄHLENWENN($B$2:$B$16;A15);"";"nicht mehr vorhanden")
C16=WENN(ISTNV(VERGLEICH(A16;$B$2:$B$16;0));"nicht mehr vorhanden";"")
D16=WENN(ZÄHLENWENN($B$2:$B$16;A16);"";"nicht mehr vorhanden")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
Hi Günther,

hier mit Günters Zählenwenn und bedingter Formatierung:

Tabelle2
ABCDE
1Liste altHinweis Liste aktuellHinweis
2Artikel 1Artikel 1
3Artikel 2fehlt in aktuellArtikel 3
4Artikel 3Artikel 50fehlt in alt
5Artikel 4fehlt in aktuellArtikel 70fehlt in alt
6Artikel 5fehlt in aktuellArtikel 9
7Artikel 6fehlt in aktuellArtikel 11
8Artikel 7fehlt in aktuellArtikel 13
9Artikel 8fehlt in aktuellArtikel 15
10Artikel 9Artikel 17fehlt in alt
11Artikel 10fehlt in aktuellArtikel 19fehlt in alt
12Artikel 11Artikel 21fehlt in alt
13Artikel 12fehlt in aktuellArtikel 23fehlt in alt
14Artikel 13Artikel 25fehlt in alt
15Artikel 14fehlt in aktuellArtikel 27fehlt in alt
16Artikel 15Artikel 29fehlt in alt
Bedingte Formatierung Fülleffekte, Symbole, Farbskalen
werden in dieser Tabelle nicht dargestellt
Schriftart wird in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel Bereich N/A
B2:B16=WENN(ZÄHLENWENN($D$2:$D$16;A2);"";"fehlt in aktuell")
E2:E16=WENN(ZÄHLENWENN($A$2:$A$16;D2);"";"fehlt in alt")

Bedingte Formatierung Haupttabelle 1
Zelle   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$A$2:$A$1601.Bed.: Formel ist=$B2<>""49407       2A2:A16
$D$2:$D$1601.Bed.: Formel ist=$E2<>""49407       2D2: D16


Schriftformate
Zelle Rot Grün Blau Color Stil Unterstreichung Effekte Durchgestrichen Schriftart
A1:E1 0000Fett  
Zellen mit Schriftformatierung automatisch werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 17.27 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#4
Hallo Günther,

hier mal noch eine Formellösung mit ZÄHLENWENN. Um die Berechnung der ZELLEN bei fehlenden NAMEN korrekt auszuführen, habe ich noch eine Bedingung hinzugefügt. WAHR und FALSCH sind intern auch Zahlenwerte, dadurch kann man das auch so verwenden und benötigt keine ausgeschriebene WENN-FUNKTION. Du kannst ja in Excel Zahlen durch benutzerdefinierte FORMATE formatieren oder wie in diesem Beispiel auch verbergen. Unten habe ich gleich noch die SUMME gebildet. Mit ANZAHL2 habe ich Zelleinträge von der Gesamtzahl der verwendeten ZELLEN abgezogen. Die Formeln und Formate von B3 und E3 musst Du bis Zeile 15 ziehen.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
1AltHinweis NeuHinweis
2     
3Name 1  Name 1 
4Name 2  Name 2 
5Name 3Fehlt in neu Name 4 
6Name 4  Name 5Fehlt in alt
7Name 6  Name 6 
8Name 7Fehlt in neu Name 9 
9Name 8Fehlt in neu Name 10 
10Name 9  Name 11Fehlt in alt
11Name 10  Name 12 
12Name 12  Name 13 
13Name 13  Name 14Fehlt in alt
14   Name 15Fehlt in alt
15   Name 16Fehlt in alt
16Übereinstimmungen:8 Übereinstimmungen:8

ZelleFormatWert
B3"";"";"Fehlt in neu"1
E3"";"";"Fehlt in alt"1

ZelleFormel
B3=ZÄHLENWENN($D$1:$D$15;A3)+(A3="")
E3=ZÄHLENWENN($A$1:$A$15;D3)+(D3="")
B16=SUMME(B3:B15)-(13-ANZAHL2(A3:A15))
E16=SUMME(E3:E15)-(13-ANZAHL2(D3:D15))
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#5
Hallo zusammen,
vielen Dank für die verschiedenen Lösungen. Ihr habt mir sehr geholfen.
Bis bald mal wieder, viele Grüße
Günther
Viele Grüße
Günther

(MS Office 2013)
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Automatische Sortierung zweier Werte Firason 5 97 16.11.2016, 17:54
Letzter Beitrag: shift-del
  Hilfe bei Vergleich zweier relativer Häufigkeiten - Komplexe Formel j_wishbow 14 289 28.10.2016, 11:19
Letzter Beitrag: schauan
  Sortierte Zusammenführung zweier Tabellen donfellone 3 63 21.10.2016, 07:41
Letzter Beitrag: donfellone
  Differenz zweier Datumswerte Toni-S 9 280 21.09.2016, 18:04
Letzter Beitrag: Toni-S
  Vergleich von zwei Tabellen / Ausgabe von Unikaten limo91 8 310 12.08.2016, 08:02
Letzter Beitrag: limo91
  Abgleich zweier Tabellenblätter und kopieren von Hyperlinks som3on3 4 427 10.06.2016, 12:49
Letzter Beitrag: schauan
  Zellen zweier Tabellenblätter automatisch in ein drittes Tabellenblatt kopieren Moe 1 298 27.05.2016, 18:40
Letzter Beitrag: steve1da
  Anzahl Differenzen zweier Spalteninhalte st3inadler 8 635 10.05.2016, 14:57
Letzter Beitrag: shift-del
  Differenz zweier Zahlen parylam 3 386 25.02.2016, 11:14
Letzter Beitrag: parylam
  Excel Formel Vergleich zweier Spalten und Summe skyflower01 7 1.219 28.12.2015, 10:40
Letzter Beitrag: skyflower01

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste