Arbeitszeiterfassung über Exel
#1
Guten Tag zusammen,

ich hätte da ein kleines Anliegen und vielleicht kann mir da jemand helfen.

Ich hab eine Tabelle erstellt um Arbeitszeiten von meinen Mitarbeitern zu erfassen um einen Stundenüberblick zu haben.

Dieses funktioniert auch einwandfrei und zieht mir die Pausen gleich ab:

=(REST(H4-G4;1)-(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24)

G4 ist die Anfangszeit und H4 Arbeitsende, in I4 steht die oben genannte Formel.

Jetzt möchte ich aber zusätzlich Urlaub und Krank einpflegen und hab es mal so versucht:

=WENN(ODER(G4="U";H4="K");8,5/24;(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24)

Jetzt macht er mir zwar Automatisch bei U und K die die gewünschten Stunden, aber falls ich Zeiten eintrage nicht mehr die zweite Formel.

Bin kein Exelprofi, ich lese viel nach aber find hierzu nichts passendes. Wenn ihr Ideen habt um es lösen, wäre ich ziemlich dankbar Smile
Antwortento top
#2
Hallo,

ohne jetzt die Formeln genauer analyisert zu haben - der zweite Teil der Formeln unterscheidet sich:

=(REST(H4-G4;1)-(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24)

ist etwas anderes wie

(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24)

Ist das so gewollt?
Gruß
Peter
Antwortento top
#3
(05.07.2016, 13:44)Tubu17 schrieb: Guten Tag zusammen,

ich hätte da ein kleines Anliegen und vielleicht kann mir da jemand helfen.

Ich hab eine Tabelle erstellt um Arbeitszeiten von meinen Mitarbeitern zu erfassen um einen Stundenüberblick zu haben.

...

Jetzt macht er mir zwar Automatisch bei U und K die die gewünschten Stunden, aber falls ich Zeiten eintrage nicht mehr die zweite Formel.

Bin kein Exelprofi, ich lese viel nach aber find hierzu nichts passendes. Wenn ihr Ideen habt um es lösen, wäre ich ziemlich dankbar :)

Hallo, hast du da nicht was vergessen..:

=WENN(ODER(G4="U";H4="K");8,5/24;(REST(H4-G4;1)-(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24))
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#4
(05.07.2016, 14:42)Peter schrieb: Hallo,
...
Ist das so gewollt?

Hallo Peter, ich denke nicht...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#5
(05.07.2016, 14:42)Peter schrieb: Hallo,

ohne jetzt die Formeln genauer analyisert zu haben - der zweite Teil der Formeln unterscheidet sich:

=(REST(H4-G4;1)-(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24)

ist etwas anderes wie

(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24)

Ist das so gewollt?

Wie gesagt absolut kein Exel Junki. Gewollt ist das bis 6 Stunden keine Pause abgezogen wird, ab 6 Stunden 30 Minuten, ab 9 Stunden 45 Minuten
und bei einem K/U im Ergebnisfeld 8,5 Stunden ausgefüllt wird.
Antwortento top
#6
Hallo, ich habe das so verstanden..:

=WENN(ODER(G3="U";H3="K");8,5/24;(REST(H3-G3;1)-VERWEIS(KÜRZEN(C3*24);{0;6;9};{0;0,5;0,75})/24))
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#7
Hi Jörg,

Tubu schrieb ja, dass er/sie in Excel nicht fit ist. Ich denke mal, dass er/sie deine erste Formel besser verstehen wird. Ich habe diese mal in einen Tabellenausschnitt gepackt.

Tabelle1

GHI
3BeginnEndeArb.-Zeit
407:0017:0009:15
507:0015:3008:00
607:0013:0006:00
7U08:30
8k08:30
Formeln der Tabelle
ZelleFormel
I4=WENN(ODER(G4="U";G4="k");8,5/24;(REST(H4-G4;1)-(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Tubu17
Antwortento top
#8
Hallo Günter, aber sie rechnet falsch... ... guck mal in Zeile 6 Ich dachte ab 6 Std. Arbeit sollte eine halbe Std. Pause abgezogen werden...


Zitat:Tubu17
Wie gesagt absolut kein Exel Junki. Gewollt ist das bis 6 Stunden keine Pause abgezogen wird, ab 6 Stunden 30 Minuten, ab 9 Stunden 45 Minuten
und bei einem K/U im Ergebnisfeld 8,5 Stunden ausgefüllt wird.
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#9
(05.07.2016, 15:46)WillWissen schrieb: Hi Jörg,

Tubu schrieb ja, dass er/sie in Excel nicht fit ist. Ich denke mal, dass er/sie deine erste Formel besser verstehen wird. Ich habe diese mal in einen Tabellenausschnitt gepackt.

Tabelle1

GHI
3BeginnEndeArb.-Zeit
407:0017:0009:15
507:0015:3008:00
607:0013:0006:00
7U08:30
8k08:30
Formeln der Tabelle
ZelleFormel
I4=WENN(ODER(G4="U";G4="k");8,5/24;(REST(H4-G4;1)-(REST(H4-G4;1)>6/24)*0,5/24-(REST(H4-G4;1)>9/24)*0,25/24))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Perfekt jetzt geht's wie ich es wollte Smile
Antwortento top
#10
(05.07.2016, 16:07)Tubu17 schrieb: Perfekt jetzt geht's wie ich es wollte Smile

Hallo, da hast du aber was anderes geschrieben...

Arbeitsblatt mit dem Namen 'Tabelle2 (2)'
 GHIJ
307:0012:595:595:59
407:0013:005:306:00
507:0013:306:006:00
607:0017:009:159:15
707:0016:008:158:30
807:0015:598:298:29
9u 8:308:30
10 k8:308:30
11  0:000:00

ZelleFormel
I3=WENN(ODER(G3="U";H3="K");8,5/24;(REST(H3-G3;1)-VERWEIS(KÜRZEN(C3*24);{0;6;9};{0;0,5;0,75})/24))
J3=WENN(ODER(G3="U";H3="k");8,5/24;(REST(H3-G3;1)-(REST(H3-G3;1)>6/24)*0,5/24-(REST(H3-G3;1)>9/24)*0,25/24))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste