Anzahl der verschiedenen Kunden pro Jahr berechnen
#1
Hallo zusammen,

ich habe ein Problem, das mich fast zur Verzweiflung treibt:
In meiner Excelliste, möchte ich überprüfen möchte, wie viele Kunden pro Jahr bestellt haben. Dazu habe ich eine Spalte (A) mit Kundennummer und eine Spalte (B) mit dem Bestelldatum.

In einer separaten Spalte (F) steht die Jahreszahl, auf die Bezug genommen werden soll (Wie viele verschiedene Kunden (NICHT wie viele Bestellungen) haben im Jahr 2015 bestellt).

Normalerweise verwende ich hierfür das Summenprodukt, aber anders als sonst, bekomme ich einfach nicht die korrekten Werten.

Code:
=SUMMENPRODUKT((JAHR(B2:B26)=F14)*((A2:A26<>"")/ZÄHLENWENN(A2:A26;A2:A26&"")))

Kann mir jemand sagen, wo mein Denkfehler liegt?


Vielen Dank
Lester72


Angehängte Dateien
.xlsx   Excel-Problem.xlsx (Größe: 13,01 KB / Downloads: 6)
Antwortento top
#2
Hallo

Das wäre mein Vorschlag.
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1KundennummerBestelldatum      
22053422.06.201420534-2014Ergebnis >    
32053412.06.201520534-2015    
42053413.06.201520534-2015    
52541613.06.201525416-2015    
62232622.06.201522326-2015    
72447922.06.201524479-2015    
81587203.06.201615872-2016    
92053403.06.201620534-2016    
102053403.06.201620534-2016    
112053403.06.201620534-2016    
122053406.06.201620534-2016 01.01.201401.01.201501.01.2016
132053407.06.201620534-2016 31.12.201431.12.201531.12.2016
142148110.06.201621481-2016 201420152016
152232613.06.201622326-2016Soll1411
162232613.06.201622326-2016Ist1411
172541616.06.201625416-2016    
182541622.06.201625416-2016    
192541722.06.201625417-2016    
202562122.06.201625621-2016    
212576622.06.201625766-2016    
222576626.06.201625766-2016    
232576627.06.201625766-2016    
243037628.06.201630376-2016    
253237928.06.201632379-2016    
263282829.06.201632828-2016    

ZelleFormel
F16{=SUMME(WENNFEHLER(1/ZÄHLENWENNS($C$2:$C$26;$C$2:$C$26;$B$2:$B$26;">="&DATUM(F14;1;1);$B$2:$B$26;"<="&DATUM(F14;12;31));0))}
C2=A2&"-"&JAHR(B2)
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Lester72
Antwortento top
#3
Super, vielen Dank für den Ansatz, hat wunderbar funktioniert!

VG
Simeon
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste