Komplexe Abfrage die zweite
#1
Lightbulb 
Hallo,

ich benötige noch einmal die Hilfe von ein paar Spezialisten.

Das Ziel ist:

WENN
  • AP = AP
UND
  • TYP = TYP
UND
  • TP <> TP
DANN
  • Ergebnis: Gib Anzahl der unterschiedlichen TP zurück
SONST
  • Ergebnis: 0
Das Problem ist hier das erwartete Dann Ergebnis. Bei der ursprünglichen Formel hat mir hier in dem Forum bereits jemand geholfen:
Code:
=ZÄHLENWENNS(A$2:A$8;A2;B$2:B$8;"<>"&B2;C$2:C$8;C2)

Um die unterschiedliche Anzahl an Werten innerhalb einer Spalte zu ermitteln habe ich folgende Formel benutzt:


Code:
=SUMME(1/ZÄHLENWENN(B2:B8;B2:B8))

Aber leider bekomme ich es nicht hin beides zu kombinieren.

Denn immerhin möchte ich ja nur das Ergebnis nach der vorherigen Einschränkung. Sprich ich möchte nur die Anzahl unterschiedlicher TP wo der AP und TYP gleich ist.

Ich bin für jede Hilfe äußerst dankbar.

Vielen Dank.

Liebe Grüße

Socimy


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 12,53 KB / Downloads: 3)
Antwortento top
#2
Hola,

beim letzten Mal gabs immerhin eine Beispieldatei ;-)

Gruß,
steve1da
Antwortento top
#3
Sorry, hatte vergessen auf Attachment hinzufügen zu klicken.

Ausgewählt hatte ich sie bereits. ^^

Outlook-geschädigt halt. Big Grin
Antwortento top
#4
Hola,


Code:
=SUMMENPRODUKT((VERGLEICH($A$2:$A$8&$B$2:$B$8&$C$2:$C$8;$A$2:$A$8&$B$2:$B$8&$C$2:$C$8;0)=ZEILE($2:$8)-1*($A$2:$A$8=A2)*($B$2:$B$8<>"")*($C$2:$C$8=C2))*1)

siehe auch: http://www.excelformeln.de/formeln.html?welcher=334

Gruß,
steve1da
Antwortento top
#5
Hallo steve1da

vielen lieben dank.

Das funktioniert wunderbar.

Ich habe das ganze jetzt noch mit einer WENN-DANN-Abfrage kombiniert um die 1er Werte auf 0 zu bekommen.


Code:
=WENN(SUMMENPRODUKT((VERGLEICH($A$2:$A$8&$B$2:$B$8&$C$2:$C$8;$A$2:$A$8&$B$2:$B$8&$C$2:$C$8;0)=ZEILE($2:$8)-1*($A$2:$A$8=A2)*($B$2:$B$8<>"")*($C$2:$C$8=C2))*1)>1;SUMMENPRODUKT((VERGLEICH($A$2:$A$8&$B$2:$B$8&$C$2:$C$8;$A$2:$A$8&$B$2:$B$8&$C$2:$C$8;0)=ZEILE($2:$8)-1*($A$2:$A$8=A2)*($B$2:$B$8<>"")*($C$2:$C$8=C2))*1);0)


Dann passt das ganze. Smile

Nochmal vielen Dank.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste