Komplizierte Zählfunktion mit Mittelwert
#1
Moin Moin,

 ich habe derzeit ein Problem bei einer komplizierten Zählfunktion.
Ich habe euch zum besseren Verständnis die Mappe angehängt.

In Spalte A befinden sich einzigartige Nummern für Erfinder. 
Die Spalte B ist für die Berechnungen nicht relevant.
In Spalte E werden den Erfindern die jeweiligen Patente zugeordnet, an denen sie gearbeitet haben.
In Spalte H wird nun jedem Patent eine bestimmte Radikalität zugeordnet.

Mein Ziel: Die durchschnittliche Radikalität der Patente, an denen ein Erfinder gearbeitet hat.
Der Weg: Ich möchte für jeden Erfinder nachschauen, welche Patente ihm in den Spalten E und D zugeordnet worden sind.
Dann sollen die Radikalitätswerte dieser Patente addiert und durch die Anzahl der Patente geteilt werden und in der dazugehörigen Spalte C eingetragen werden.

Da dem 1. Erfinder kein Patent zugeordnet wurde ist der 1. Wert 0
Für den 2. Erfinder sind 3 Einträge (mit dem selben Patent, ich weiß das ist verwirrend) vorhanden. In der Zelle H67 findet sich die dazugehörige Radikalität von 2.

Ich habe schon versucht mit PowerQuery Abfragen zu erstellen, kriege das aber nicht hin.
Der Weg ist mir persönlich egal, ob Formel, VBA, oder PowerQuery.

Wie kann ich mein Ziel erreichen?

Beste Grüße,
MahadmaKandis


Angehängte Dateien
.xlsx   Hypothese_2 Forum.xlsx (Größe: 595,35 KB / Downloads: 7)
Antwortento top
#2
(03.07.2016, 16:22)Mahadmakandis schrieb: Moin Moin,

 ich habe derzeit ein Problem bei einer komplizierten Zählfunktion.
Ich habe euch zum besseren Verständnis die Mappe angehängt.
...
Ich habe schon versucht mit PowerQuery Abfragen zu erstellen, kriege das aber nicht hin.
Der Weg ist mir persönlich egal, ob Formel, VBA, oder PowerQuery.

Wie kann ich mein Ziel erreichen?

Beste Grüße,
MahadmaKandis

Hallo, das habe ich die Tage schon mal gesehen, hier..? In einem anderen Forum... Gab's da keine Antwort..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#3
Moin Jockel,

von mir kam diese Frage noch nicht. Auch bin ich in keinem anderen Excel-Forum angemeldet.
Über die SuFu habe ich natürlich auch Themen zum Thema Zählen gefunden aber mein Anliegen scheint eine Verschachtelung mehrerer Funktionen zu sein.
Die ZÄHLENWENN Funktion ist mir auch nicht unbekannt, nur das kombinieren bekomme ich nicht hin.

Beste Grüße,
MahadmaKandis
Antwortento top
#4
Morrn, MahatmaKandis;
die Matrixformel in/für C lautet:
C2[:C334]: {=WENNFEHLER(RUNDEN(MITTELWERT(WENN(G$2:G$201=MTRANS(WENN(E$2:E$741=A2;D$2:D$741;""));H$2:H$201;""));1);0)}
Gruß, Castor
[-] Folgende(r) 1 Benutzer sagt Danke an Castor für diesen Beitrag:
  • Mahadmakandis
Antwortento top
#5
Moin Castor,

vielen Dank, passt alles perfekt!

Beste Grüße,
MahadmaKandis
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste