Problem mit ISTFEHLER
#1
Hallo zusammen,

ich verzweifel gerade daran, in diese Formel ISTFEHLER einzubauen.
Code:
=WENN(VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);SVERWEIS($B10;'Filiale-Menge-2015'!$A$1:$BF$463;VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);0);"")

Die Formel funktioniert so, wie sie soll aber da durch fehlende Daten sehr oft #NV ausgegeben wird, will ich diese ausblenden.
Eine bedingte Formatierung (z.B. ISTFEHLER und weiße Schriftfarbe) kommt leider nicht in Frage.
Ich habe jetzt zig Anläufe gestartet, erhalte aber immer wieder eine Fehlermeldung, dass mit der Formel etwas nicht stimmt.

Gruß Marcus
Antwortento top
#2
Hola,


Zitat:dass mit der Formel etwas nicht stimmt.


perfekte Fehlerbeschreibung ;-)



Code:
=wennfehler(Deine_Formel;"")


Gruß,
steve1da
Antwortento top
#3
Zitat:perfekte Fehlerbeschreibung ;-)

19  Sorry, die Standard-Fehlermeldung halt, wenn man ein Zeichen vergisst o.ä.

Aber mein Ansatz war ja eh schon nicht richtig... Mit wennfehler geht es einwandfrei.

Vielen Dank für deine Hilfe!

Gruß Marcus
Antwortento top
#4
Hallo,

dann reicht aber schon das:


Code:
wennfehler(SVERWEIS($B10;'Filiale-Menge-2015'!$A$1:$BF$463;VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);0);"")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
(29.06.2016, 11:00)BoskoBiati schrieb: Hallo,

dann reicht aber schon das:


Code:
wennfehler(SVERWEIS($B10;'Filiale-Menge-2015'!$A$1:$BF$463;VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);0);"")

Hallo Edgar,

habe das gerade mal probiert. Funktioniert auch, aber dann verschiebt sich der Spaltenindex. Die Werte passen also nicht mehr.
Der 1. Vergleich deckt mein 2. Suchkriterium ab, welches sich über mehrere Spalten erstreckt.
Ich kann die Tabelle leider nicht anhängen, da sie Geschäftsdaten enthält.

Trotzdem Danke! Wink

Gruß Marcus
Antwortento top
#6
Hallo,


das ist Deine Formel, von mir nur kopiert!!!!!!! Der erste Vergleich gibt entweder eine Zahl oder ein #NV zurück. Also ist das Ergebnis der Formel entweder #NV oder der Wert aus dem SVERWEIS. Der Dann-Teil wird nie erfüllt. Daher reicht meine Formel vollkommen aus!
Der Fehler liegt schon darin, dass der SVERWEIS nicht so viele Spalten hat, wie der Vergleich!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Hallo,

1. Vergleich: 1 von 2 Suchkriterien
2. Vergleich: Variabler Spaltenindex des SVerweises

 
Zitat:Der Fehler liegt schon darin, dass der SVERWEIS nicht so viele Spalten hat, wie der Vergleich!

Selbst wenn ich die Spalten anpasse, verschiebt sich der Index.
Ist aber auch nicht schlimm. Mit der Lösung von steve1da funktioniert ja alles, wie es soll.
Ich behaupte auch nicht, dass sich meine Formel nicht vereinfachen lässt, aber ohne die Datei anzuhängen, kann man das sicher nur schwer nachvollziehen.
Ich bin dir trotzdem für deine Hilfe dankbar! Wink
Gruß Marcus
Antwortento top
#8
Hallo,

da der 1.Vergleich und der 2.Vergleich identisch sind, kann das alles nicht sein!


Zitat:Mit der Lösung von steve1da funktioniert ja alles, wie es soll.

Nein, es werden nur die Fehler, die in der Formel stecken, vertuscht!!!

Hier mal ein Beispiel:

[html]
Arbeitsblatt mit dem Namen 'Tabelle2'
 BCLMN
8  543789653
9     
10ABC17#BEZUG!135 
11DEF#NV#NV#NV 
12XYZ20#BEZUG!111 
13rcf25#BEZUG!147 
14     
15ABC17 135 
16DEF    
17XYZ20 111 
18rcf25 147 
19     
20ABC17 135 
21DEF    
22XYZ20 111 
23rcf25 147 

ZelleFormel
C10=WENN(VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);SVERWEIS($B10;'Filiale-Menge-2015'!$A$1:$BF$463;VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);0);"")
C15=WENNFEHLER(WENN(VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);SVERWEIS($B15;'Filiale-Menge-2015'!$A$1:$BF$463;VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);0);"");"")
C20=WENNFEHLER(SVERWEIS($B10;'Filiale-Menge-2015'!$A$1:$BF$463;VERGLEICH(L$8;'Filiale-Menge-2015'!$A$1:$BZ$1;0);0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
[/html]

Mit der Datentabelle:


[html]
Arbeitsblatt mit dem Namen 'Filiale-Menge-2015'
 ADBFBM
1 543653789
2ABC17135281
3xyz20111256
4rcf25147233
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
[/html]
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9
Da ich alle Tabellen vorliegen habe und die ausgelesenen Daten mit denen der Originaltabelle übereinstimmen, muss da wohl irgendwas richtig sein!
Das wennfehler nutze ich nur dazu, um bei nicht vorhandenen (Artikel war in dem Jahr noch nicht gelistet) Daten das #NV auszublenden.
Dient rein der Lesbarkeit von ca. 60.000 Zellen.
Antwortento top
#10
Hallo,

da meine Formel in meiner Tabelle das gleiche Ergebnis bringt, wie die anderen, kann also Deine Aussage mit dem verschobenen Spaltenindex nicht stimmen!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste