Auswertung von Kundendaten
#1
Hallo zusammen,

ich bin neu hier im Forum und habe mich angemeldet weil ich ein kleines Problem mit einer Auswertung von Kundendaten

bei Excel 2013 habe.

Ich habe eine Tabelle in der erhaltene Summen von Kunden nach Jahr und Kalenderwoche aufgelistet sind (siehe bild im Anhang). 
Es soll mit einer Formel das Geld nach Kunde und jahr getrennt aufsummiert werden. Dabei bereitet mir das Format des zeitraums Probleme,
dies ist aber festgelegt und kann nicht geändert werden (Jahr-KW also 2016-1).
ich möchte das wie folgt aufbauen

Summiere den Betrag aus Spalte B auf, wenn Spalte A mit 2016 beginnt und in Spalte C Kunde 1 steht. 

Für Kunde 1 sollte dann für 2015 160€ rauskommen, für Kunde 2 in 2015 250€ usw. 

die summewenns funktion habe ich schon gefunden, um mehrere Bedingungen festzulegen, aber ich bekomme es nicht hin, dass Excel aus Spalte A nur die ersten 4 Zahlen opder Zeichen
ausliest. 
Den Links befehel habe ich auch schon ausprobiert, der scheint aber nicht über eine komplette spalte zu funktionieren, sonder nur für einzelne zellen. 

mein bisheriger Versuch war =summewenns(B:B;A:A; Links(A:A;4)=2015;C:C;Kunde 1)
das funktioniert aber nicht. Denke das liegt am links Befehl.

kan mir jemand dabei weiterhelfen?

Vielen Dank im vorraus


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,


Code:
=SUMMENPRODUKT((LINKS(A2:A10;4)="2015")*(C2:C10="kunde 1")*(B2:B10))


Gruß,
steve1da
Antwortento top
#3
Hallo,

alternativ:

Eine Hilfsspalte mit =Links(A2;4) verwenden um nur das Jahr auszugeben und dann einfach eine Auswertung mit einer Pivottabelle machen.

Sollte es sich in der Spalte A um ein benutzerdefiniertes Datum handeln könnte man die Auswertung auch ohne Hilfsspalte erstellen.
Gruß
Peter
Antwortento top
#4
Smile 
@Steve1da:
Vielen Dank, dein Weg funktioniert prima. Das hat mir einen haufen arbeit erspart, danke  28

@Peter
Es handelt sich um ein vorgegebenes Datumsformat, das nicht verändert werden soll.
Dein Weg funktioniert zwarauch, ich finde das mit der Hilfsspalte allerdings etwas unschön.
Trotzdem danke Smile
Antwortento top
#5
Nur anders geschrieben:


Code:
=SUMPRODUCT((LEFT(A2:A11;4)&C2:C11="2015kunde 1")*(B2:B11))
Antwortento top
#6
(22.06.2016, 11:26)Phinehas schrieb: Dein Weg funktioniert zwarauch, ich finde das mit der Hilfsspalte allerdings etwas unschön.

Hi,

Hilfsspalten müssen ja nicht stehenbleiben. Wenn sie stören, einfach ausblenden oder sogar auf einem separaten Tabellenblatt oder in einem Bereich weit außerhalb des Sichtbereichs anlegen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#7
Hallo snb,

keine Kritik nur ein Hinweis Smile

Tipp:
füge doch die deutsche Syntax ein, wenn du willst auch zusätzlich mit der englischen Syntax.
Die meisten Fragesteller können wahrscheinlich mit den eng. Formelbezeichnungen nichts anfangen.

nutze z.B
http://de.excel-translator.de/translator/

Ich bin selber auch in engl. Foren ab und zu unterwegs, dort würden die Fragesteller mit einer deutschen Syntax auch keine Freude haben.
z.B http://answers.microsoft.com/en-us/offic...c7b03f55aa

lg
Chris
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 ?mage

[-] Folgende(r) 1 Benutzer sagt Danke an chris-ka für diesen Beitrag:
  • Jockel
Antwortento top
#8
(22.06.2016, 12:35)chris-ka schrieb: Hallo snb,

keine Kritik nur ein Hinweis Smile

Tipp:
füge doch die deutsche Syntax ein, wenn du willst auch zusätzlich mit der englischen Syntax.
Die meisten Fragesteller können wahrscheinlich mit den eng. Formelbezeichnungen nichts anfangen.

nutze z.B
http://de.excel-translator.de/translator/

Ich bin selber auch in engl. Foren ab und zu unterwegs, dort würden die Fragesteller mit einer deutschen Syntax auch keine Freude haben.
z.B http://answers.microsoft.com/en-us/offic...c7b03f55aa

lg
Chris

Hallo Chris, ich glaube das ist vergebene "Liebesmüh"...

... snb könnte den link zum Translator ja in die Signatur hier einfügen... (^_-)
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#9
Hallo, was spricht gegen DBSUMME()..?

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1Jahr-KWBetragKunde Jahr-KWKundeBetrag 
22015-1100Kunde 1 2015*Kunde 1160160
32015-150Kunde 2     
42015-260Kunde 1     
52015-2200Kunde 2     
62016-1250Kunde 3     
72016-1300Kunde 4     
82016-2160Kunde 3     
92016-2250Kunde 4     
102017-1150Kunde 5     
112017-1350Kunde 6     
122017-2300Kunde 5     
132017-240Kunde 6     

ZelleFormel
G2=DBSUMME(A1:C13;2;E1:F2)
H2=SUMMENPRODUKT((LINKS(A2:A10;4)="2015")*(C2:C10="kunde 1")*(B2:B10))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#10
@Chris

Wenn der TS seriös ist, will er/sie  jedes Antwort analysieren und verstehen bevor an zu wenden.
Und eine Übersetzung darf dann doch kein Problem sein !?
Ich möchte vermeiden das Vorschläge nur kopiiert werden.
Und allerdings ist VBA völlig Amerikanisch.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste