Zählfunktion mit Bedingung
#1
Hallo Leute,

ich suche eine Formel mit der ich im Bild beschriebenes Problem lösen kann. Ich habe es schon mit der ZÄHLENWENN Funktion und nur WENN Funktion versucht, auch als Matrixformel, aber irgendwie will das nicht so ganz klappen 39

Kann mir hier jemand helfen? Falls das Problem noch unverständlich sein sollte, einfach fragen 43


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

für die erste Prüfung:


Code:
=SUMMENPRODUKT((($B$9:$B$19=B3)+($D$9:$D$19=B3))*($E$9:$E$19=5))


Gruß,
steve1da
Antwortento top
#3
Dankeschön, hat funktioniert 19 

Kannst du bitte noch ne kleine Erläuterung schreiben? Will ja nicht nur kopieren, sondern es auch verstehen Wink

Steht das + quasi für ODER und das * für UND? Und warum werden dabei die Zeilen gezählt?
Antwortento top
#4
Hola,

+ = ODER
* = UND

Es wird die Anzahl der Zeilen gezählt, die entweder in B oder D die gesuchte Buchstabenkombination habe und gleichzeitig in E die Zahl 5.

Gruß,
steve1da
Antwortento top
#5
Super, vielen Dank!
Antwortento top
#6
Hallo,

als kleine Ergänzung: Sehr hilfreich beim Nachvollziehen von Formeln ist in XL auch die Formelauswertung die sich im Menü Formeln befindet.

Hier kannst du die Formelberechnung Schritt für Schritt nachvollziehen.
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste