Excel 2010 Index Vergleich
#1
Hallo Zusammen

Ich habe folgendes Problem. Ich muss zwei Tabellenblätter mit einander vergleichen. Dies möchte ich via Matrix Index Vergleich vollziehen. Die Abstimmung ist aber an zwei Bedingungen geknüpft und wenn eine genaue Übereinstimmung stimmt sollte in der Tabelle1 "okay" erscheinen.

Leider bin ich nicht sehr visiert in diesem Bereich, kann mir jemand helfen. Ich habe eine Exceldatei angehängt mit den zwei Tabellenblätter. Die Abstimmung betrifft die PersNr und ArtikelNr diese müssen geprüft werden bzw. sollten übereinstimmen. Dann muss auf der Tabelle1 "Okay" erscheinen.

Besten Dank für Ihre Mithilfe
Freundliche Grüsse
gweste


Angehängte Dateien
.xlsx   Test_16062016.xlsx (Größe: 13,65 KB / Downloads: 6)
Antwortento top
#2
Hallo,

da beide Tabellen gleich sortiert sind, war in der Beispiel-Datei ausreichend:


Code:
=WENN(A2=Tabelle1!A2;"";"Fehler")


Sowohl in Spalte A als auch in B gibt es keine Unterschiede.


Reicht das?

mfg
[-] Folgende(r) 1 Benutzer sagt Danke an Fennek für diesen Beitrag:
  • gweste
Antwortento top
#3
Hi,

ich würde es mit ZÄHLENWENNS lösen:

Tabelle1

ABCDEF
1PersNr.ArtikelNameVornameGebDatum
2118044062137-4400MusterHans08.06.1963okay
3124049301251-3020MusterHans17.07.1951nicht okay
4127039357629-3431MusterHans09.03.1953okay
5156001222408-3210MusterHans29.07.1961okay
6162025209879-4290MusterHans12.03.1951nicht okay
7162041179301-3077MusterHans07.12.1958okay
8162062162162-3201MusterHans07.02.1963okay
Formeln der Tabelle
ZelleFormel
F2=WENN(ZÄHLENWENNS(Tabelle2!A:A;A2;Tabelle2!B:B;B2)=1;"okay";"nicht okay")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Tabelle2

ABCDE
1PersNr.ArtikelNameVornameGebDatum
2118044062137-4400MusterHans08.06.1963
3118044301251-3020MusterHans17.07.1951
4127039357629-3431MusterHans09.03.1953
5156001222408-3210MusterHans29.07.1961
6162025209879-5290MusterHans12.03.1951
7162041179301-3077MusterHans07.12.1958
8162062162162-3201MusterHans07.02.1963

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

In Zeile 3 und 6 habe ich zur Veranschaulichung zwei Zahlen verändert.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • gweste
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste